Previous 1 2 3 4 5 6 Next 189 Replies Latest reply: Apr 28, 2016 12:20 PM by Patrick1982 Go to original post Branched to a new discussion.
  • Desigurl03 Level 1 Level 1

    I have been having the same issue with my computer and the only time I could connect to the internet was when my Firewall was off. I was luckily still under warranty so I called apple care today and she told me these steps that fixed my problem. When you are at your desktop screen go to the tab labeled "GO" and click on Computer. Once you are there follow these steps:


    1. Click on Macintosh HD

    2. Click on the file labeled "Library"

    3. Click on the file labeled "Preferences"

    4. Click on the file labeled "SystemConfiguration"

    5. Then move these three documents to the trash (don't delete them just in case but your computer should remake these documents on its own



         3. NeworkInterfaces.plist

    6. Then restart your computer and you should be good to go and if you are you can go ahead and delete those documents in your trash (that is what I did) because one of those documents was corrupted.


    Hope this helps and let me know if it worked!

  • Facie Level 1 Level 1

    After 18 months of working every day at my office, my mac air suddenly has htis problem.  I've tried everything in this entire thread.  I've deleted key chain.  I've reset DHCP by fooling it and renewing.  I've gone into the system folder and deleted the three files referenced above.  None are permanent solutions. 


    This is insane.  Any other ideas from anyone?


    I feel Iike I've gone back in a time machine and am using my old Windows laptop. 



  • MrNinja Level 1 Level 1



    I take it your still aren't getting an IP address even after a reboot?


    Is this via a cable or wifi?


    Can you try something for me, as mine is working and I can't test this?


    Reboot and log in as the guest user (you might need to enable the guest account).


    When you log in as guest, try logging on to you network and then see if you can get on the internet. Does this account get network access?


    Then reboot the machine and log into your normal account. Is it still broken?



  • shyH33 Level 1 Level 1

    I'm having the same problem with my macbook pro OS X 10.6.3

    I've tried practically evrything that i could find over the internet but have yet to solve this problem.


  • shyH33 Level 1 Level 1

    WOOOO finally got my mac working again after 6 hours.....

    for those of you who have tried just about everything you could find just like i did this is what worked for me.

    From what i've read from all kinds of sources the problem has something to do with the communication between the airport and modem/router. Try disconnecting your airport to whatever network that you are having problems with and search for an open one(one that does not require a password) to check if you can connect to it instead. This is to check if your airport works at all and if it does, well that's a good sign. Reset you modem/router (this isn't always easy as you'll have to set it all up again from scratch.) Then delete the network from your airport list, turn off airport and restart mac. From there turn on airport again and reconnect with your newly resetted network.

    If this doesn't work right away you can try manually assigning an IP address and then hit renew DCHP. I was able to connect after that. I know this might not work for people having problems with connecting from offices and schools as it will be difficult to reset their modems, but i hope this might help others or at least give them an idea as to where the problem might be.

  • candilyn18 Level 1 Level 1

    My friend asked if I could take a look at her laptop (macbook) because it would not connect to the internet.  I went to her house and discovered the wifi was not working.  She was getting the self assigned ip address and the internet would not connect.  I took my own laptop (macbook pro) to her house and was able to connect to her wifi no problem.  I connected her laptop via ethernet and that worked.  Brought her laptop to my house and it connected to my wifi no problem.


    I surfed the internet looking for a fix.  I was afraid to mess someone else's computer up.  I was desperate to find a solution that didn't require me to delete or move anything around.


    I had already tried numerous things (including installing a new operating system), but none of them worked.


    Here is what I did today that fixed the issue for her.  I'm going to list it all, although I don't think it is all needed.


    1.  I unplugged the power cord and coaxial cable from the router.  I turned the airport off on her laptop and turned the laptop off.  I left everything off for about a minute.


    2.  I reconnected the power cord and coaxial cable and turned the computer back on.


    3.  When it all turned on and airport was turned back on, it still had the same internet.


    4.  I went into system preferences, network, wifi, then clicked on "Assist me" at the bottom.


    5.  I chose Assistant and followed the prompts.  I named her new location "home", then chose her network that I wanted to connect to and entered the password.  Following all the prompts when the process was over, the laptop connected to the internet!


    I really feel that only steps 4 and 5 need to be done, but I listed all steps I took just in case.  I did tell my friend that I'm not sure if she leaves her house and connects to another network and then back to her house and connects to her network if it will continue to work.  I showed her how to go into system preferences, network, wifi and assure that her location is set to "home".


    Anyway, this is what I found to work and thought I would share since in all my searching, this wasn't a solution that I found.

  • Dedalus2011 Level 1 Level 1

    I was having this issue at my public library, where you get a window that automatically pops up (when working) and asks you to agree to terms and connect. I tried renewing the lease and it didn't help. I tried setting the DHCP to manual, and changing the ip address and it didn't help. I tried adding a DNS server and it didn't help. I tried verifying keychain access and it didn't help. I tried adding an acception to the firewall (system-->library-->coreservices--> and it didn't help.


    Then I clicked on "Assist Me..." in network preferences and it changed my manuaul DHCP back to automatic, allowed connection, etc. and now it works. At the moment...

  • pixieluca Level 1 Level 1

    After hour and hours of trying a fix.


    I Factory reset my router and now all works fine ! Do this it works.

  • misstes Level 1 Level 1

    Thank you so much Desigurl03! I also couldn't connect to my home wi-fi (although my son's mac worked fine, as well as, my ipad). I tried every method before yours and none of them worked. After days without internet on my laptop, your solution worked for me. Two thumbs up!

  • rx7car Level 1 Level 1

    Ok, so my problem migrated from a self-assigned ip issue into something else.  For me, I think it was a keychain issue because after deleting the keychain entries and reconnecting it now "connects" fine.  However, now it thinks I am completely connected (green dot) but I can't actually access the Internet (browsers think DNS issue). 


    I have tried everything above, I get the same issue with manually assigned ip.  Must be a communication issue with the router, I think, but unfortunately I don't have the luxury of resetting the router to factory or changing the wep to wpa.  My iPhone and iPad connect perfectly fine, and my MacBook Air used to be perfectly fine on this network before.


    Dying here...  Help!


    (btw, where is apple support on this?)

  • vkehayas Level 1 Level 1

    I also had this problem for both ethernet and wifi connections,

    with Wind*ws in Bootcamp mode working,

    and all other devices and/or colleagues at work connecting,

    and most solutions didn't work.


    What solved it for me (I hope it lasts) after 3-4 stressful days was

    a 'Repair Disk Permissions' through the Disk Utility.

    It found that the 'com.alf.plist' permissions caused the problem.

    So maybe you don't need to delete it, at least in some cases.


    (Apple Support will be 19$ -in my region at least!)

  • vkehayas Level 1 Level 1

    I did 'Repair File Permissions' followed by a Restart, and it worked!


  • HansvdV Level 1 Level 1

    After spending hours trying to resolve the same problem of not being able to connect to the internet - also got: "the Wi-Fi has the self-assigned IP address and will not be able to connect to the Internet."

    ericdy's solution sorted out my problem. I think he needs to replace some of those how ranking advisors on this forum!

  • ericdy Level 1 Level 1

    Woo hoo, glad it was helpful, can't take the credit though because I found the solution through others.  I just remember how frustrating it was trying to get to the bottom of it.  I haven't had another problem with it since I applied the solution many months ago.  All the best!

  • Bob Kerstetter Level 1 Level 1

    Do this the stuff you find at the bottom of this thread:


Previous 1 2 3 4 5 6 Next