Previous 1 3 4 5 6 7 Next 186 Replies Latest reply: Nov 29, 2015 2:22 PM by Eddie Epic Go to original post Branched to a new discussion.
  • jcdill Level 1 (0 points)

    I found a work-around that works for me where none of the other solutions posted before have worked (for me).  The beauty of this fix is that it works when you are using wifi away from home (e.g. in a coffee shop or hotel) and can't set a static IP because you don't know what numbers the router is using.


    Turn on the AirPort, select the network, let it connect.  Go to System Preferences -> Network, select your Airport connection then click Advanced, and select the TCP/IP tab.  You will see the self-assigned IP address.


    Turn your Airport OFF (right click or control click on the icon in the menu bar, select Turn AirPort Off).


    In the still-open Advanced settings TCP/IP window, click on Renew DHCP Lease.  Do this several times, as it may "renew" with the self-assigned IP address the first few times.  Eventually you will get NO IP address.  This means you have finally convinced the buggy DHCP process to abandon what it thinks it knows about an IP address you have previously "used" (the useless self-assigned IP address).


    Now turn your AirPort back on (right click or control click on the icon in the menu bar, select Turn AirPort On).  Let it come on, and connect (or offer to connect) you to your wifi.  If necessary, select the wifi you want to connect to.


    Watch in the still-open Advanced settings TCP/IP window as your connection gets an IP address.  Sometimes it briefly shows the self-assigned address before getting a routable address.  When you have a working network connection you need to click "cancel" to close the Advanced settings window and return to the Network settings window, from there you can just close System Preferences.


    I have found this to work 100% of the time where none of the other fixes in this thread helped me. 

  • jcdill Level 1 (0 points)

    Oops, please ignore.  (No way to delete after posting. grrr.)

  • tanvir5391 Level 1 (0 points)

    I've tried everything I found online and nothing worked. Then I tried something that finally fixed my wifi after months of trying. Here's the link for the video I made showing what to do (very easy!)



    Hopes this helps. I was extremely happy when it worked for me.

  • Ian Currie Level 1 (15 points)

    Of all the (increasingly common) bad things wrought by Apple software and firmware updates, this one should win an award.


    I tried everything in this thread -- not necessarily in the order I found them -- and one finally worked for me.  I report this for the Apple engineers that I'm sure are working tirelessly on this problem even as I write ;-]


    First the basics: MBP late 2007.  10.8.2.  Wireless router is an Actiontec supplied by Bell Aliant in Atlantic Canada.  I installed 10.8.2 about 10 days ago.  The MBP is set to "Never Sleep" and I am quite sure I had not done a restart since installing 10.8.2.  No problems at all until this morning.  This morning, the dreaded self-assigned IP address was waiting for me.  All the other devices in the house were still connecting over wi-fi, no problem.


    The trick that eventually worked for me was this: 1) shut down 2) connect ethernet cable directly to router 3) power on computer.  Please note that I left wi-fi on throughout this process.  Wi-fi and ethernet were both immediately connected and both assigned valid IP addresses from the router.  I disconnected the ethernet, and the wireless continued to work.  I put the computer to sleep, woke it up, and wi-fi is still working.  Will update if it stops working again.


    It is just so wrong that we've all had to waste time on this.  Good luck to everyone.

  • Ian Currie Level 1 (15 points)

    A sad update to my last: when I physically closed the MBP (as opposed to just putting it to sleep) I lost the wi-fi again.  I was able to get it working again by simply opening it and plugging the ethernet cable in again, but every time I close it, it loses the connection again.  Weird.

  • jcdill Level 1 (0 points)

    Ian, did you try the solution I posted above?  Open your network settings, go to the TCP/IP tab for your wifi connection.  Then in the toolbar at the top of your screen, turn wifi off.  Then in the TCP/IP tab click "refresh DHCP" until it refreshes to empty (no IP address, self-assigned or other).  Then turn the wifi back on using the toolbar icon, and select your network (if necessary).  If you do this, does it come back up with a self-assigned IP or does it give you a routable IP?

  • Ian Currie Level 1 (15 points)

    Actually, this was one of the first things I tried!  The solution sounded almost as weird as the problem, so I thought why not? 


    Didn't work for me. Tried it twice.


    Also, an update: I tried ethernet on a non-wireless router within range of the existing wireless signal.  This did not bring the wi-fi back.

  • Ian Currie Level 1 (15 points)

    Sorry jcdill - another update with late breaking news.  Your solution DOES work, if I am within about 20 feet of the router.  As soon as I move out of that range, I get the self-assigned IP again.


    So - perhaps this is not a Lion / Mountain Lion issue at all?  Hard to imagine the OS would affect wi-fi range... or at least it's hard for me to imagine.


    I will check the MBP discussions, but does anyone know if a reduction in range is indicative of a failing airport card?

  • Jon Levinson Level 1 (15 points)

    Just tried this but it did not work.

  • Specular Level 1 (0 points)

    After trying pretty much all the suggestions here, and still getting nowhwere.

    As other devices could connect without a problem, I was starting to get just a tad peeved.


    I then stumbled onto the fact that the security profile on my router WPA2 was using TKIP,  changing to AES the wireless now works flawlessly.



    Hopefully this helps



  • null.pointer Level 1 (0 points)



    I have had this happen on multiple computers.  In one case one of the posted solutions here worked.  However, in a recent situation I required a different solution for a router that had multiple Macs all failing to wirelessly connect in the same way.  These same computers worked a year ago on the same router!  Something in the MAC OS has changed.


    THE SOLUTION IN THIS CASE: Turn off MAC filtering on the router (if you don't know what this is you almost certainly don't have it set up and this is not a solution for you, because it would NOT be a default router configuration).  Even though the MAC addresses for the computers were programmed into the Router MAC filter, something about that filter is a problem.  My guess is that it is a problem in the MAC OS in its interaction with the router filtering, since a windows machine worked fine on the same network and nothing has changed with the router.  I have NOT tried turning the filtering back on to see if it works once I met with success, because in this case I didn't care and I must move on. 


    Hopefully Apple fixes their software soon, because this problem is crippling and seems to manifest itself in a half dozen different ways (i've seen two so far.)

  • Barteatapple Level 1 (0 points)

    Yes indeed, a very irritating issue!


    After reading the posts here, i have tried to combine several possible solutions.

    Now Ethernet -> Wi-Fi Internet Sharing works and also with Firewall on. I have done:



    1. put Internet Sharing and Firewall off

    2. done the instruction from: Desigurl03


    1. Click on Macintosh HD

    2. Click on the file labeled "Library"

    3. Click on the file labeled "Preferences"

    4. Click on the file labeled "SystemConfiguration"

    5. Then move these three documents to the trash (don't delete them just in case but your computer should remake these documents on its own



         3. NeworkInterfaces.plist

    6. Then restart your computer and you should be good to go and if you are you can go ahead and delete those documents in your trash (that is what I did) because one of those documents was corrupted.


    3. redo all your settings in Wi-Fi Internet Sharing

    4. put Internet Sharing on


    Test the Internet Sharing with other device.

    When it works:


    5. put Internet Sharing off (don't know this is needed)

    6. put Internet Sharing on again

    7. put Firewall on again


    Hope it stay working.

  • ingrocioibarra Level 1 (0 points)

    This worked for me!!! THANKS. Hey guys, if you are using DROPBOX defenitely check this option out. THANKS man I created my apple ID just to say thank you ily.

  • MichelF2 Level 1 (0 points)

    Hi everyone,


    I think I have tried every solution published on all the Internet forums worldwide... None have worked for me. But... I have made a clean re-install of Mountain Lion... Twice ! The first one left the problem unchanged... So I have tried a second time... And now, it is working all right. I don't understand what has happened and why it is working now, but it works just fine ! So the big mistery of networking connections is still on !


    Regards to everyone.

  • Annoyedatappleagain Level 1 (0 points)

    I've tried EVERYTHING and nothing has worked. I switched from PC to Mac because of the reliability but now I can't fix anything! I could rebuild a pc from the ground up!


    After having a hard drive crash that apple knew was faulty, and now this I'm ******. What a waste of everybody's god **** time.

Previous 1 3 4 5 6 7 Next