Previous 1 4 5 6 7 8 Next 186 Replies Latest reply: Nov 29, 2015 2:22 PM by Eddie Epic Go to original post Branched to a new discussion.
  • Bob Kerstetter Level 1 (35 points)

    If are you near an Apple Store make a genius bar appointment and take your Mac in for technical assistance.


    Make sure your wifi security is configured correctly.


    If are using a lot of third party software, check to see if any of it has added kernel extensions, especially anything using the network in a non-standard way, like a game server, for example. Sometimes a third-party kernel extension totally messes up your ability to connect by wifi. A lot of programmers just port things games from Windows without regard for the OS X API, then try to work around the problems they create by adding kernel extensions. Not good, but true.


    After all of this checks out and gets fixed:


    Go to System Preferences in the Apple menu.

    Click on Network. (It may say Network Settings on some system systems.)

    Click the Turn Wifi Off button near the top of the Network panel.

    Unlock the lock in the lower left corner if necessary. This requires admin ID and password.

    Click Advanced button

    Select your wifi network and

    Click the minus sign to delete it

    Click OK

    Click Apply

    Open the Keychain Access application in Applications > Utilities folder.

    Find your network name in the list.

    Delete the login password for your network.

    Then go back to Network settings and turn wifi on.

    Click Advanced button.

    Click plus sign.

    Click Choose a Network.

    Select your network and enter your password

    Click Okay

    Click Apply


    This should work. Sometimes the settings get hosed, but not very often. I have had this happen once in 10 years with Mac OS X.

  • MrNinja Level 1 (0 points)



    Probably not the forum to vent your anger.


    If you really don't like the Apple OS then vote with your feet.


    I use Macs and PCs on a daily basis and have about 7 computers on my desk. I'm very confident with Windows, Mac, Linux, UNIX, Solaris etc. and I choose Macs for my own personal computer, albeit, I run Windows and Linux in VMs on my MacBook too.


    Hard disks are mechanical devices that *will* fail and Apple don't manufacturer them so you can't blame them for that. If you can rebuild a PC from the ground up a mere hard drive crash shouldn't cause you any problems anyway!?


    If you're having issues with your machine picking up an IP address - try rebooting and logging in as the guest user. Can you get on wifi and get a DHCP address through that account?

    Or in your normal account install a Virtual Machine program and install another OS - bridge the VM's NIC - can your windows box get an IP?



  • BritchiV Level 1 (15 points)

    hey guys...I found the helped me very much just try to change the wireless mode from 11bgn mixed to 11bg this from router settings,wireless settings I guess this will help you

  • Bob Kerstetter Level 1 (35 points)

    Improper wifi settings in the router are frequently the problem. When I worked for Apple Retail we always tried to own the problem and solve it, not blaming the router. But the router was often the problem. For example, if you are having the problem at home, but not at Panera Beard or Starbucks or the Apple Store, then the problem is your wifi router.

  • amunoz74 Level 1 (0 points)

    Hi This solucion works for me. Its pretty simple as create a new location.


    Take a look to this tutorial  video:


  • TFCTECH Level 1 (0 points)

    Another possible solution if other things dont work.

    Just went through many steps listed to figure this out and depending on folks situation it can also be caused by the router.  I found that in my situation for a business that the DHCP on the wireless router was set to only except addresses from (example) -  With that configuration only 10 people could get on that router unless it was changed to say - (now it has room for 100 people).  .Once the business hit the initial 10 that was set originally by ISP (provider) nobody else was getting on. 

    All I can say is "WOW, that was FUN, NOT".  Hope this will help somebody else in need if the other steps posted earlier didnt help.


  • chensianna Level 1 (0 points)

    I tired everything and still it doesn't work. So I turned off the modem for 1 mintute and than turned it on. My internet is back!!! So easy but I took me 4 hours to figured it out and made me so worried and upset!!!

  • The Nail Level 1 (0 points)

    YES!!! Worked. The Best.

  • Petesla Level 1 (0 points)

    This did the trick for me too! Glad I found this thread after only a few hours, not days.

    Thanks so much for posting the solution to delete that network password in the keychain file.

  • jrmcwilliam Level 1 (0 points)

    I had this problem and was able to fix it by deleting the network from my list of preferred networks and its keychain password.  Then the network was recognized as new and seemed to reset itself once I entered the WEP password.


    I tried all of the other solutions on many forums over many hours and this is the only one that worked for me.

  • jrmcwilliam Level 1 (0 points)

    this is the only solution that worked for me.

  • Pdub Level 1 (5 points)

    This just worked for me! After a week of reading discussions and realizing that my iphone5 and original ipad were finding the network but not the imac, I tried ericdy procedure and it worked. Happy New Year!!!!!!!!!

  • kyuss66 Level 1 (0 points)

    Thanks to candilyn18

    Worked at last!

  • onkaval Level 1 (0 points)

    hi ericdy, i read your post.


    i use a public network most of the time and it does not have a password. So there is noting to delete in keychain access. I have a mac book air, i only connect through my wifi. Can you please help me out. Thank you

  • CDawggehhh Level 1 (0 points)

    I was stuck on this for days and days running both a netgear wifi/cable modem and Dlink wifi/cable router - which basically conflict Ip addresses to which i had to manually set different IP to the Dlink, which didn't solve the problem just yet. As my Dlink's wifi I had access to very easily just not a very fast connection, But my netgears wifi I couldnt connect via airport only by ethernet.
    I tried everything from...


    renewing the DHCP lease
    Deleting the Keyaccess

    Revoming the wifi preference in advanced settings

    Turning off my Dlink & Netgear
    Reset the Dlink
    *couldn't reset my Netgear as last time i reset it got stuck on reset for two days.*
    Deleted my airport plist in MacHD

    creating a new location
    Manually inputting an IP address. (which said was connected but no internet connection)

    & Changing both my pass to WPA2-PSK

    & I'm pretty sure I tried that all in many different combinations and still didn't reslove my issue.
    Today I was planning to call apple and spend that $50 that I don't have and see what their solutions were.


    instead I thought I'd try one last time to fix this, Here's what I did - and I can't say that it will work for people unless you have two routers, but it may work with just one, either way my previous methods above may help someone fix theirs!


    I basically switched off my dlink and was about to directly plug the ethernet cable into the Netgear and all of a sudden I had a wifi signal that worked - browsed the net for a solid 30mins - onwards, switched on the dlink and my airport still stayed with its connection and I saved as a new location.



    I'm no guru all my methods were stuff I found searching forums and just trial and error runs, I think what may have happen and someone please correct me is that maybe the two networks were getting confused with each other I did noticed that my netgears subnet mask ended with 240.0 instead of 255/250.0 which was what the dlink entered in. Originally when i tried connecting the first time the subnet on the netgear tried picking up at which was strange as i was used the the 240.0 So turning the Dlink off must of made the netgear re-register its sub?



    Anyway I hope my solution helps someone out! or maybe someone can give me some good feedback on why my issue might have occured and maybe a better solution to fix this problem next time!



Previous 1 4 5 6 7 8 Next