10 Replies Latest reply: Jan 19, 2013 9:21 PM by mg8765
RyanDamage Level 1 Level 1

I have a MacBook Pro running 10.6.8 and we got wifi at the house this afternoon. It will not connect, if I open network diagnostics the top four lights are green, internet and server are red. There are two other macbooks in the house(at least one also running 10.6.8) and two ipads, all of which connect with no problem. The macbbok in question connects fine at coffee shops and, up until a week ago, fine with the wifi at my last apartment.


We are using Charter and the router is a Motorola SBG941.


Thanks for any advice you can give!

MacBook Pro, Mac OS X (10.6.8)
  • CMCSK Level 6 Level 6

    Change your router channel.  Sometimes this is all you will have to do.


    Power cycling the router.  Read the router's user manual or contact their tech support for instructions.


    System Preferences/Internet & Network/Network

    Unlock the padlock

    Locations:  Automatic

    Highlight Airport

    Click the Assist Me button

    In the popup window click the Diagnostic button.


    System Preferences/Network- Unlock padlock.  Highlight Airport.  Network Name-select your name.  Click on the Advanced button.  Airport/Preferred Networks-delete all that is not your network.

    Place a check mark next to "Remember networks this computer has joined."  Click the OK button and lock the padlock.  Restart your computer.



    http://support.apple.com/kb/TS1920 Mac OS: How to release and renew a DHCP lease



    No internet connection (wireless)

    Check to see if an extra entry is present in the DNS Tab for your wireless connection (System Preferences/Network/Airport/Advanced/DNS).

    Delete all extra entries that you find.

    Place a check mark next to "Remember networks this computer has joined."



    Other resources to check into:

    Troubleshooting Wi-Fi issues in OS X Lion and Mac OS X v10.6




    How to diagnose and resolve Wi-Fi slow-downs


    Pv6 troubleshooting


    Mac OS X 10.6 Help:  Solving problems with connecting to the Internet


    What Affects Wireless Internet?


    Solutions for connecting to the Internet, setting up a small network, and troubleshooting









    Image Hosting by PicVault.info

  • RyanDamage Level 1 Level 1

    Okay, I've tried everything that youo suggested and nothing has helped. I decided to try and update my software by plugging straight into the router with an Ethernet cable. After about a minute it dropped the Internet connection while it was plugged in. Airport was turned off at the time.

  • RyanDamage Level 1 Level 1

    Thanks everyone for looking, I feel emabrassed to admit that I believe I have solved the problem by shutting off the firewall on the router. Don't know if I should feel frustrated that it took me an hour or two or relieved that is all it took.

  • CMCSK Level 6 Level 6

    Thank you for reporting back your solution.  It should help others with the same problem.









    Image Hosting by PicVault.info

  • InSkill Level 1 Level 1

    I bought my first Macbook pro 13" with Lion yesterday.Was pretty excited about it, because I had saved for so many months to get this machine.


    But when I tried to connect it to the WIFI (2wire Router from ATT) I just would not get connected. I tried for 2 hours but in vain.

    Tried for the whole day today SADLY very frustrated now. With so much Hype and being so pricy, plus with so much focus on moving towards the cloud and all, I though getting online should be a peice of cake. Anyway.. Please suggest a solution. I have tried everything suggested in this forum. I am scared to delete any files though.


    I am posting this message from my PC ha ha..

  • CMCSK Level 6 Level 6

    InSkill wrote:


    I have tried everything suggested in this forum. I am scared to delete any files though.


    I am posting this message from my PC ha ha..

    Then there is nothing more to add from anyone. 



    I bought my first Macbook pro 13" with Lion yesterday.



    Call Apple Care.   You have 14 days from the date of purchase to return your computer with no questions asked.


    Take FULL advantage of your warranty.  Posting on a message board should be done as a last resort and if you are out of warranty or Apple Care has expired. 











    Image Hosting by PicVault.info

  • memos Level 1 Level 1

    Still, there is no official word on this ongoing issue since 2007! 5 Years!

    I mean it's as simple as a darned wifi connectivity hiccup! Fix it already!

    All I see is "Connection timeout" and "Conection Failed" I am two dialogue errors away from smashing my MBP on the wall.. the irony is that I work at home via this thing called the internet!

  • greensuz Level 1 Level 1

    I had the same problem and after 4 hellish days of messing with router settings, I have finally figured it out, and came back to this thread to share!  I searched here (and everywhere else on the internet) yesterday for an answer, but although the information I found led to the fix, nowhere did I find what was, for me, the vital missing piece of information.


    I have a factory reconditioned MacBook Pro that I purchased from the Apple site.  It came running Snow Leopard, and I upgraded to Lion  as part of my ridiculous quest to connect to wifi at home.  Turns out Lion wasn't necessary, but nonetheless, I guess it's nice to have the upgrade.  I have Uverse internet with AT&T, and we are using the 2Wire router that came with the system.  It has worked with our other apple products and pc laptops at default settings no problem.  The MacBook wouldn't connect.


    I think MacBook likes WPA2-PSK security for some reason.  We were set on WEP.  So, go to this address -

    That will take you to the 2Wire settings site.  On the tabs across the top, click "Settings."  Then click the "LAN" tab.  Go down to the subheading "Security."  By Authentication Type, drop-down menu to WPA2-PSK (AES).  Then go to the bottom of the page and click Save.  Now for the small detail no one has mentioned in my four days of searching for an answer.  When your Airport recognizes the network and you select it, it will prompt you for a password.  It is not the number you were using for your WEP security.  For us, that was a 10 digit number called router access address.  For WPA2-PSK, the password is the SSID #.  I had to reset all the other devices running on the network with the same new password, and now we are all running on the network again.  Thank the lord!!!  Hope this helps save some poor souls from the hours of frustration I have just been through!

  • blake7even Level 1 Level 1

    This is more for people searching on a similar issue.


    My 2011 MacBook Air would connect to the work WiFi and network diagnostics showed green all the way. I could Ping as well.


    I tried all the solutions offered up mainly setting up a new location and messing with DHCP. Nothing worked.


    My iPhone could connect but the mac couldn't.


    Here was my fix.


    Open System Preferances.

    Open Network.

    Click Advance

    go to TCP/IP tab

    Select 'Using DHCP with manual Address' from drop down.

    Type in an IP address you assume to be free.




    My aging work router that I don't have access to was sharing out IP addresses, so I picked one for myself with a high number.


    hope this helps.

  • mg8765 Level 1 Level 1

    Most likely you MAC filtering in 2wire is on. You need to add the MAC id of you Macbook to the "allowed" list or turn the MAC filtering off.