Skip navigation

Duplicate events in iCal

36421 Views 22 Replies Latest reply: Apr 27, 2013 7:32 AM by williej56 RSS
  • ninthname Calculating status...
    Currently Being Moderated
    Jul 26, 2012 6:06 PM (in response to John Maisey)

    Hi John-

    Well I just spent 45 minutes doing this (I have a lot of calendars) and when I resubscribed to iCloud, I now have four of every event, the three that were previously duped and the new one I created. I'm surprised that iCloud can't tell which is more recently created, and that they are duplicates (given the calendar names, colors and text are identical.

    I'm going to try this again (call me sucker) and see if I can delete the calednars from iCloud before resubscribing. I'll let you know what happens.

    THanks,

    Matthew

  • ninthname Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2012 6:49 PM (in response to ninthname)

    That way worked, but man what a lot of work. DO we know why iCal is dupeing events so we can simply avoind that in the first place?

    Thanks for the assistance.

    Matthew

  • ThunderRoadJoe Calculating status...
    Currently Being Moderated
    Oct 4, 2012 9:01 PM (in response to LexSchellings)

    Thanks LexSchellings. It worked like a champ.

  • KoldSnapz Calculating status...
    Currently Being Moderated
    Dec 19, 2012 8:44 AM (in response to TonyInSF)

    Not sure if its needed any more but I just wanted to point out that I had a similar issue where I would enter an event and about a minute later it would duplicate it. Sometimes it would then duplicate everything in my calendar. I was able to stop this by click the Calendar button, and unchecking the calendar Delegates. No need for any additional apps or anything.

  • Andrew Beswick Design Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 6, 2013 1:47 AM (in response to TonyInSF)

    HI

     

    I went to iCal Preferences and foudn that I have three icloud log ins, so diabled two of them, and it seems to have worked! Im not sure why I had three though, as I log in with a mac and an iphone... but the duplication of events only started in teh last mfew weeks. FIngers crossed it goes.

    Its only on my mac, not my iphone, so perhaps thats whats doubling up!

  • swellshark Calculating status...
    Currently Being Moderated
    Jan 22, 2013 4:18 PM (in response to KoldSnapz)

    Hi KoldSnapz

    You are absolutely correct this worked for me too, but what is "delegates and where does it come from?" Should we be deleting some calendars from somewhere? Thanks

  • swellshark Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2013 6:05 AM (in response to TonyInSF)

    Hi all

    Having spent what feels like years of my life trying to get rid of duplicate calendars, I have finally found something that may help:

    It seems Google no longer use delegation but it happens automatically if you use an account preference of google and not your email account.so...

     

    I went into https://www.google.com/calendar/syncselect and checked that the calendars I wanted were correct.

     

    Then into ical, this bit taken from setting up a new iCal Google Calendar

    1. Open Apple iCal
    2. In the toolbar, click Calendar, then Preferences
    3. Click the Accounts tab
    4. In the accounts pane on the left, click the + button to add an account
    5. Enter the following information:
    • Account Type: Google
    • Email Address: Enter the email address that you use to log in to Calendar. Make sure to include the '@domain.com' portion (which is @gmail.com for Gmail users) in this section.
    • Password: Enter the password for the email address you listed above.

    I had previously had an email account and therefore delegation duplicates too. Once you are happy to see that you have everything in the google calendars then you need to delete the email calendars from iCal.


    If you previously synced additional calendars using Delegation, you have to remove those settings to prevent duplicate events:

    1. In the iCal toolbar, click Calendar, then Preferences
    2. Click the Accounts tab
    3. Select the correct account in the left pane and click Delegation
    4. Deselect all checkboxes for your additional accounts

     

    Now instead of having my email calendars, cloud and delegation, the delegation ones are gone and I have google showing but No duplications, hurrah!

  • williej56 Calculating status...
    Currently Being Moderated
    Apr 27, 2013 7:32 AM (in response to John Maisey)

    Hi John, I'm a big fan of your app, but since I installed Mountain Lion, it doesn't seem to work. Best, Bill

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.