3 Replies Latest reply: Apr 12, 2012 5:50 PM by MrHoffman
AdamKasprzak Level 1 Level 1 (0 points)

Hello!

 

I have a common problem with iChat server (OSX 10.6 SL), but I still can't figure out how to fix. Please advice.

 

iChat server log shows multiple lines:

 

[7] [::ffff:192.168.2.112, port=49581] connect

SASL callback for non-existing host: 192.168.2.112

[7] [::ffff:192.168.2.112, port=49581] disconnect jid=unbound, packets: 0

 

but sometimes connects and shows:

 

[7] [::ffff:192.168.2.112] is being rate limited

 

I was fighting with DNS and also still can't figure out how to change DNS Hostname

 

changeip -checkhostname shows:

 

 

Primary address =192.168.2.112

Current HostName =doe.local

DNS HostName =MACSERVER

 

I was trying to work within ServerAdmin->DNS, but without any effect.

 

I was reading:

https://discussions.apple.com/thread/3065100?start=0&tstart=0

https://discussions.apple.com/message/11292341#11292341?messageID=11292341

http://support.apple.com/kb/TS2987

 

I would appreciate step-by-step solution

 

Have a nice day!

Adam


Mac mini, Mac OS X (10.6), Mac OSX Server Snow Leopard
  • MrHoffman Level 6 Level 6 (13,275 points)

    Don't use .local as your domain name, as a starting point for troubleshooting this.  You don't own that top-level domain.  Don't use .private, either, as that's not yours.  Best to register a real domain name, and use it.  If you can't, then you're going to need to pick a TLD that won't get lit up with all the new top-level domains that are going online.  Best to register and use a real domain, or use a subdomain of a domain you have registered.

     

    Here is a step-by-step for configuring DNS services on OS X Server.

     

    All sorts of stuff can and usually does get weird when DNS is wrong; DNS is fundamental to network operations, distributed security, and network-level authentication.

  • AdamKasprzak Level 1 Level 1 (0 points)

    Thank you for reply!

    I did everything according to your link. I had registered domain: doe.pl. I've created subdomain: server.doe.pl, which I've added to OSX Server as Zone:

     

    Primary Zone Name: server.doe.pl.

     

    but I can't add Nameserver - when I add, then click Save - it disappear.

    There is still unsolved problem with my DNS Hostname. How can I change MACSERVER to server.doe.pl so that everything will be correct?

     

    Don't get me wrong - I just need to connect 10 computers in closed, private network to iChat. In the beggining it worked well, but after first upgrade iChat stopped responding...

     

    Thank you again for your time!

  • MrHoffman Level 6 Level 6 (13,275 points)

    If you have the domain doe.pl registered, then the DNS zone for the private network would typically be

     

    doe.pl

     

    Given what you're using here, the resulting FQDN for the host in the zone would be

     

    macserver.server.doe.pl.

     

    I expect what you wanted here for the FDQN wasL

     

    macserver.doe.pl.

     

    OS X Server will provide a self-hosted single-host DNS zone using whatever the initial configuration was, if there's no valid DNS service on the LAN.   It'll use the name and domain as the host.  So if you gave the box the name server.example.com., you'd get the zone server.example.com created.  And as is discussed in that article, cleaning out the DNS setup and starting over is typical.

     

    For completeness, I've hit a few (rare) cases where Server Admin.app was not able to delete the zone; where Server Admin kept helpfully repopulating stuff.  If that's happening, it'll be very obvious; delete the zone and *poof* it reappears.  This is rare (and may well be tied to specific versions of Server Admin.app), but I've seen it happen a few times.

     

    And again, OS X Server (and pretty much any other server available these days) expects to have valid DNS services.  That folks skip this step and don't get DNS working is one of the most common errors.  Everybody does the "nope, don't need that" (or "nope, don't understand that") and here we are...  The first few times I ran into DNS, I certainly thought that myself, and DNS has only gotten more central to correct operations since then.