12 Replies Latest reply: Jan 18, 2014 11:28 AM by Dennis A. Livesey
beng_10 Level 1 (5 points)

Hi, I've created a vault for one of my image libraries. The library is large (300Gb) though the vault is less than 300Mb. There are no referenced images in the library and I've done a double check on this by searching for referenced images. ANy thoughts on what's happening? I want to ensure my images are backed up but this isn't giving me much comfort that they are! (I'm on Aperture 3.2.2).



Aperture 3, Mac OS X (10.7.3), MacBook Pro mid-2009
  • léonie Level 10 (85,295 points)

    Have you updated your vault? After creation the vault initially will be empty.

    To update your vault:

    • In the Vault pane, click the Vault Status button to the right of the vault’s name.



  • beng_10 Level 1 (5 points)

    I have though I'm finding that it's actually getting incrementally smaller each time I do an update (by 1 or 2Mb). I've also tried deleting the vault and re-creating it but I get the same problem.

  • léonie Level 10 (85,295 points)

    There are no referenced images in the library and I've done a double check on this by searching for referenced images.

    And if you search for the opposite - "File status is managed" - does Aperture show you all of your library, or is the search result empty?

  • léonie Level 10 (85,295 points)

    What do you see when you update the vault? Is there a progress bar showing ""Updating Vault" or no reaction at all?


  • beng_10 Level 1 (5 points)

    Thanks for this, appreciate you continuing to help me solve this.


    I did get a progress bar as per the above when I created it. I tried it again just to make sure and it does do this (though very quickly given that I have only made minor changes since the last update). I tried a couple of combinations of searches;

    - Managed = shows all the images;

    - Offline = shows nothing (i.e. no images are offline);

    - Online = shows all images;

    - Referenced = shows nothing;

    I ran these searches on everything in the library.


    I re-tried the loop of deleting the vault and starting again just to get a better sense of what might be happening and got this dialogue box (this happened last time to though didn't note it). It seems strange given that when I search there are no referenced images and, even so +17,000 high res images will be well above 300Mb.


  • léonie Level 10 (85,295 points)

    There seems to be something wrong with either your Aperture Library or your disk(s). Where are the Aperture library and your vault(s) located? On internal or external volumes? Directly connected volumes or network volumes? And how are the volumes formatted? MacOS X extended?


    Since Aperture seems to be confused whether your images are referenced or or managed, there may be a permissions problem with your library or a corrupted database file. I'D suggest you make a backup copy of your library, and make sure you can open this copy properly, and then try the Aperture Library First Aid Tools on your Library - try "Repair Permissions" and "Repair Library"


    To run the "First Aid Tools" hold down the options-key and the command-key while you double click the Aperture icon. This will display the "First Aid" panel. See here for more information:

         Aperture 3: Troubleshooting Basics: http://support.apple.com/kb/HT3805





  • beng_10 Level 1 (5 points)

    Thanks Leonie this fixed it. Workflow as follows;

    - Delted the vault;

    - Closed all programs;

    - Repaired permissions;

    - Re-opened Aperture and created a new vault. Worked perfectly.

    (backed up the library before doing any of the above).



  • léonie Level 10 (85,295 points)

    Great! I am glad you could solve it.



  • Thatblokeoverthere Level 1 (0 points)

    Sorry to crash in. I've read all this with interest having suddenly hit a bunch of problems with Aperture.

    I was concerned about the loss of photos if I get continued repeated crashes. I read up on the VAULT thing. Still not very clear on how it works but I gathered that it makes some kind of backup on my external HD of my entire library. Not really sure what referenced files are but - 'whatever'. Also not too sure whether the backup is automatic or whether I have to remember to initiate updates.


    I too thought I had created the vault but realised it was actually empty. So now it's on the initial backup. 6 hours gone ans still only about 10% done. Can this be right? It is moving slowly. No idea how many files as the action has locked me out of Aperture completely, can't even minimise it.


    So, questions:

    - How long does it take to complete the initial backup?

    - What are referenced files?

    - Is the backup auto-initiated?

    - Can I rely on the vault or would I do better just exporting my 'important' photos on a monthly basis?


    Some Bloke (over there)

  • Thatblokeoverthere Level 1 (0 points)

    24 hours on. The HDD is still grinding but the VAULT backup is still not complete and Aperture is still locked up.

  • danamay Level 1 (0 points)

    did you ever get an ans to how to get your vault to back up - I am now having the same issue!

  • Dennis A. Livesey Level 1 (0 points)

    I had the slow updating Vault issue recently myself.


    I did the steps of deleting the Vault HD, formatting that hard drive, running Aperture permissions, creating a new Vault path, and then making a new vault.


    I have about 1.1 TB of images. It takes about 16 hours to create the new vault. Patience is a virtue. I have done this twice since I keep one vault off site at all times.


    Apeture is fine, you just need patience.