11 Replies Latest reply: May 10, 2012 9:45 AM by rapasc
chitownquilter Level 1 Level 1 (0 points)

Unable to edit one page number in my iBook. There is a red triangle and text where the number should be? How do I get rid of the text?


MacBook (13-inch Aluminum Late 2008), Mac OS X (10.6.8)
  • Old Toad Level 10 Level 10 (128,695 points)

    What iPhoto version and theme are you using?  Where are you seeing this problem: in iPhoto?, in a PDF preview of the book or both?

     

    Can you post a screenshot of the area.

     

    As a first fix attempt try this:  make a temporary, backup copy (if you don't already have a backup copy) of the library and do the following:

     

    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home()/Library/ Preferences folder.

     

    2 - delete iPhoto's cache file, Cache.db, that is located in your

         User/Home()/Library/Caches/com.apple.iPhoto folder. 

     

    Click to view full size

     

    3 - launch iPhoto and try again.

     

    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.

     

     

    OT

  • rapasc Level 1 Level 1 (0 points)

    This solution did not work for me...I have 58 different  books i am producing...all have some pages where the text from the page in the page number field. I tried deselecting the page number...didnt work. I also noticed that when i go to print, it tells me I have text that doesn't fit, and will bring me to the field. I can delete the text at that point. but I cannot choose the field myself. so if there are only a few characters in the field...I'm stuck.

     

    with it. Help! These books have to be printed this week! iphoto error.jpg

  • LarryHN Level 9 Level 9 (68,415 points)

    To see what the text will look like in the printer book

    Before ordering your book preview it using this method - http://support.apple.com/kb/HT1040 - and save the resulting PDF for reference - the delivered book will match it.

     

     

    LN

  • Old Toad Level 10 Level 10 (128,695 points)

    This is a bit off the subject but are all of these book in one library?  If so then in the future I suggest you use a separate library for each book.  YOu can move the photos you need for them from your main library to them using  iPhoto Library Manager.  That way a damaged library will only affect one book and after purchase the library can be archived by burning the library to a CD or DVD via the Finder (NOT using the Burn button in iPhoto). 

     

    OK, back to the problem.  Try the following on the library: make a temporary, backup copy (select the library and type Command+D) and apply the fixe below:

     

    Fix #1

     

    Launch iPhoto with the Command+Option keys held down and rebuild the library.

     

     

    Select the options identified in the screenshot

  • rapasc Level 1 Level 1 (0 points)

    Hi LN & OT

     

    LN: I am aware, this also is in the preview.

     

    OT: I have an average of 7 books in 5 different libraries....Do you have any idea how long it will take to rebuild? I do have backups...

     

    Also, do you have any idea what is causing this text to go into the wrong field in the first place? Its like it grabs the content from the other text boxes...very strange..

     

    THank you for the quick replies!

     

    rp

  • Old Toad Level 10 Level 10 (128,695 points)

    The rebuild shouldn't take much more that 30-45 minutes depending on how many photos are in the library.  I only have small libraries and the one I rebuild often has 2700 photos and rebuilds in less than 30 seconds with the option in the screenshot above.  I've not tried it with any larger libraries.

     

    I was hoping that the deletion of the preference file would help.  When it gets damaged it can create a variety of strange issues in iPhoto.

     

    Is this happening with all of your books in the 5 different libraries or just that one?  If it just than one then we have to point the finger at that one library.  Select the book in iPhoto and type Commande+D (duplicate).  Then experiment with that copy like unselecting and reselecting the page number option, etc. Can you get the text cursor to appear in that page no. area as if there's a text box there. What theme are you using?  You might try changing the theme  on the book duplicate copy and see if the problem remains or goes away.  If it goes away switch back to the same theme and check that page again.

  • rapasc Level 1 Level 1 (0 points)

    heres the history. This started as one book created for a school. Parents wanted it, so I duplicated the book and renamed per child. As I saw things were getting out of hand, I created (with help from your tutorials!) the 5 seperate libraries.

     

    The problem cropped up somewhere along the way....not certain it is in every library, but is in more than one.

     

    There is a page number text "box" but not that can be accessed manually. The only access is when I go to buy the book, I will get a message that there is text that doesn't fit, and to cancel if I want to correct it. when I cancel, it takes me to ONE of the fields on ONE of the pages. The best I can do is delete the text, but it doesn't fully recognize that I have deleted the text and does not give me a way to move to the next text box/page number.

     

    I have tried deselecting the page number option..no avail.

     

    i will let you know if the rebuild works. Surpised apple doesn't have a fix

  • rapasc Level 1 Level 1 (0 points)

    Add'l note...it is not in every book in the same library, and does not seem to be related to theme or type of book. but if it is on one page in a book, it is on some others as well.

  • Old Toad Level 10 Level 10 (128,695 points)

    That screenshot you posted of the page number shows some kind of text in it.  I have no idea what could have gone wrong to put any text in that area other than a page number. 

  • Peter Joshua Level 3 Level 3 (815 points)

    Have you considered just turning off page numbering?

     

    PageNumbers.png

  • rapasc Level 1 Level 1 (0 points)

    Hi Peter, yes I did that...no avail. I also tried changing the book to different themes and different sized books, and am running the most current version. No go...at this point...i am going to just live with it as i cannot recreate 57 books...will keep an eye out next time...if there is a next time

     

    thanks for all the assistance!