5 Replies Latest reply: Nov 19, 2012 10:09 PM by Rktito
mcfadyensolutions Level 1 Level 1

I have been using snow leoprad and it hangs after  login to the system (from the first one/two minutes). But it works well in safe mode . So far the things I  have tried are - repair the disk permissions, verify the disk , created a  new user account etc.  But  I'm not getting a soluion. Please help!!

iMac, Mac OS X (10.6.8)
  • X423424X Level 6 Level 6

    New account doesn't work?  But boots ok in safe mode?  Ok, post the files in the following folders:






    Also open Terminal (in Utilities) and copy/paste the following line, hit return, and post its output:


    kextstat -kl | awk ' !/apple/ { print $6 $7 } '


    These are all places for third-party add-ons that you may have installed, one of which may be causing your problem.  Booting in safe mode suppresses all this stuff.  So these become the first suspects.

  • Kieran Mcghee1 Level 1 Level 1

    I have the same problem.

    My machine began to freeze (spinning ball, nothing that was clicked on would open) about 1 month ago.

    I though since the machine was 1 and a half years old maybe it needed a system reinstall.

    I tried that, problem persists.

    Also when I restarted, it would take 10-15 mins to get to desktop screen.

    I have been removing my own music files and pics, and have run disk utility from the start-up disk.

    I ran verify and repair disk, which informed me there was corruption on the disk, and duly repaired it.

    But when I restarted, it was fine for 5 minutes then the same problem again.

    The fact that this problem seems to be effecting machines simultaneously, would indicate this is a worldwide problem.

    Any ideas what's suddenly caused this, anyone?




  • mcfadyensolutions Level 1 Level 1

    I did the things as you suggested.  But, /Library/LaunchAgents and  /Library/StartupItems are found to be empty.

    /Library/LaunchDaemons has a file named, com.apple.third_party_32b_kext_logger.plist.


    I tried the command kextstat -kl | awk ' !/apple/ { print $6 $7 } ' in terminal, but it doesn't give any output.

    I have done all these in safe mode.

  • X423424X Level 6 Level 6

    Hmm, that's not good.  Running out of "moving parts".


    No third party add ons but works in safe mode only!    Here's the apple article on what happens during a safe boot.


    Mac OS X: What is Safe Boot, Safe Mode?


    Since third party stuff is rulled out you would think it would be one of the other things mentioned that may be corrupted.  For example, /System/Library/Fonts, font cache.  In other words, font related. 


    Not sure what to suggest at the moment and it's my bed time. 


    Maybe look at OnyX (Maintenance, Rebuild) and rebuild the dyld shared cache and look at other stuff in OnyX that might need rebulding (Cleaning, Fonts, delete font caches).

  • Rktito Level 1 Level 1

    i have same problem either...but mine is worst......in safe boot also hang and running very slow(freeze with speening ball)..its been like this for 3 days...have u solve the problem?? pleasee heeelp