4 Replies Latest reply: Apr 14, 2012 11:59 AM by Fookes
Fookes Level 1 Level 1 (20 points)

I thought everything was ok with iCloud syncing but I seem to now have issues.

 

I created a spreadsheet under Pages on my iPad (3rd Gen) and, after pressing the 'spreadsheet' button to show thumbnails of all docs being worked on, I'm seeing a small arrow pointing upwards on the thumbnail.  Before, I used to see a progress bar updating in the thumbnail (which I presume is updating to iCloud). 

 

Now? Nothing.  The arrow stays and nothing is updated on my iPhone 4.   In fact, a previous version of my spreadsheet is shown on my iPhone with the same upwards pointing arrow but with the whole thumbnail 'greyed out'.  I can't even open it on the iPhone to delete it!

 

Is this a know issue and are there any fixes?  I've tried the usual turning iCloud off and on for both devices but this has not had any effect.


iMac, Mac OS X (10.6.8)
  • Winston Churchill Level 10 Level 10 (90,185 points)

    Unfortunately I suspect your documents have become corrupt. You could try downloading them from one of your devices, all from iCloud.com if it will let you, but this is often not the case.

     

    Going forward, I suggest you keep regular backups of your work by saving to iTunes from the iWork app.

  • Fookes Level 1 Level 1 (20 points)

    Sorry - should read 'Numbers' - not 'Pages'

  • Winston Churchill Level 10 Level 10 (90,185 points)

    Unfortunately, this applies to all types of iWork applications. It may take a little time to get into the habit of making regular backups to iTunes, but once you do this, it is well worth it.

  • Fookes Level 1 Level 1 (20 points)

    This is ridiculous!

     

    I have now established that there are issues with Pages, Numbers and Keynote documents!!!  They surely cannot all be corrupted?

     

    I have managed to salvage an important Numbers Document which I have copied in to iTunes (and subsequently on to my external HD).

     

    To try and rectify the situation I have then turned off iCloud on all 3 apps on both my iPhone 4 and iPad and deleted all documents under each app.  I have then gone on to iWork under iCloud and deleted all documents off there (some of which I noted were not the up-to-date documents I had been working on in iOS).  I had to turn off iCloud regardless to delete a couple of the documents on my iPhone (under all 3 apps) as some documents were greyed out (see original post) and could not be deleted.  As soon as iCloud was disabled it enabled me to remove off the local device. 

     

    Having switched iCloud back on to my iPhone and iPad (and bearing in mind I had deleted all documents off both iOS devices and in iCloud) the greyed out thumbnails re-appear (and cannot be deleted or altered!!!!)

     

    Anybody? Aaaaarrrrrrgggghhhhhh!!!!!!!!