1 Reply Latest reply: Apr 14, 2012 1:58 PM by LaPastenague
Vicky Bilaniuk Level 1 Level 1 (5 points)

Line 0:  I have a 400 GB external Western Digital drive that I leave plugged into an Airport Extreme.  Previously, this worked mostly without a problem.  It took some massaging to get it to work at first (I had to create the backup with the drive directly connected to the computer, and then I moved the drive over to the Airport Extreme and it was fine after that), but after that, it worked forever.  This was in the previous version of the OS that I was running (snow leopard?).  I very recently upgraded to Lion and it seemed to be OK, but then suddenly it gave me an error that said it had not been able to do a backup for 10 days.  I thought "wow, that means it hasn't backed up since I upgraded to Lion." 

 

So I told it to do a backup right away.  It failed with the error "The backup disk is not available."

 

I unplugged the drive and plugged it back in.  No go.

 

I tried to reselect the drive from within Time Machine preferences.  It would not appear and in fact it kept forcing me to go to the Airport Extreme software.  I did this and there was no obvious way to set anything up from within that software.  I left everything as it was ("Enable file sharing" checked, "Secure shared disks" was at "with device password," and it was remembering the password in my keychain). 

 

Go back to Time Machine preferences and the disk still doesn't show up.  Force a reboot on the router, it still doesn't show up.

 

I brought the drive over to the computer and plugged it in directly, and everything was fine.  It did a backup on the spot, it read the backup that was there, the drive showed up, etc.  I formatted it just for the heck of it and started over completely and it was happy.  I did a disk check and everything was fine.  After leaving it on all night to complete a new backup, I unmounted the disk, brought it over to the Airport Extreme, plugged it back in, and now we go back to line 0 and rinse repeat.

 

Can someone please tell me how to get my drive to start working with Time Machine again?


MacBook, Mac OS X (10.7.3), Airport Extreme base station
  • LaPastenague Level 8 Level 8 (45,315 points)

    It should not have worked in the first place.. when you moved it from the PC to the airport extreme.. that is not correct.. I don't know how SL managed to work around it.. but Lion obviously cannot.

     

    You will need to start all over again..

     

    Also note.. the flakey nature of this setup.. according to well respected people here AEBS with USB drive does not give reliable TM backups.. I would pay close attention to what they are saying. Time Capsule is more than a AEBS with a hard drive inside.. although exactly the difference I don't know.

     

    But you can expect the current setup to not work, because it never should have.