Skip navigation

I can't save pdf from Safari

71864 Views 74 Replies Latest reply: Apr 18, 2014 12:00 PM by O2plus RSS
  • cartom1010 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 15, 2013 11:59 AM (in response to Linc Davis)

    Thank you.  This worked.  I am so frustrated with how adobe works on my apple computer!  Hopefully the future will be better with this fix.

  • PanGalacticGargleBlaster Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 15, 2013 12:23 PM (in response to cartom1010)

    This fix worked for me a long time ago. (Thanks again.) At some point along the way, with 10.8 updates and Adobe updates, when I go to save a pdf in Safari, I cannot paste in a file name I want to use into the save dialog box. In most cases, if I try to type in a different name anbd save, the result is a saved pdf that's viewed by Acrobat as a corrupt file and won't open (this isn't 100% the case, it's confusing). So, I end up saving the pdf as whatever name the file is, opening that file in Acrobat, and using the Save As command, at which point i *can* paste in whatever I want for the filename. But then I have to delete the original file, which is a PITA. It's been so long, I can't remember if this was the original problem that was fixed by deleting the suggested files. (which, again, did work as everyone replies.)

  • George Chapman Level 2 Level 2 (300 points)
    Currently Being Moderated
    Apr 15, 2013 1:21 PM (in response to PanGalacticGargleBlaster)

    Thanks for this. I've been fighting this crazy PDF behavior for several months now. This fixed it. What I don't understand is why that file didn't show up in the folder inside Library but when I did a find it said it was there. I deleted from find and now I'm back to normal behavior until the next Adobe upgrade. Figured  out the location problem. It's in Macintosh HD/Library not UserHD/Library.

  • katiejury Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 25, 2013 5:10 AM (in response to PanGalacticGargleBlaster)

    I'm still having problems downloading or saving any PDFs from Safari - I have removed the plug-in you suggest, now I can't even view online, let alone print or save!

  • Soopie Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 1, 2013 8:58 AM (in response to Dansyacht)

    Thanks Dansyacht - following your instructions, it took me no time at all to get Adobe to work in Firefox again - after days of frustration!!  I'm very grateful, thanks

  • gcortes Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 30, 2013 5:51 PM (in response to sacmacguy)

    I just did this today with the latest upgrades and it still works. Thanks for the tip.

  • AxelJump Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 27, 2013 2:42 PM (in response to Wally Himself)

    The problem with downloading PDFs from Safari seems to me to be a Safari problem, not an Adobe problem, since I use Mountain Lion's Preview as my default PDF viewer and I have had the same problem.

     

    Safari's "Save As" action in the File menu doesn't work, and results in the saving of a 1k stub of a file with the target filename. I find that I can save successfully using any of the following methods:

     

    (1) Control-click (or whatever you have configured to perform this function on your mouse or trackpad) on the link to the PDF. Choose "Save linked file as ... "

     

    (2) Click on the link to the PDF. When the file is displayed, you should see an icon bar across the bottom of it. Click on the disk icon and save. This icon bar, however, disappears after a few seconds and it may not always reappear when you hover the cursor over the PDF. The simplest way is:

     

    (3) With the PDF displayed on the screen, hit ⇧⌘S and save.

     

    It shakes my confidence in Apple that they should have a menu item to perform so simple a function and not be able to make it work.

  • George Chapman Level 2 Level 2 (300 points)
    Currently Being Moderated
    Aug 27, 2013 6:06 PM (in response to AxelJump)

    Did u read applenovice's answer on preceeding page? That is where the problem is. Since fixing it, I don't update the Adobe anymore.

  • GeoEngJS Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 27, 2013 6:08 PM (in response to AxelJump)

    If you hover your pointer over the pdf file that is showing in Safari, and move it towards the bottom of the screen, a phantom set of icons will appear that allow you to save or print the pdf file.  Pretty simple.

  • montom Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 9, 2013 10:42 AM (in response to sacmacguy)

    Thanks so much - this worked for me after days of frustration!

  • tornado_200685 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 7, 2014 3:50 AM (in response to AppleNovice)

    Thank you! It works! It was hard to find and understand the reason.

  • Raymond Greenwell Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 21, 2014 11:20 AM (in response to sacmacguy)

    I'm also grateful to you, sacmacguy! I recently switched from Chrome to Safari as my primary browser, but had to switch back to Chrome to download pdfs. Now I don't have to any more!

  • guyku Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 9, 2014 10:58 AM (in response to sacmacguy)

    Almost two years later and STILL HELPFUL! Been struggling with this for about that length of time. Thank you, sacmacguy!

  • kimginn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 16, 2014 9:50 AM (in response to rogerfromswansea)

    My 'translusent icons have been there all morning, and I have been saving PDF documents for a project, and now that capability is gone, and that includes previous pdf's I'd already worked on.  How can that ability to save disappear?  Did I hit some setting that 'hides' it?

    Kim

  • O2plus Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 18, 2014 12:00 PM (in response to Wally Himself)

    Now, two years later with OS X 10.2.9 and Safari 7.0.3, this same problem persists!  The procedure of sacmacguy was the solution for me:

     

    In Finder Go to:  Macintosh HD/Library/Internet Plug-Ins and look for "AdobePDFViewerNPAPI.plugin" and move it to Disabled Plug-ins Folder (if you want to keep it).  You will have to remove this file from the Internet Plug-Ins folder altogether.  (I put mine in the trash)

     

    though I note that no "Disabled Plug-ins Folder" existed in the Library folder (I created one on my desktop and moved the "AdobePDFViewerNPAPI.plugin" into it--just in case).  After restarting Safari, the pdf file was still able to display in Safari, but now Safari's menu "Save As" function actually worked to download the complete file.  Moreover, the cryptic "download" icon that displays if I hover my mouse over the lower center of the display also works to download the pdf file (with its original filename).

    Mac mini (Late 2012), OS X Mavericks (10.9.2)
1 2 3 4 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.