6 Replies Latest reply: Apr 16, 2012 6:03 PM by springbunny
springbunny Level 1 (0 points)

I just received a nice iBook G4 800. It only has one flaw: the trackpad works erratically when I turn on Trackpad Gestures > Clicking. Even though I selected "ignore accidental trackpad input" it still is odd. If my hands are anywhere NEAR the trackpad while typing, the cursor just flies off somewhere unwanted on the page. It is insanely over sensitive. How can this be fixed? Love the iBook otherwise. Trackpad is better when I turn off Gestures > clicking - however that means I have to use the clicky-button behind the trackpad which plays havoc with my carpal tunnel (and no, I can't use a mouse, I lose feeling in my hand from a mouse.) Help?  (running os 10.4.11  tiger)

Mac OS X (10.4.11), iBook G4 800
  • Kenichi Watanabe Level 7 (33,116 points)

    Did you previously use a non-Apple USB input device, where you had to install a custom device driver (system kernel extension)?  Oh, I guess this iBook is new to you, so you probably don't know...  I'm thinking there may be a driver conflict with the built-in trackpad.


    One way you can test for this possibility is to start up from your Mac OS X installation disc.  When you get to the Installer screen, does the trackpad tracking still act erratically?  If it acts normally, then the problem is somewhere in your currently installed system


    If you don't have a Mac OS X installation disc, you can do a more limited test.  Create a new user account (in System Preferences Accounts pane), log out and log in to the new user account.  See if this problem recurs in the new account.  This won't eliminate the possibility of a conflicting device driver, but if it works properly in the new account, that means there is something in your usual user account that is causing this problem.

  • Kenichi Watanabe Level 7 (33,116 points)

    Thought of a better way, if you don't have a Mac OS X installation disc.  Restart with the Shift key held down.  This starts up in Safe Mode




    Only required Apple system extensions will load.  So if the trackpad works properly in Safe Mode, there is probably a third-party system extension installed that is causing the problem.

  • springbunny Level 1 (0 points)

    Thank you for helping.


    I tried safe mode first - but my ibook doesn't like that. :-(  When I held down the shift key it would get to the apple icon and the spinning thing - then suddenly shut down. I did it again, this time letting go of the shift key before the spinner showed up - but it still shut down the computer. I powered up again without the shift key and was glad to see my computer start up.


    I do have the installation disk for Tiger (universal) - and I had done a totally clean install when I received this nice little ibook. I don't think I could test the behavior of the trackpad by booting from the disc, as this wouldn't allow me to open up something to really do much typing in. I have to be typing for a little while (like in this forum box, or in a word processor, or email, etc.) and suddenly the cursor will jump awy from where I'm typing. It is like it sees my thumb barely hovering over the trackpad when it should not. Even when I try to keep my hands totally away from the trackpad while typing, it will sometimes make that jump. Then the cursor ends up inserting my typing whereever it jumps. I've turned off the ability to tap the trackpad for the time being.


    I will test that other user idea you have - it is worth a shot. Be back after I try that out.


    Thank you again for offering help.


    Oh - a side note - I'm going to google to see if there are any sorts of external trackpads that might plug in. I do have a drawing tablet which I have not installed with this computer yet - but dragging the pen tool around with a laptop is a bit impractical.


    PPS: Forgot to mention that I have not installed any other device drivers on this ibook. I didn't even install the drawing tablet yet.

  • Kenichi Watanabe Level 7 (33,116 points)

    If it has a clean system installed since you received it, it would not be related to a system extension conflict or something running in your user account (unless you installed third-party software since the clean install).


    I found this Apple article, with more possibilities (including some things already considered).




    Three items may be relevant.  One is Reset the Power Manager (PMU), which is this procedure




    Another is to apply a "teflon" trackpad surface protector, which may make it less sensitive.  The last item is a possible hardware problem.

    I'm going to google to see if there are any sorts of external trackpads that might plug in.

    Have you considered a trackball, such as the large square one made by Kensington.  It seems to be popular with people who don't like the using a mouse due to repetitive stress.

  • springbunny Level 1 (0 points)

    Thank you again for your help.  You've been a real help on understanding what is happening with the trackpad.


    I have zapped the PRAM, and the PMU. No luck, but good that I learned how to do that.


    That article was really intersting - and the linked article about erratic trackpads was also helpful.


    It seems if I am super careful about keeping my thumbs and wrists very far away from the trackpad it behaves much better. Unfortunately, I'm a touch typist and that's not a very easy way to type efficiently. I may just turn it on and off. When I'm just reading, I can have the tapping turned on and it won't jump around. When I'm typing something, I'll have it turned off so it doesn't interupt me. That may be good enough for now.


    I am going to look into that teflon pad idea. I'd never heard of it before. Hope it might work (and be inexpensive).


    The external trackpads look interesting, but they're far too expensive for me right now.


    The trackball is a neat idea, but it may not work for me personally - as it seems when anything is cupped in my hand (like a mouse, ball, or anything I grab) it triggers the numbness and tingling sensation. The trackpad is pretty nice since nothing touches my palm. I can live with using the button better than I can live with a mouse again - so I'll just make it work until I can rig something better.


    Thanks for the effort you made in helping me resolve this. I sincerely appreciate your help.

  • springbunny Level 1 (0 points)

    PS: I tried a piece of paper over the trackpad to simulate the teflon film as the article recommended. That was not an improvement. In fact, it made a noticeable lag between typing and the appearance of the words on the screen. Plus, the cursor still managed to jump. I guess the teflon won't solve it for me. Maybe this is really a hardware issue after all.