Previous 1 2 3 Next 93 Replies Latest reply: Dec 25, 2015 10:36 AM by adestefMac Branched to a new discussion.
paula185 Level 1 Level 1

Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAg ent" has been modified and will not be repaired.

 

<Subject Edited by Host>


iMac, Mac OS X (10.6.8)
Solved by Niel on Apr 16, 2012 9:20 AM Solved
That's normal. Ignore it. (65670)
Reply by anthonybperez on Dec 29, 2012 9:40 AM Helpful
crap my mac pro has the same issue.
Reply by anthonybperez on Dec 29, 2012 9:19 PM Helpful
Just figured it all out, and it worked.And my repair also fixed some permission that cant on coming back. Thanks.

All replies

  • Niel Level 10 Level 10

    That's normal. Ignore it.

     

    (65670)

  • paula185 Level 1 Level 1

    thank you

  • estebaan Level 1 Level 1

    I recommend back up your mac and then install your system from original DVD and then load your data back with migration assistant.

     

    We had it on Mac Book white and it is only question of time, when problems will come.

    F.e. after restart we were waiting approx. 45-50 min. to get in, some applications did not work properly etc.

     

    Now is everything OK.

  • varjak paw Level 10 Level 10

    Sorry, but your advice in this case is misguided. As Niel said, the message about the SUID file is a normal status message and not an indication of problems. Reinstalling, or any other problem solving, is completely unnecessary.

     

    http://support.apple.com/kb/TS1448

  • Sonnyonbass Level 1 Level 1

    Could be a coincidence but my iMac is getting unresponsive as well. Repaired permissions and this popped up.

    After a restart it took ages to function properly.

    Wierd.

  • varjak paw Level 10 Level 10

    I can't say anything about the permissions on your system or what might be causing your system to function incorrectly since I know nothing about your system or situation, but again, this particular message about the SUID on the ARD agent is completely normal and not an indication in and of itself of anything amiss.

  • Bottleworks Level 1 Level 1

    My MBP just started getting this error and it also has started slowing way down.  Don't ignore the error.  It's clear there is a relation. 

  • varjak paw Level 10 Level 10

    You are wrong, Bottleworks. The SUID warning for the ARD agent is completely normal and not related to any slowdowns you may be experiencing.

  • Bottleworks Level 1 Level 1

    Despite what you say, the facts are pointing to you being incorrect on this issue.

  • varjak paw Level 10 Level 10

    I have no idea what "facts" you are referring to, but suit yourself. If you won't believe two highly experienced users and Apple themselves:

     

    http://support.apple.com/kb/TS1448

     

    that's up to you. But if you spend a lot of time trying to fix the SUID warning, you'll just be wasting that time.

  • David Vincent Level 1 Level 1

    Thank you for posting the link to TS1448.  That item says 'products affected' includes 10.6.  I am getting the same behaviour with 10.7.4.  Can we safely assume it still applies?

  • noondaywitch Level 6 Level 6

    Yes.

  • Joseph Kriz Level 5 Level 5

    I know this question has been sort of answered but not properly in my opinion.

     

    There should be no permissions to repair once they have been repaired.

    There should also be no permissions that can't be fixed especailly by Apple.

     

    Many computers have seen this:

    "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAge nt" has been modified and will not be repaired."

     

    To me this is not normal even though Apple may say it is.

    Not all computers have this so why do some other computers show this problem?

     

    I have fixed this on my computers as I can't stand to have things like this show up when they shouldn't.

     

    I replaced the problematic ArdAgent by using a copy from another computer that did not have that warning.

    Once, replaced, I got the message in Disk Utility when I repaired the permissions with this new one:

    Permissions differ for:

    System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgen t

    should be "0" instead of 501 (or something like this)

    Then it states those permissions were repaired.

     

    Now I no longer get that stupid warning about the ARDAgent.

     

    For those of you that want to get rid of that warning, try using a copy from another computer running the same system.

    Worked for me.

     

    I also repaired a few other permissions that always kept coming back even though Disk Utility said they were repaired.

    Hogwash.

    If it was repaired then the same exact ones wouldn't be coming back everytime you repair permissions.

    In my mind, there should be no permissions to repair once they have been repaired.

    Otherwise, they were not fixed or repaired in the first place.

     

    I now no longer have any permissions to repair unless I may install something new that might need repair.

    Good luck with your mileage.

     

    This is how Disk Utility should look like without any permissions to repair once you have repaired them one time, and one time, only.

    Screen Shot 2012-11-14 at 9.39.19 PM.png

    Clean bill of health.

  • anthonybperez Level 1 Level 1

    Would it make a diference if I get the copy from my mac pro?

Previous 1 2 3 Next