13 Replies Latest reply: Feb 8, 2015 11:22 AM by guillevelasco
Boece Level 5 Level 5 (6,245 points)

Apple has a KBase article about configuring other mail apps, such as Thunderbird, to use iCloud iMap email:

 

http://support.apple.com/kb/HT4864

 

I found that there are two outright errors in this and one tip that you might have to do to make things work in Thunderbird.

 

First, after moving from MobileMe to iCloud, change your password. Even if your old password met the criteria of at least 8 characters, one number, and one Capital letter, change it anyway.  This will perform a soft reset on your email account.  Without this reset, many old accounts won't work with Thunderbird, even if they work fine with Apple Mail on Lion.

 

Then the KB instructions below have to be changed slightly, see bold:

 

IMAP (Incoming Mail Server) information:

 

    Server name: imap.mail.me.com

    SSL Required: Yes    Connection Security: SSL/TLS      Authentication: Normal Password

    Port: 993

    Username: example@me.com (use your @me.com address from your iCloud account) Don't use the @me.com part here!

    Password: Your iCloud password

 

SMTP (outgoing mail server) information:

 

    Server name: smtp.mail.me.com

    SSL Required: Yes

    Port: 587

    SMTP Authentication Required: Yes  Authentication Method: Normal password / Connection Security: STARTTLS

    Username: example@me.com (use your @me.com address from your iCloud account)

    Password: Your iCloud password

  • Peter Days Level 1 Level 1 (0 points)

    Thank you very much. I was almost crazy to figure out how to put the email working but with your tips, everything turns easy.

     

    Pedro dias

  • rnegron57 Level 1 Level 1 (0 points)

    Thanks for the tips!  This works great!   Now if only Apple would update their info...

  • Csound1 Level 8 Level 8 (40,325 points)

    rnegron57 wrote:

     

    Thanks for the tips!  This works great!   Now if only Apple would update their info...

    I hope not, if Apple update their info to match then everyone will be sending e-mail in the clear instead of securely. No thanks, it's time Mozilla fixed Thunderbird.

     

    It's insecure enough without disabling SSL/TLS.

  • RocKKer Level 1 Level 1 (0 points)

    I know this is an old thread but -

     

    According to this: http://security.stackexchange.com/questions/7822/email-ssl-security

    and this: http://superuser.com/questions/279138/secure-email-sending-with-thunderbird

     

    ...the entire email session is encrypted when using SSL/TLS. So when Thunderbird sends/receives userid, password and email they are all encrypted.

     

    Don't let the "Authentication: Normal Password" setting scare you, everything that is sent/received will be encrypted before being sent, so there is no need for any additional encryption of the password so it is sent "normal". This is how most email servers are set.

     

    Apple's email server (or any server, email or otherwise) controls which client(s) are allowed to connect and how. Encryption is controlled by the SSL/TLS configuration on Apple email servers. If Thunderbird (or any email client) is NOT set up correctly it absolutely will not be allowed by Apple's email server to connect, period. It has nothing to do with Thunderbird being "broke" (it's not).

  • Csound1 Level 8 Level 8 (40,325 points)

    Why are you posting this to me?

     

    I was not in any doubt, and the posters who were left months ago.

  • cybermat Level 1 Level 1 (0 points)

    Worked for me too, great tip. It was time anyway to change my old PW.

  • djoyce8 Level 1 Level 1 (0 points)

    Thank you, thank you, thank you. Worked like a charm.

  • abrahamleon Level 1 Level 1 (0 points)

    Thank you very much, even now 2 years later you need this settings in order to make Thunderbird work.

  • Cubanero Level 1 Level 1 (0 points)

    Doesnt work for me. It always asks me for password. Nevertheless, manually setup of usernames from settings after the setup wizards has finished works.

  • peak_performer Level 1 Level 1 (0 points)

    This setup almost worked for me, with a few tweaks. SMTP now requires SSL/TLS, but still uses port 587. I had to go to advanced settings to change this. That, and the usernames were both without @icloud.com or @me.com, depending on which one you use for your email. Other than that, great starting point, saved me some time.

  • venician Level 1 Level 1 (0 points)

    This may have worked at one time.  Is it still working for anyone?  using Thunderbird 31.3.0

    The settings seem to autodetect but no combination of using or not using the @me.com seems to work.

  • j03d Level 1 Level 1 (0 points)

    The above does not work for me.

  • guillevelasco Level 1 Level 1 (0 points)

    (Originally in Spanish, I'm sorry if the translation is not perfect. Thanks to Ian C.)

    Setting up a mail account iCloud does not support Thunderbird settings. This app uses a different folder map that used by iCloud, so you have to make some small changes.

    First of all, if you have previously tried to install iCloud account with insactisfactorious results, it is recommended before deleting the account from Thunderbird, and delete any file on that account:

    {user} / Library / Thunderbird / Profiles / xxxxxxxxxxx / ImapMail /
    imap.mail.me.com (folder)
    imap.mail.me.com.msf

    Then:

     

    1. Configure iCloud account in Thunderbird.

     

    It's a little more complicated than it should. This is not Apple's fault. They work well with their own email program (Apple Mail), and they don't need to change their configuration for a third party program. Therefore it is something that should be corrected for future versions of Mozilla Thunderbird.


    – New email account > name, email and password
    Messages:
         ... looking configuration: your mail provider

         ... based ISP ...

         ... trying usual data server names ...

         ... default Thunderbird "proposes " a configuration.

     

    The default data show like this(WRONG):

    Incoming: IMAP Server Name: .icloud.com *
    Port: Auto
    SSL: Auto Detect
    ID: Autodetect

    Outgoing: SMTP Server
    Name: .icloud.com *
    Port: Auto
    SSL: Auto Detect
    ID: Autodetect
    Username: Incoming: {username}
    Outgoing: {username}
    • NOTE: .icloud.com IS NOT VALID. It must be:
    Incoming: imap.mail.me.com (including imap.)
    Port: 993
    SSL: SSL / TLS
    ID: Password Normal
    SMTP: smtp.mail.me.com:587 (by putting the following options and disappear)

    Identification : Password standard in both inbound and outbound.
    Names, let them without @icloud.com

    You can press OK now.

     

    2. Folders structure


    Thunderbird automatically creates files in the aforementioned path where we erase all traces of the previous configuration with only 4 files:

    Drafts.msf
    INBOX.msf
    Sent.msf
    Templates.msf

    On the website of iCloud: https://www.icloud.com/#mail deposite yourself an email either in each of the folders: Inbox, Drafts, Sent, Archived, Trash and Spam. For this to work, there must be at least one file in each folder, including drafts (Drafts), we can move any mail, and if it is "virgin" account, with no messages, create multiple drafts by yourself, save them and move to each of the other "basic" folders, which has its own icon in iCloud. Other way, Thunderbird does not show that folder because it thinks that folder does not exists or is not used.

    Click OK in the Settings window, quit Thunderbird and reopen it. In doing so the program reads back the files from the server iCloud.

    Thunderbird, by default with an account, create a folder structure. These do not match the iCloud.


    Thunderbird / iCloud (ok):

    Archives / Archive
    Drafts / Drafts
    INBOX / Mailbox
    Junk / Junk
    Sent / Sent Messages
    Templates / -not exists-
    Trash / Deleted Messages

    If we not previously changed the IMAP root folder from Thunderbird, maybe other folders that were previously created may be displayed is them were not entirely eliminate, either by caching or for any other reason.

    The problem is that if we select Thunderbird he select folders "default", he goes CREATE its own folders, with the Thunderbird-style names, not with those who iCloud recognized as good. This means that, for example, display a "Thrash" folder in the iCloud web, and a "Deleted Messages" in Thunderbird (as the other types any other relevant). Since we can not CREATE the correct folders because if you try to do that, iCloud tells us that ALREADY THERE, let them inside ANOTHER FOLDER:

    For example, create a folder that call "hello" (or any other). Within create the following folders: Archive Drafts Sent Messages Deleted Messages

    In Thunderbird, do this: click Settings > Server Settings > Advanced ... For the "iCloud" IMAP server directory features: hello

    By the way, un-check "Show only subscribed folders".

     

    (Remember to quit Thunderbird each time you make any change to be shown, them are not instantly displayed)

     

    We can see, while we are changing emails from the web in iCloud, as they appear different messages in each folder, to see how it behaves.

    Already changed ROOT IMAP and created the folders with the correct names, proceed to link them:

     

    1) In Server Configuration > Server Settings > When you delete a message: Move it to this folder: Deleted Messages in iCloud.

     

    2) In Conf. > Copies & Folders, we must make one by one by selecting the folders with the correct names:

    – When sending messages, automatically: Add copy: Other: Sent Messages in iCloud

    – Archives, Save message files: Other: Archive – Drafts and templates

    – Drafts (this being the only one that match between TB and iCloud, so use the default).

    – Templates, there's not that folder in iCloud, then create one for that function, both in iCloud root folder, and inside the folder hello that we have provisionally created, named Templates.

     

    3) In Spam > Destination and retention > Move messages to spam: Folder "spam" in: iCloud. Here both the same name: Junk, so no problem.

     

    Click OK. Exit and re-open Thunderbird. If you have not left loose folders assigned to something, you delete or change to a site outside of hello. We'll see then where to place them.

     

    When we back to Configuration, we will see only this folders:

    – Inbox (Because it is the "root" this "folder" is not shown in iCloud)

    – Drafts

    – Templates

    – Sent Messages

    – Archive

    – Deleted Messages

     

    Well, if there's everything "clean" now, we can back to change the IMAP ROOT to the iCloud root folder. So we go to Conf. > Config. server > Advanced ... and remove the word hello from where we had set. OK. OK. GET OUT. Back into Thunderbird.

     

    Folders previously created by us now are into a folder named "hello", within which are all those listed.

    It could be that appeared a new folder called Notes. This is because if we turned off the option to synchronize notes in iCloud (both PC and mobile), iCloud makes notes in a folder visible in the email account, but not from Apple Mail or from the website of iCloud. Forget it.

    Now you might have correctly configured each folder between iCloud and Thunderbird.