Skip navigation

error code -50

18641 Views 22 Replies Latest reply: Jan 6, 2014 12:09 AM by SHADYZZ RSS
1 2 Previous Next
tsunamijack Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 17, 2012 10:45 AM

I sometimes encounter an "The operation can’t be completed because an unexpected error occurred (error code -50)" message when trying to copy large video files from one external disk to another, and when erasing large video files—or folders containing them—from external disk drives.

 

What causes this? How can I correct or get around the error in order to complete the copy or erase operation?

  • ds store Level 7 Level 7 (30,305 points)
    Currently Being Moderated
    Apr 17, 2012 11:09 AM (in response to tsunamijack)
    -50paramErrError in user parameter list

     

     

    https://support.apple.com/kb/TA22339

     

     

    Use exFAT not MSDOS (FAT32) for your external drives to work with PC's or use OS X Extended journaled for only Mac use

     

    changing the format will erase the data, so remove it first or use another drive to transfer too later

     

    read why here, your likely going over the 4GB file size limit or have bad characters in the file names

     

    Drives, partitions, formatting w/Mac's + PC's

  • ds store Level 7 Level 7 (30,305 points)
    Currently Being Moderated
    Apr 17, 2012 2:06 PM (in response to tsunamijack)

    I don't think DU can handle 2TB and 3TB drives, all I can think of it's bad sectors on the drive and when you go to copy large amounts....

     

    Use Disk Utility Erase Free Space option, however it might not complete, one other tried that and it didn't work on his 3TB drive so I suggested he partiton it 3x, then zero each then format the whole drive.

     

    These large drives are causing a problem lately with Mac's it seems.

     

    Don't know why really.

  • fane_j Level 4 Level 4 (3,655 points)
    Currently Being Moderated
    Apr 17, 2012 2:41 PM (in response to tsunamijack)

    tsunamijack wrote:

     

    I sometimes encounter an "The operation can’t be completed because an unexpected error occurred (error code -50)"

    One of the causes of this error is a file name containing an illegal character (eg, solidus) being copied over the network, but that doesn't seem to be your problem. At any rate, I regard Finder as unreliable for copying large amounts of data. Try ditto and see if you get any errors with it.

  • shafiq786110 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 5, 2012 12:44 AM (in response to fane_j)

    Any more updates on this?

    Im having the same problem, i used this forum's steps to see if i could fix the problem, the transfer got further but then came up with the same error again http://forums.macrumors.com/showthread.php?t=1078212

    I had to change my HDD from MBR to GUID which got it further but im now back at the same problem again

    Any help would be appreciated, im using a 3TB external hard drive

  • Ncat Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 8, 2012 1:14 AM (in response to shafiq786110)

    Hi All,

      Likewise - does anyone have any other thoughts on this error.  I've had some major problems lately associated with this - I run all my iTunes media from external drives and a couple of weeks ago I started to encounter errors which resulted in Orphaned Files on my external drive.  I was running out of space so purchased a new external Firewire/USB disk (4Tb) and copied over all my files, then something happened which orphaned all the files.  Thought it was a bad disk so purchased a different make and I've been in recovery mode every since.  However, for no reason I've started to get this "error code -50" when trying to do anything on my new external drive - even trying to create a new folder so I know it is not a copy or filename issue.

     

      I unmounted the disk, though I had to force eject because something had it locked, powered off the device and restarted and everything was fine - for a while and then it did it again.

     

      Any thoughts/help/ideas much apprecaited before I lost all my media again :-(

  • Jacob6 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 4, 2012 12:58 PM (in response to tsunamijack)

    i get an error with some songs when syncing to my iphone, what causes this? HELP

  • shafiq786110 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 4, 2012 1:01 PM (in response to tsunamijack)

    The error for me occured because my hard drive was faulty, it had a few bad sectors on the drive itself. A quick call to the company who i bought it from got me an exchange and removal of the error     

  • somanna Level 1 Level 1 (110 points)
    Currently Being Moderated
    Nov 9, 2012 6:23 PM (in response to shafiq786110)

    Hello Shafiq,

     

    I have been facing this error 50 'demon' since yesterday. I do not know what will be the fate of the precious projects I have on it. You said that it was a faulty drive that was responsible for the issue. How long did you use your drive before you starting getting this error 50 problem? Okay, you got your drive replaced by the company, fine...but what about your data stored in the damaged drive? were you able to retrieve it?

  • shafiq786110 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2012 5:46 AM (in response to somanna)

    Hi Somanna

    It was actually a new drive with a bad sector, so luckily there wasnt too much data on there

    Nontheless i recovered the data by plugging the drive into an ububtu distribution and copying all the data off to my server. It took a very long time to transfer 50GB of data, usually on the USB3 drive that i had, it would take no longer than 20 mins, this took 4 hrs :/

    But a linux distribution should help with the data recovery. Ubuntu is especially good at that

    I didnt even have to install ubuntu, i just ran it off a USB on a windows PC i have

  • somanna Level 1 Level 1 (110 points)
    Currently Being Moderated
    Nov 11, 2012 9:21 AM (in response to shafiq786110)

    Looks good! Could peppermint of linux help in retrieving the data? I have one CD of linux peppermint with me.

  • shafiq786110 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2012 9:35 AM (in response to somanna)

    I think so

    Im a computer tech and i never use anything but unbuntu when it comes to retrieving data from damaged sector drives. Peppermint should work but previous experience says ubuntu is the best at it

  • somanna Level 1 Level 1 (110 points)
    Currently Being Moderated
    Nov 11, 2012 5:45 PM (in response to shafiq786110)

    Can we get a feee download of ubuntu? Can this ubuntu help me to retrieve files from my external drive which is in Mac extended journal format?

  • shafiq786110 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 15, 2012 4:23 AM (in response to somanna)

    Yep Ubuntu is free. Their website is really helpful with guides for creating the discs from downloading the ISo or also creating a bootable USB.  Sorry for the delay in replying!!!!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.