Previous 1 2 Next 22 Replies Latest reply: Jan 6, 2014 12:09 AM by SHADYZZ Go to original post
  • somanna Level 1 (110 points)

    Hello Shafiq,


    Thanks for this info. I don't know how, but finally I was able to get rid of the error-50 problem. I guess it was an image I had imported into an event which was the cause of all my problems. I was able to delete this image and every thing became 'normal' again.

  • somanna Level 1 (110 points)

    Oops! This error-50 has once again resurfaced to torment me.


    Yesterday I had imported my audio CD into iTunes [in fact my Mac does not even give me the permission to open the music files with any other player!]; I had, upon advise from this forum, imported the audio onto my Seagate ext drive and not to my Mac's int drive. Next, I had copied and pasted the imported CD songs from this Seagate to another ext drive, a LaCie.


    After doing this I wanted to shutdown by Mac and tried to eject the Seagate ext. I could not do it, and a pop-up informed me that it was due to error-50. Ugh! This demon has come again to haunt me! As I had to go to sleep, I simply put the display to sleep and slept.


    Today, when I tried to eject the drive I got these notices and I had to force eject the drive:








    Well well well, I am again in a well! Wonder why this is taking place. It seems to me that iTunes is the culprit which is casting me into the error-50 well over and over again.


    I would like to hear from knowledgeable members about what this problem is all about and how to deal with this problem once for all.

  • shafiq786110 Level 1 (0 points)

    The only thing left to do to see if the error is hardware or software is to do a clean install of OS X. Its a pain i know but it would involve manually backing up your data by a drag and drop method, if you can, and then manually reinstalling your programs back again. Keep a time machine backup as well because if the error persists after the clean install, then you can always revert back to the time machine's backup in the knowledge that there is definately a hardware error on one of the devices

  • somanna Level 1 (110 points)

    Thanks for your reply shafiq. The task appears intimidating. I had, based upon my earlier tryst with thus problem, done this thing which iTunes advocates: use the parenteral controls under iTunes preferences to first check and then uncheck the iTunes connection to the store. After doing this stuff, I have not had the time to see whether the problem has gone away but will do so now. I need to open FCPX and then I will know whether things are fine or not. Shall let you know.


    Take care. Cheers. Have a great day. [Hope I too will have one!]

  • DitzlerPhoto Level 1 (0 points)

    I saw a thread here that helped me.



    I spent a few moments carefully deleting the .AppleDouble directories from one of the directory trees that would not properly copy over.  Once that was fixed, I was able to properly copy the files via the finder.

    good luck.

  • oldpapamoose Level 1 (0 points)

    I ran into the same problem with a WD external hard drive. Finally it turned out that "error code -50" was its nerdy way of letting me know that it needed me to enter a password to access the hard drive. I opened "WD Unlocker," entered my password, and, voilà, no more error message.

  • infogeek2 Level 1 (25 points)

    I got  error code -50 when I tried to delete files on an external HD used for backup. I could read, write and copy the files okay. I could not use Disk Utility > Repair Disk as the volume would not unmount, even after booting from the Recovery Disk. The Repair Permissions button was greyed out. After shutting down the computer and removing the external HD from its enclosure, I noticed the HD worked normally using a different cable connection. I cleaned thoroughly the external HD drive bay and enclosure which were very dusty. The external HD in the enclosure performs normally now.

  • SHADYZZ Level 1 (0 points)

    Just got this -50 error when trying to move files from an external drive to the trash,  for the second time in my life.


    This is how I fixed it.


    1: Eject all drives: external, thumb, etc... For me, one drive would not eject  and returned a warning which said the drive was still in use. Just close the dialog box, don't try to eject again.


    2: Quit all applications.


    3: Power off Mac.


    4: Power off all drives and wait for 30 seconds until they wind down completely.


    5: Power on Mac.


    6: Power on drives.


    7: Delete files.


    VOILA, it works.


    Hope that helps some people as this error keeps popping up over the years. Don't delete or reformat anything if you don't need to, typically it's SOME system resource still using a file or directory on the drives that you're trying to delete the file from.



Previous 1 2 Next