Previous 1 2 3 4 Next 56 Replies Latest reply: Oct 16, 2015 2:02 PM by hugh251 Go to original post
  • mighty-sherminator Level 1 Level 1

    I've had this same problem going on for awhile, and it's not an isolated incident. I've read on many, many forums of a lot of MBs having this same issue. I wish Apple would figure out a real fix and distribute it.


    Apparently the headphone jack is stuck in digital/optical mode or something... I've found that I if I plug in my earbuds, open the sound preferences panel, then unplug the ear buds, it works again. Like it's resetting the digital switch in the input jack.

  • LightDJ Level 1 Level 1

    I have a similar problem, suddenly about once every other month I lose sound everywhere usually after waking up from sleep mode. I solve it by restarting, however Im afraid one day the restarting wont work anymore.

    I just hope its a software bug that can be solved via update and not a hardware issue, since my macbook pro might not be serviced since I replaced the optical drive and stuck in an ssd.

  • xtoned Level 1 Level 1

    I have this same problem since 2 hours ago. Was gonna post another thread but 60herz also has same problems as in my macbook. It happened once sometime back, and a restart fixed it. But this time restart din't work. Also tried connecting and removing the headphone, sound ouput device changes from headphone to internal speaker when I unplug the headphone, but sound doesn't work.


    - volume icon and slider are working

    - mute button is unchecked, not stuck on mute mode

    - sound output is selected for audio port

    - no red light on audio socket
    - tried different applications


    Will try resetting NVRAM. Please let us know if there's any other method to fix this

  • xtoned Level 1 Level 1

    Removed the power connector, shut down, power on, it worked

  • seavalley Level 1 Level 1

    Same problem this side of the planet. Sherminator's fix does the trick, however it seems like the issue is getting worse. I noticed there is a red light in the audio port when the sound ***** up.


    Macpeople- please send a fix thru the ether asap.

  • seavalley Level 1 Level 1

    All I wrote was c-o-c-k-s up and i got *****ed! Can I say bum or poo?

  • clintonfrombirmingham Level 7 Level 7
    Mac OS X

    3 Brit. informal nonsense: that's all a lot of ****.


    Bet the c-o-c-k gets c-a-u-g-h-t.



  • LouFink Level 1 Level 1

    Greetings. I have a 15" MBP from 2010 unibody style. 2.66 GHZ i7 processor. Thats enough of that jargon. Um... Well... I am having audio issues as well. However, I have only had the red light deal a couple of no sound. Long story short....from what i have read on (which you should def. look at) I need to replace my logic board. I believe you might need to do the same. And oh! I havent tried to reset my pram/ nvram....which i shall do shortly and report back.


    So...part 2. On my old MBP 17" Core Duo (2006) I had many issues with audio, it was always the RED light...but a little paper clip took care of that..just needed to push in that sensor. Also had to replace the logic board on that beast.


    PS (you want to read this)....just to give you an idea of what i mean by BEAST .... Yes... it still works. Slid off dashboard while friend was making me multi-task and he was making a hard left turn simultaneously...with my window open. hit the pavement (we were going 25 mph) and it skidded about 60 or so feet into traffic... i salvaged it...Still on. Still running. (Rhino osx beta) and it still works today./___sbsstatic___/migration-images/188/18869345-1.jpg

  • LouFink Level 1 Level 1

    Totally worked for my 15" MBP (2010). Soooo siked I don't have to replace my logic board.

  • daniel86 Level 1 Level 1

    I was using my internal speakers all morning and I had no problems.  I was using both headphones and speakers and then, this afternoon, I tried to listen to internal speakers and there was no sound.  However, I could hear sound through the headphones but not the internal speakers.  I went to System Preferences > Sound > Output and it showed Digital Output selected; it would not show internal speakers.  I turned the computer off and then on, and the issue persisted.  I rebooted a number of times and still no success.  I was ready to take it to the Apple Store.  Well, decided to do some web search and read some of the posts on this thread and decided to try putting my headphone connector into the headphone jack and twisted it a few times.  The 'Internal Speakers' option then showed in System Preferences > Sound and it now is working fine.  My headphones are from an iPhone and I have had problems with them before on the computer.  So, I assume it has something to do with them.


    Anyway, it appears that there are a number of different issues causing this problem from the variety of posts.  Hope that this helps someone.



  • TheeDT Level 1 Level 1

    Im guesing you resterted the computer? If not I had the same EXACT problem, no redlight in the HeadPhone Jack, no Grey Audio Icon. Just simply no sound what so ever even with headphones in. I just restarted my Mac and it fixed it.

  • mike's username Level 1 Level 1

    so, i'm new to posting to forums, bear with me?

    i work in electronics, and my prob was on a MB 2,1 (not a pro): no sound, grey speaker icon, red digital-audio-light in the headphone jack, no internal speakers option in the sound settings, was using my iphone headphones in it last night - today no sound (and a restart didn't work)


    the fix? sounds too easy, but... i plugged the iheadphones in and out 3 times "quickly" (didnt have to go crazy with it, not 'racing', just intentionally quickly) and the light went out and the speakers worked... there might be a sticking tab inside the headphone jack, and a lil extra movement frees it up... i didn't dig that deep to find out, but that would give the same reaction


    feel free to try it if you have the same issue, of course if you break something, or it doesn't work? not my fault

    but it worked for me

  • BaasBogers Level 1 Level 1

    I had this problem too, on my Macbook Pro(Lion), and when I looked at 'Sound' in System Preferences, my In- and Output were set one LogMeInSoundDriver, some programme I once downloaded. When I changed them back to 'Internal Speakers', it worked again.

  • jjrice997 Level 1 Level 1

    Resetting the PRAM worked like a charm.  Thanks OGELTHORPE!

  • BBlacrosse Level 1 Level 1

    Thank you! I was having the same issue and twisting the headphone connect in the jack totally worked!