Previous 1 2 3 4 Next 56 Replies Latest reply: Oct 16, 2015 2:02 PM by hugh251 Go to original post
  • snappo Level 1 (0 points)

    i have had the same problems to a coupla you. plugged in iphone headphones and now no sound from internal speakers once unpluged. there is a red light in the headphone socket and in system preferences it says digital out. tried you jiggling mike and didnt work and tried restarting and turning off and on and neither worked. when i take headphones out volume icon is grey and if i try to change the volume with F11/F12 its grey and has a little circle with line through under the volume bar. has anyone got any suggestions or encountered something similar?

  • clintonfrombirmingham Level 7 (30,000 points)

    You're 'stuck' in optical out mode. Usually, wiggling around some headphones or gently 'cleaning' the port with something like a toothpick will clear up the problem. See -



  • NoHandJoys Level 1 (0 points)

    Same issue for about 6 Months (2010 MBP)


    I find opening preferences>sound and controlling it from there usually works.


    Sometimes volume control from preferences also becomes disabled.In which case I put some headphones in and tap the volume keys up and down a few time and take the headphones out = usually works.


    Very annoying.

  • bromage Level 1 (0 points)

    Having the same issue also - but 'Sherminator's' worked. I've noticed the infra red on the audio out (headphone socket) stays on if there's an issue. Good place to start to check if having an issue.


    Thanks for the fix.

  • nicoleleedavis Level 1 (0 points)

    I really hope someone can help me with this issue, I just purchased a 2012 macbook pro 13" non retina display.

    and well..... ive had it literally 3 days, ive had some weird issues.

    the system seems a bit clunky... I'm not sure if its just the mountain lion os...

    but now im having issues with the sound, and its really bothering me.

    I'm not new to mac... and my volume and sound are not muted....

    the issue is, there is no sound. and the volume even though it is unmuted... shows a no sound icon below it... a cicrle with a line through it as though the sound cannot work, i took some pictures of what it looks like

    usually this only happens if i have my bassjump 2 for macbook plugged in.

    however i had my bassjump2 off. and havent used it in a day or so and i just had literally no sound at all

    and when adjusting volume the little menu that pops up to show you that you are adjusting volume didnt even show up. I dont really know what to do at this point i only have 2 weeks to replace it, and i dont want to constantly

    struggle with this if it could be a serious underlying cause.

    what should i do? also i should note, my mountain lion is up to date, aswell as safari and every other application.

    and im still having this issue.


    as you can see it is not muted... and it shows this little icon at the bottom and i have no sound.

    restart doesnt fix the issue either.

  • nicoleleedavis Level 1 (0 points)

    ive got this same issue, minus the red light on a brand new macbook pro :\

  • nicoleleedavis Level 1 (0 points)

    i just had my problem solved by calling apple support.

    just go here

    and follow the steps to reset both of these.

    and it should fix your issue

  • ScotteeLP Level 1 (0 points)

    I just had to same issue. I noticed that it happened after I connected the power supply. I unplugged power, audio restored. This must be a bug, b/c when I plugged it back into my macbook pro, the audio didn't dissappear.

  • Darkpsychosis722 Level 1 (0 points)

    Hey guys. I have been working on my 2006 MacBook Pro with OS X 10.7.5 for a while when the sound went out. No red light. I got not sound from either my internal speakers or from the headphones jack. I tried flashing the PRAM and putting headphones in and taking them out with no results. When I would plug in the headphones in System Prefs -> Sound -> Output the Device would change from Internal Speakers to Headphones as it should. Never said Digital out or anything. I could change the volume with the keyboard keys and the volume icon in the top bar. The volume symbol that came up never showed the circle with a line through.


    I was about to go out and buy a USB sound card to get sound back on my Mac. I just started messing with it again today just to give it one last shot. What I found was that in the System Prefs->Sounds->Input for some reason the Mute check box was checked. But it was not checked anywhere else. As soon as I unchecked that. I had sound again. Makes no real sense to me,. But it worked. I just wanted to put that out there for everyone.

  • abadvibes Level 1 (0 points)

    I had the same problem and I think going on Youtube fixed it for me. I say 'I think' because I was doing a bunch of stuff before/during that. I tried the twisting technique, restarting/shuttingdown, going on Sound Preferences and plugging and unplugging the earphones, and even opening Garageband and closing it. None of them worked. Then I was kind of multi-tasking, doing all sorts of stuff on the computer to try to fix the problem and went on Youtube because I thought, what would happen if I actually played something, and it just worked. So I dunno if it was just me going on youtube or something else or a combination of things.


    I'd also like to add, while the problem persisted every time I removed my earphones, iTunes would turn on but obviously the sound didn't work and the redlight was present (on the earphone port). I dunno what THAT was all about...

  • Emism Level 1 (0 points)

    I tried everything all morning - restarting, the terminal code, twisting my headphone jack, RAM reset. Then when all was lost and I was getting ready to take it to a Genius Bar - I tried Mike's 3 time in out and trick and presto sound was back on!!

    Thanks mate!

  • OSXAppleMan Level 1 (0 points)

    Screen Shot 2013-03-20 at 18.47.57.pngSame thing with me!

  • kendel101 Level 1 (0 points)

    if you have ran out of options and you have tried everything else and the red light in your port is still on, try blowing as much as you can into the port, it could be problems with the port that is causing the problems, i have tried everything and didnt work, then i blew into the port and the sound was restored right away. TIP: when blowing into the port and notice the red light flickering, that might be an indication that it is working.

  • Gia- GEM Level 1 (0 points)

    Thanks for the thread. I just had the same problem described here for the first time today on MacBook Pro 2012 running OS X 10.8.3.

    Restart fixed it for me.

  • RicoWulf Level 1 (0 points)

    Twisting the headphone jack did the trick. Thanks for posting.