Previous 1 2 Next 27 Replies Latest reply: Jan 28, 2013 9:24 AM by NoreenB
CavemanCooking Level 1 (0 points)

Until a few hours ago, I had several Google Calendar delegates synced with the iCal app on my iMac.  Now, only one delegate will show up in my list ... all the others are still there on my Google Calendar, and all the delegates show up fine on my phone.

I have tried deleting my CalDAV account and have cleard the library/calendars folder and relanuched iCal, but still only the one account will show up.  PLEASE help ... Ineed my desktop calendar!


iMac, Mac OS X (10.5.8)
  • panettore Level 1 (0 points)

    Same issue here. Just to point that out, I'm using iCal 3.0.8 on a Macbook late 2008 with Mac OSX 10.5.8.

  • panettore Level 1 (0 points)

    And there seems to be a similar issue discussed in this thread:


  • Stace Felder Level 1 (0 points)

    Same issue: multi calendars in iCal as delegates, all but one have disappeared.  Running 10.5.8 and iCal 3.0.8.


    Interesting to note: in addition to the affected account, I have replicated this issue with new user accounts and new caldav accounts on both this machine and another also running 10.5.8 and 3.0.8.  Accounts on a 10.6.8 machines with iCal 4.0.4 seem to be fine, not dropping delegates from existing accounts and seeing/syncing all delegates for new accounts.


    Bottom line is that I don't think it's an issue at our end; rather something changed at Google's and hopefully it will be corrected soon.

  • Salix11 Level 1 (0 points)

    Hi guys, same thing happended to me. There is a great, free program that syncs your google cal and your ical. It was so easy to set up. You download it free, put in your google account and password and that was it. Works great and no more delegates.

    Here is the link:

  • panettore Level 1 (0 points)

    Calaboration seems to do the job. It's just frustrating that you have to use such an old fix...

  • Stace Felder Level 1 (0 points)

    My understanding of Calaboration is that it's a (really old) way of adding read-only calendars.  In my case, anyway, I'm able to add read-only calendars without issue.  It's the adding of writable calendars - through the delegates process - that's posing problems.


    Anyone had different experence?

  • smsuch Level 1 (0 points)

    I'm having the same issue... it only shows the most recent calendar i've created on google calendar, but doesn't show any of the other calendars under delegates....


    Is there a fix for this??? I really want to keep using iCal if possible

  • CavemanCooking Level 1 (0 points)

    How do we get Google to correct it?  Their tech team is impossible to contact!

    Perhaps this is G's way of making our use of iCal obsolete.

  • CavemanCooking Level 1 (0 points)

    I need to be able to have "write" capabilities between my iCal and my Google calendar (which feeds and receives with  my DroidX).  Don't think Calaboration supports that.  A working delegate, however, does!

  • CavemanCooking Level 1 (0 points)

    Well, someone on the Google forums has figured out a work-around for this widespread problem.  Thanks to Level 1 and Jennska for posting this!  BTW, it DOES work if you do it right.  All my Google calendars are back up on iCal and working flawlessly!


    Login to Google Calendar via a web browser (Safari, Chrome, Firefox)

    On the left side, locate Other Calendars click on the triangle to the right of it

    Select Settings from the menu

    Scroll until you find the calendar you want to add to iCal

    Click the calendar name once

    On the Calendar Details page, look towards the bottom for Calendar Address

    On that line, go to the right until you find (Calendar ID:

    Copy just the part after the colon and before the ending parentheses

    Paste it into something (Textedit doc, Word, Stickies, whatever)

    Copy/paste the following bolded text before the Calendar ID:

    Copy/paste or type the following bolded text after the Calendar ID: /user

    You will end up with something that looks like:

    In iCal, select Preferences from the iCal menu

    Click on Accounts

    Click the + button below the list of Accounts

    Give it a description, can be anything you like.

    Enter your user name. Note that if it is not a Gmail username, you need to enter the part also, critical for Apps for Education or Apps for Business that use their own domain

    Enter the password for that account.

    Click the triangle to the left of Server Options

    Copy/Paste the address you created in the above steps into the Account URL: box

    Do not check the Use Kerberos v5 for authentication

    Click Add

    The Account Description name will list on the left side of iCal, with a flip down triangle to see the calendar associated with the url entered.

  • CompComp Level 1 (0 points)

    (re: write capabilities)


    Yes, I found this to be the case as well:

    I applied the workaround (using calendar IDs) and was able to successfully add all my (actually my client's) secondary calendars to iCal with read/write access.  But the primary calendar--whos ID is just the user's Google login--only comes readonly.


    In this case the user has 8 calendars so they got 7/8 of a solution, which turned out to be good enough in this case.  But clearly Google needs to fix something...unless they intend to simply drop all support for iCal 3.x.   Goodbye Leopard?


    p.s. thanks for the great workaround!

  • chipmunk6 Level 1 (0 points)

    CavemanCooking. A hearty thank you for your post - spot on and it works.  Until recently there were problems with google calendats and IiCal in OSX Lion. One can't help but think Apple is disincentivised from supporting google stuff in general. It's worth noting that the iPhone supports delegates directly, so why shouldn't iPad. It's not as if the code hasn't been written, so whay not include it. What convoluted policy decision gave rise to this ommission i do not know.


    Still, I no longer care thanks for the workaround again. Really appreciated.

  • Tony Reidsma Level 1 (55 points)



    You had me till I had to Click the triangle. I don't see one.


    I just upgraded to Mountain Lion, and now I'm having this issue.





  • Śāntanu Level 1 (0 points)

    Tony, I ran into the same problem and I found the solution. After clicking "add account". Choose your account type as "CalDAV". A field for "Server Address" shows up. Paste the address you created into that and fill in your gmail info into the User Name and Password fields. It worked for me. I hope that helps.

Previous 1 2 Next