8 Replies Latest reply: Apr 22, 2012 6:44 PM by jschwend
darkseven Level 1 (0 points)



i have the problem that i can not load photos through iTunes on my iPhone or iPad because iTunes can not find my Aperture Library.

In Aperture itself i have the setting enabled, that other program can use thumbnails.


Some Tipps for me?




Bildschirmfoto 2012-04-19 um 10.06.03.png

Bildschirmfoto 2012-04-19 um 10.05.35.png

MacBook Pro, Mac OS X (10.7.3)
  • léonie Level 10 (85,160 points)

    Where is your Aperture Library? On an internal or an external volume? What is your Aperture version?


    Typically iTunes cannot find the Aperture Library if the volume with the Library is offline, or if the Aperture Preference file is corrupted or not readable.

    Sometime this helps:

    • Quit iTunes.
    • Launch Aperture and create a new Aperture Library  (File -> Switch to Library -> Other/New)
    • When Aperture open the new, empty Library import one image and switch back to your regular Aperture Library,
    • Quit Aperture
    • Lauch iTunes.

    Your Aperture Library now should be visible.


    If this did not help, remove the Aperture Preference file, as described here:

    Aperture 3: Troubleshooting Basics: http://support.apple.com/kb/HT3805





  • darkseven Level 1 (0 points)



    thanks for your fast answer, great, this solved it!!

    thank you.


    after quiting aperture it was rebuild the preview section and now it works.


    Some Information for the Archives


    my Aperture is 3.2.3

    lies on the internal HD, ~/picture/

  • léonie Level 10 (85,160 points)

    You are welcome, I am glad this simple solution helped. If the library is not in a standard location it can be tricky to point iTunes to the aperture library.




  • jschwend Level 1 (0 points)

    Hello all, Oh man, I thought this would be the answer, but sadly, it's still a no go for me.  I am getting that "Aperture Library cannot be found" message in iTunes as well. 


    I have share preferences set to Always

    My "first" aperture library was stored in the default location (internal hdd)
    My "real" library is located on a HFS+ formatted external drive
    When my first library is selected, iTunes sees it no problems
    When my second library is selected, iTunes complains
    I've tried deleting the plist for iApps and Aperture, still no dice

    I've tried the "create a new library, switch back" method, yep, no dice

    I've done all three aperture first aid options


    My screen saver can see my "real" library (the second one that iTunes struggles with).


    Any other ideas?

  • léonie Level 10 (85,160 points)

    Sorry to hear that.


    iTunes complains

    What exactly is the error message from iTunes?

  • léonie Level 10 (85,160 points)

    Is your main Aperture Library on a locally conneted external volume or on a network volume? Does iTunes not show the aperture library at all, or does it show the Aperture library as empty? If it is shown as empty, I would try to regenerate the Previews in Aperture (this may take a while if your library is huge):

    • Select all images in the Browser and select: Photos -> Delete Previews
    • Then recreate them: Photos -> Update Preview

    This usually works, if iTunes sees the Aperture Library, but does not show the correct number of images inside.


    If however the error message concerns the syncing of of images between iTunes and your mobile devices, you may need to clear your Photos Cache: http://docs.info.apple.com/article.html?artnum=300225



  • jschwend Level 1 (0 points)

    Hi leonie, thank you very much for replying.  I'm sorry for the vauge "error description"


    iTunes complains = Aperture Library cannot be found (same error as before)


    My library is contained on an external HFS+ formatted USB drive.  I know other programs can see the library because my screeensaver shows photos from it.


    As for your soultion, that didn't fix it unfortunately


    But I did end up figuring out a solution: I don't know why iTunes was so fixated on the original library aperture created on my OS drive in the "Photos" directory (which is now a very limited space SSD).  Even if I created a new library located on my OS drive, it "wouldn't find it" when I switched to it.  So for the solution, I moved (not copied, but moved) the original library to the exact same location as the one on the USB HDD.  Changed the library to the "original one" located now on my USB hdd.  Merged in the one that had all my photos.  iTunes now can see my library located on my HFS+ formatted USB hard drive. *WHEW* I hope that helps someone else out.

  • jschwend Level 1 (0 points)

    GAH! I spoke too soon.  After I posted this, I noticed that iTunes said I had 0 photos (despite seeing the projects).  Well, I repaired (didn't work, same 0 photos), then rebuild.  NOW it says it can't find my library again.  SIGH... any other ideas?