Previous 1 2 3 4 Next 58 Replies Latest reply: Jun 13, 2013 8:26 AM by aThanasi Go to original post
  • wsw1217 Level 1 (0 points)

    i got it fixed.

    1. First unclick the "synchronize with google" in contacts settings on your Mac.

    2. Delete all your google contacts

    3. Go to System preference>Mail, Contacts&Calendar>Add Other Account>Add a CardDav Account>

    user name is ur email address, server address is

  • wsw1217 Level 1 (0 points)

    However, I do find the method has its issue as well.

    I found out that some of my contacts that I use their own gmail/google profile pic as their gmail contact pic, don't have profile pics in Contacts on Mac while their pics do show up in Messages App on Mac. That's a weird bug.


    Then I removed the CardDav Account and re click "synchronize with google". The profile pics were just back.

  • Calvinkw Level 1 (0 points)

    I face similar but different problem, and I guess it's a bug in Mac OS, or setting problem.


    I syn the contacts from my MS Outlook > gmail contact.

    Then, I syn my Gmail contacts to iPad/iPhone (by adding a Google Exchange account in iOS). Results: All new contacts will appear in my iOS devices EXCEPT picture.


    After that, I add picture in to the iPad Contacts, syn again. The pictures appear in both my iPhone AND gmail contacts.

    However when use iSyn in my Macbook (OS Mountain Lion), the pictures still can not be shown in my Mac Contacts.


    Thus, I guess if it is Mac OS issue? Why the picture updated in my iPad can be shown in my iPhone via gmail contacts, but not work in my Macbook?


    In Macbook's Contacts > Preference >vCard, there are several checkbox. Will it work if I make some changes?

    e.g. "Enable private me card (currently unchecked)", "Export photo in vCards(currently checked)", etc?

  • ksh9032 Level 1 (10 points)

    This is happening because you do not have any pictures on Google address book.

    Fix this by adding same picutures to Google.

  • Calvinkw Level 1 (0 points)

    Updated a picture in my Macbook Contacts and syn to gmail contact.... the picture does not appear in gmail contacts... So, it should be no doubt that a problem of Mac OS ML.


    But I dun know what is the checkbox in the Preference for. Anyone know or tried those setting?

  • marcodiversi Level 1 (0 points)

    the solution of cancel all the contacts and restore from backup is easy and works, the pont is that i don't have a recent backup, i will lost at least 40 contacts from the last backup so please solve this problem i like to have all my contacts well in order with the picture but now i have lose like 400 pictures and some numbers.

    i mean on google there's still pictures and number but not in address book ! why ???

  • flips01 Level 1 (0 points)

    That app (Contact Sync for Google Gmail) is just for manual syncing, or does that sync app run in the background?

  • jamesh53 Level 1 (0 points)

    I have been having the same problem running Mountain Lion 10.8.2 with iPhone 4 running 5.1.1. I have not updated to 6 because I have heard too many complaints. Nonetheless, I get the same popup, and if I "sync now" I would have lost over 600 photosas Google would have erased them from


    Here is what I did to potentially solve the problem, while still maintaining an Apple-Google Sync in the future...


    First, I made sure the my apple contacts were fully up to date, and synced with facebook. Basically, I wanted my macbook contacts to be as "up to date" as possible, so i went through several iterations of ensuring that facebook, twitter, and my current were all in sync. While I was doing all of this, I kept pressing "sync later" on the google popup that is in question if it ever appeared.


    Then, I synced with my iphone running 5.1.1 to ensure that my iphone had the most recent contacts from my mac, and vice versa. I double checked on the macbook that there were no duplicate contacts, and merged anything that was duplicated. I also refreshed the connection to facebook and twitter contacts by going into system preferences > mail accounts > update contacts for both facebook and twitter.


    FINALLY. I went into contacts and into preferences and unchecked the box for "sync with google" ... see the attached image.


    Then I repeated the same process of ensuring that, and facebook, and twitter were all in sync.


    THEN I went back to the check box (As shown in the attached picture, and re-enabled the google sync. My hope is that the fresh connection to Google would let the Google Servers know that all of these contact on the macbook are actually the most current version (And thus, to leave them the **** alone!).


    So far, so good. I did get a popup asking me which versions of my contacts were correct. But this pop up let me choose either the iphone, the, or google. It didn't force me to delete any photos.


    I'll post again if it fails. If you don't here back from me, assume it's still working.

  • jamesh53 Level 1 (0 points)

    Sigh. My method didn't work. Instead, I got the popup again as I was syncing my iphone. I ignored it. I might follow the original method of backing up contacts, as suggested.

  • pdyholman Level 1 (0 points)

    Since my last post a few months ago, I switched to CoBook.


    I'm pretty happy with the results - syncing via Google between both my Mac Mini and MacBook, but also with my Android phone without any glitching.


    As an added benefit, it includes Facebook and other social media links (picking up information from people at these sites), and was easily populated (with images) from my original address book.

  • flips01 Level 1 (0 points)

    CoBook was the first to mess up my address book ... Later OS X/ Services messes up just fine by itself ...

  • jamesh53 Level 1 (0 points)

    Yes. I am too now having trouble with CoBook and I haven't had time to sort it out. Others should be fair warned, however, before installing it.

  • LeRwaNL Level 1 (0 points)

    Of course I'm experiencing the exact same problem als everybody else here. I also bought Contacts Sync for Google Gmail. I think it might be the best solution for now, but the program can mess up your groups. I would advise only using the manual sync option (not the automatic), so you have control over unexpected events.


    So what I did is manually (without syncing software) made my Mac contacts and Gmail contacts and their groups exact the same and use that as a starting point for syncing. Then the groups did not mess up. Also I'm considering just updating my contacts without the use of any sync-software and hope that Apple fixes this problem soon.

  • aThanasi Level 2 (300 points)

    You should export your iPhone contacts to a single vCard file and them re-import then to your Gmail account. The vCard file will conserve your contact photos and transfer them to your Gmail account. Here is more about how to sync iPhone contacts with Google.

Previous 1 2 3 4 Next