Previous 1 2 3 4 5 6 7 Next 102 Replies Latest reply: Aug 24, 2015 5:53 PM by Meenik Go to original post
  • ninjitalia Level 1 Level 1 (0 points)

    Hi Glenn!

    I've tried this re-indexing suggestion and my mail search is still having the following issue which originaly led me to look for and find this thread: when I type in a word or name to search (in Mail), even a word or name that I know is contained in many different messages in my inboxes (such as the word "amazon"), I can search only among certain suggested options that appear (and those do come up), which are usually full email addresses that the word is contained in.  However, if I select 'message contains', searches are not bringing up anything at all when I know there is at least one and often there are many emails containing that word. 

    I am not sure when this issue started; it has been a few months.  Before that the search had always worked perfectly and always brought up every email containing the searched word or name.... Maybe it occurred during the update to Lion, not sure. I do have multiple email addresses and many emails and files. 

    Am I missing something among your suggestions?  What else can I try?  I tryied the reindexing thing but I'm not even sure that I did it right...I followed the link you provided for more info and followed the steps, but saw no evidence of 're-indexing'...your message seems to suggest that I should see some sort of process being done...?

    Thank you so much & Happy Holidays!

  • justcallmekath Level 1 Level 1 (0 points)

    i had success by removing the search window in mail and adding it back in. to do this, right click in the search window and choose customize toolbar. while the options are open, drag off your search window in your mail window (upper right corner) so it "poofs" away. then add a new search window back in from the customizable options. i thought this would never work, but it did for me. i tried deleting those files someone else suggested first, but this is what did the trick for me. good luck.

  • Glenn Leblanc Level 6 Level 6 (8,690 points)

    If you are trying to rebuild the Mail message database by deleting the envelope index files and followed the instructions to quit mail first before deleting the files, then restarting mail will have a box come up to continue and the database will reindex. You will definitely notice it.


    You should also check the spotlight preferences to make sure there are no exclusions which might include Mail. You should also reindex spotlight. I haven't reread all the messages in this post, but I'm sure everything is listed. Let me know exactly what you need help with and are trying to do.


    I don't normally recommend an application to do this with, but the easiest way for you might be to download Onyx and run these from there. I use this application from time to time and haven't had any problems with it, but I would definitely tell you to have a good backup before using this or doing anything esle.

    If you download Onyx for Mac, don't download the beta version. Use only the lastest tested version which is 2.6.3.


    When you run Onyx, open the Maintenance tab, the select the Rebuild tab. You can check the boxes for Spotlight Index and Mail Envelope Index and hit execute. Make sure you close all applications before running Onyx.



    In Addition:

    The latest stable version of Onyx is 2.6.3. I edited the version above.

  • a.p.fromportland Level 1 Level 1 (5 points)

    Oh dear.  I was having the same trouble. Using the "rebuild" menu item gave me back some limited search capability, but not everything.  So I followed the instructions above and deleted the three "envelope" files.  Then I re-staretd Mail.


    Mail dididn't say that it was re-indexing my mail, but re-importing it, as if I had deleted all of the cached mail!  Mail said that this woudl take an hour and some minutes.  6 hours later, this is what I see:


    Screen Shot 2013-01-23 at 14.22.59 .png


    It did actually count down to zero, but then the counter evidently wrapped ...


    So, I don't recommend that you try this at home.  I may have to restore mail from a backup.

  • Derek_Brown Level 1 Level 1 (0 points)

    a.p.fromportland  You should try some housekeeping.  If you really have that many emails, that could be why it's having an issue.  My wife also runs into issues because she never deletes any emails and she has 10k+ emails in her inbox.  I'm guessing that instead of the Mail app not finding the emails, it just hasn't finished looking through all the emails yet.  If it takes 6 hours to index, its going to take a long time to search through it.  Just my opinion.

  • kitschagogo Level 1 Level 1 (0 points)

    Thanks - the removal of the envelope files and restarting mail worked for me

  • xtreamers Level 1 Level 1 (0 points)

    Oddly enough... removing the search bar from the toolbar and then re adding it worked!


    Thanks everyone!

  • David Deutsch Level 1 Level 1 (0 points)


    I have read through this entire series of posts on this subject and have done everything suggested, even things as silly as removing the search box and adding it again. I've re-indexed and rebuilt and have removed my address book from the library folder but still nothing. My spotlight works just fine, but my mac mail search just doesn't work completely. If I search for something in the "subject line," or "from" or "to," not a problem, but if I ask it to search "any" through "everything", nothing happens. I get "searching," and then "no messages found." This is very annoyiing and I'm not really looking forward to re-installing mountain lion. Any ideas?

  • slaterk Level 1 Level 1 (0 points)

    thanks, that (removing the search space and adding it back) worked for me!!

  • mikeyba Level 1 Level 1 (0 points)

    I have the same problem as David Deutsch.  I have rebuilt the Mail and Spotlight indexes and removed and added back the search field.


    Searches in Mail work OK when using search in Subject, From, etc. but NOT "Any," aka "Entire Message," which is the only way to search the email body.


    Strange problem. Any more suggestions?

  • David Deutsch Level 1 Level 1 (0 points)

    FINALLY my problem is solved.


    As mentioned in my original post, I've been pulling my hair out and have cursed up a storm about this problem for months.



    This macworld article hits the problem right on the head and explains why. Apparently a spotlight problem.


    I hope this helps.

  • mikeyba Level 1 Level 1 (0 points)

    It worked! Thanks David!


    Using the instructions from the link, I only needed to do the first command:

    sudo mdutil -i on "/Volumes/Macintosh HD"


    which returned "Indexing enabled.".


    Just to reiterate, I had previously rebuilt the Spotlight indexes using the method of adding my hard drives to the exclusion list in the Spotlight preferences panel on the Privacy tab.  After that I removed them from the exclusion list which caused the indexes to be rebuilt. This was not enough to fix the problem (or possibly even needed).


    Thanks again!

  • newappdev Level 1 Level 1 (0 points)


    Dear friend I had the same problem too. but after moving the


    Envelop Index

    Envelop Index-shm

    Envelop Index-wal

    messageRules.plist and it's back up my problem solved.


    tnx for Glenn Leblanc and  every one.

  • country and western Level 1 Level 1 (0 points)

    Thanks to everyone who has contributed to this thread. The problem (and solution) is in understanding the way the email search box works

    This is what I have realised after trying some of the things you have suggested. When I search for an email address using "from" it does not show up.  That is because I link my email conversations and they show up as a thread of emails with a small number next to the the last email.  If the email address I am searching for is not the latest email received in the thread, it is buried in the thread and cannot be found in the email search box this way.

    So if I search for under "from" it does not show, but if I click the little downward arrow next to "from" in the mail search and choose the option "entire message" I will find his email amongst one of the threads of conversations - the ones with little numbers next to them.  I then have to click that thread of emails and Fred's email appears in there.  You just have to remember that this is how the search mode works and not go into a blind panic when nothing shows up in the search - which is what had been happening to me. I hope this helps someone.

  • Manik-1770 Level 1 Level 1 (0 points)

    I downloaded the latest version of Onyx as recommended by Glenn Leblanc (I thought the program iceclean would have this same option to rebuild spotlight / mail but I guess not)


    Under maintenance, I checked: Spotlight Index and Mail's Envelope Index along with all the other already checked options... and it "search all"  FINALLY WORKS!
    It's been over 4 months since I've upgraded to 10.8... and have tried the manual deleting and terminal rebuilding without any luck. Onyx did the trick for me.