3 Replies Latest reply: Apr 20, 2012 12:23 PM by planb77
MonroeTrojan20 Level 1 Level 1

my ipod wont let me go on the app store, itunes, or safarie please tell me whats wrong and how i might be able to fix it? its 3rd generation 8gb.

iPod touch, iOS 4.3.1, might be 4.2.1
  • planb77 Level 7 Level 7

    Are you connecting to a working Wi-Fi network?  Have you tried rebooting your iPod Touch and router/modem?  To reset your iPod, press and hold both the Sleep/Wake and Home buttons together long enough for the Apple logo to appear.


    To reset your router, simply unplug it for about 30 seconds and then plug it back in and wait for it to come back online.



  • MonroeTrojan20 Level 1 Level 1

    i alreadt tried all of that and none of them worked and im on very nice and strong wifi. i even tried restoring it which also didnt do anything either. i have no idea whats wrong. my other ipod and ipad 2 work on this wifi perfectaly well it just this ipod.

  • planb77 Level 7 Level 7

    Can this iPod Touch connect to any other networks successfully (i.e. connects to the access point and you can browse the web and use web enabled services)?


    Have you tried resetting your iPod's Network Settings?  To do this, head to Settings -> General -> Reset and tap reset network settings.  Then try reconnecting to the network.