4 Replies Latest reply: Apr 22, 2012 10:50 PM by dtbraun
dtbraun Level 1 Level 1 (0 points)

I have a peculiar problem that has been developing for some time now.

 

Current Symptoms:

  •   Safari (Any Version 5.0-Current) will load but WebProcess.app Opens to 100%

           on one core of CPU (Non-Responsive) and no web-pages will load.

  •   VLC.app launches in the same fashion, one process pegs to 100%.
  •   iMovie.app hangs.  Not crashing, but failing to successfully launch.
  •   Apple Script saved as an application behaves in the same way.

 

Attempted Diagnosis:

      I'm currently running OS 10.7.3 on a Early 2009 Mac Pro.

     

     I have tried:

  •   Deleted Preferences, and Saved Application States. Then realized the

problem can't be in ~/Lib/Prefs. because it also is a problem on a clean user

profile I created to check. So I also looked in /Sys/Lib/Prefs. with no Success.

 

  •   I have run disk permissions more times that I can count. 

                This comes up with regularity but solves nothing:

 

  Group differs on “Library/Preferences/com.apple.alf.plist”; should be 80; group is 0.

  Repaired “Library/Preferences/com.apple.alf.plist”

  Permissions differ on “usr/lib/ruby”; should be lrwxr-xr-x ; they are drwxr-xr-x .

  Repaired “usr/lib/ruby”

 

  •   Reinstalled 10.7.3 from the Combo Updater from apples website.  No Help.

 

  •   I did find launching any affected App from the Unix Exe File in the .app

         bundles (So it launches in terminal)  will open them and allow them to

         runwithout issue (yea! temporary fix)! 

 

  • Finally I booted with -x into Safe Mode.  There the problem vanished.  Hooray

        it's another piece of  software or an extension I have loaded (Could  be any over

        the past 6 months or so)!

 

  • So, I rebooted and tried to launch Safari immediately. It worked!  Only after a

        minute or so, when the GUI and background Apps had finished

        loading, the problem returns.

 

 

What I need help with:

 

  • Is there any good way to tell what application is causing the problem or what

these four apps have in common?  I have looked at Console Logs, Crash Reports,

etc. etc. but admittedly am not sure what to look for.  I would be happy to post logs

or reports or more detailed info, if it would help.

 

Otherwise Thank-you to anyone who reads this and has any good ideas short

of a fresh install. Cheers!


Mac Pro, Mac OS X (10.7.3), It's Tricky, Tricky, Tricky.
  • Carolyn Samit Level 10 Level 10 (98,720 points)

    Hi...

     

    Reinstalled 10.7.3 from the Combo Updater from apples website.

     

    The only way to reinstall the Mac OS X or repair the startup disk running v10.7.3 Lion, is to use Lion Recovery The combo update does not do that.

     

    How much free space on the startup disk? Not enough free space can account for the problems with your apps.

     

    Right or control click the MacintoshHD icon. Click Get Info. In the Get Info window you will see Capacity and Available. Make sure there's a minimum of 15% free disk space.

     

    and no web-pages will load.

    Try using OpenDNS as suggested here >  Safari 5.0.1 or later: Slow or partial webpage loading, or webpage cannot be found

     

    Use OpenDNS for better speed, more security, includes anti phishing filters, prevents browser redirects, and it's free.

     

    Open System Preferences / Preferences then select the Network tab. Click the Advanced tab then click the DNS tab.

     

    Click +

     

    Enter these addresses exactly as you see them here.

     

    208.67.222.222

     

    Click +

     

    208.67.220.220

     

    Then click OK.

     

     

    edited by:  cs

  • dtbraun Level 1 Level 1 (0 points)

    Hi Carolyn,

     

    Thank you for your quick response!

    The only way to reinstall the Mac OS X or repair the startup disk running v10.7.3 Lion, is to use Lion Recovery The combo update does not do that.

     

    I should have clarified that I only re-ran the Combo Updater, as opposed to the Delta Update from System Update. (There were some issues with the initial release)

     

    I have ruled out DNS.  (I have used both Google and OpenDNS)

     

    To Clarify:

    and no web-pages will load.

     

    Safari will not load anything. Not even local files will load. Because as I stated, WebProcess.app (A sub process of Safari is not loading(it hangs)).

     

    Also Firefox and other browsers load web pages just fine.

     

     

    As for drive space:

    Make sure there's a minimum of 15% free disk space.

     

     

    I did free up a little more space, but I'm fairly certain this is not an issue.  (I went from 57GB free to 115GB on my 500GB System Partition)

     

     

    At this point it almost has to be another piece of software causing the problem.  I just find it odd that Safari, VLC, and iMovie are affected but not other applications? Any help finding a common thread here would be great.

     

    If a Crash Report, or Process Sample would help please let me know.

    Thanks.

  • dtbraun Level 1 Level 1 (0 points)

    Short Recap for anyone who only has a mintue to look at this, this week:

     

    Safari and three other applications hang.

     

    I've tried a bunch of tricks to get them working right with no real success (See OP above).

     

    I can run Safari (and others) by opening the Unix Executible File in the .App bundle!?

            *Can anyone explain to me why this works? 

     

    The applications also open fine in Safe Mode.

     

    Any help would be great! Thanks!

  • dtbraun Level 1 Level 1 (0 points)

    Afer lots of struggling with this, I finally rebuilt Launch Services with OnyX and all is well again.

     

    Probably my fault for messing around with the FileSystem to often experimenting with this and that.

     

    With any luck this might hlep someone else too!

     

     

    Hackintoshes are computers too!