Previous 1 2 Next 24 Replies Latest reply: Aug 2, 2014 10:22 AM by anticlomabliacs Go to original post
  • Pierre-Yves 1 Level 1 Level 1 (5 points)

    In fact something else is required on my config to get aptX. After each reboot, after connecting my BT headphones I need to use the menu bar Bluetooth menu, then select "Don't use as audio device" and then "Use as audio device".

    Before this operation the codec is SCO and after it is aptX !

    It seems that it stays configured unitl next reboot...

     

    Nevertheless, audio quality is not perfect with aptX nor SCO.

     

    Hope it could help.

  • seanmclainbrown Level 1 Level 1 (0 points)

    You're a genius! It worked for me using my new Dr. Dre Beats Wireless! Surperb sound quality now. It was using the SCO codec and now it uses the apt-x. I'm running 10.7.5, Mac Pro Tower and Mac Mini. Thanks!

  • claire2904 Level 1 Level 1 (0 points)

    Thanks for this post! I got a pair of bluetooth sennheisers for xmas, sounded great on my iPhone and PS Vita but I thought all my music was screwed when I connected them to the iMac!

     

    All sounds amazing now

  • NKhechog Level 1 Level 1 (0 points)

    That worked perfectly. I love the fullness and detail that aptX enables on my MM400x headphones. Thanks a lot.

  • SWTate Level 1 Level 1 (0 points)

    Hi

    Whilst it sounds like everyone who's tried these various fixes has managed to get aptX working, I'm still struggling & wonder if I'm missing something. I've got a late 2009 iMac running OS X 10.8.4 and have been connecting it to an Arcam rBlink BT DAC; my other BT devices are the usual Apple mouse, keyboard & trackpad. At first I managed to get apptX working by simply disconnecting all my BT devices & then reconnecting with the rBlink first, but after changing the bitpool settings to cure dropouts, that trick refuses to work any more (even I restore the default bitpool settings). I installed Bluetooth Explorer & used that to enable aptX but simply get the error message:

    "A Bluetooth audio error occurred: there was an error connecting to your audio device. The encoded audio stream configuration was unacceptable to the remote device"

     

    Oddly I also now get a similar message if I try to use the rBlink after connecting it before my keyboard - or if I use it without any other BT devices.  I seem to have gone through every suggestion & possible work around multiple times & now I've given up & appear to be stuck with SBC - which is OK, but I did notice a significant boost in quality with aptX. Im waiting for Arcam to get back to me & will post any reply I get, but if anyone has any other bright ideas, I'd be really grateful. Thanks,

    Simon

     

     

    These are my bitpool settings btw:

    "Apple Bitpool Max (editable)" = 64;

        "Apple Bitpool Min (editable)" = 53;

        "Apple Initial Bitpool (editable)" = 53;

        "Enable AptX codec" = 0;

        "Negotiated Bitpool" = 53;

        "Negotiated Bitpool Max" = 53;

        "Negotiated Bitpool Min" = 53;

        "Stream - Flush Ring on Packet Drop (editable)" = 0;

        "Stream - Max Outstanding Packets (editable)" = 30;

        "Stream Resume Delay" = "0.75";

  • NKhechog Level 1 Level 1 (0 points)

    Did you try running this terminal script?

     

    defaults write com.apple.BluetoothAudioAgent "Enable AptX codec" 1

     

    It worked for me.

  • SWTate Level 1 Level 1 (0 points)

    Hi

    Yes: tried it using terminal & also Bluetooth Explorer. Also just tried removing all other BT devices & it refused to even connect until I reconnected both keyboard & mouse. Driving me mad!

  • NKhechog Level 1 Level 1 (0 points)

     

  • MDMac86 Level 1 Level 1 (0 points)

    If none of these recommendations work for you ... Try turning off multipoint functionality on your headphones if the feature is available. Having this enabled forced the SBC codec to be used regardless of the 'force aptx' setting.

  • anticlomabliacs Level 1 Level 1 (0 points)

    This solution works for those who can't seem to get apt-X working with their iMac connected to a bluetooth keyboard in combination with a magic mouse.

     

    Make sure that you connect the bluetooth keyboard and mouse and open itunes before doing the following steps:

     

    - Disconnect the bluetooth keyboard

    - Connect the speaker

    - Connect the bluetooth keyboard

    - Press the 'play' button (F7) on you're keyboard

    - Check if it worked bij clicking the option key + the bluetooth symbole in the top bar

     

    For some reason, only if you connect the speaker before the bluetooth keyboard, the imac uses apt-x

Previous 1 2 Next