Previous 1 2 Next 20 Replies Latest reply: Jan 29, 2013 8:13 PM by Cosme422
Jeff_Jeffty_Jeff Level 1 (0 points)

Hi everyone,


This is my first post!  I'm getting desperate as I can't find any answers elsewhere online and Applecare were no use as they don't help with software issues apparently!


Basically I've used older versions of Garageband for years with no issues, but after upgrading to Garageband '11 (I've got the latest version 6.0.5 (428.5)), I can no longer record any guitar!  It will record for a split second, then stop, leaving only a split second of recorded track.   If I try again, I get another split second of recording (this time coloured red) and a warning telling me:


Part of the project was not played

This project has too many tracks, effects, or notes to be played in real time.

To optimize performance, see the 'Optimizing GarageBand performance' page in GarageBand Help.


This is crazy as I'm using a brand new iMac 10.6.8 (Snow Leopard) 2.7Ghz Intel Core i5 with 4 GB 1333 MHz DDR3 system and I'm only trying to record 1 track!!!


So it clearly can't be because I've got too many tracks - this is the first one!


I've gone to the Optomizing GarageBand Help page and found that I'm already doing everything it suggests (no other Apps open, 500GB free space on the hard drive etc).


I've run out of ideas.  This is really frustrating because older versions worked perfectly on far slower Macs with much less memory!


Please help me if you know how to fix this.


Thanks everyone,.

GarageBand (Mac) '11, Mac OS X (10.6.8)
  • léonie Level 10 (90,466 points)

    This looks like some application has a bad memory leak. Do you get the same error message after restarting your system?


    Are there any warning messages/ diagnostic messages in Console window?


    And what do you see in the Process Monitor - llok for cpu usage and memory usage.


    Both "Console" and "Process Monitor" can be launched from Applications -> Utilities.


    You may also check, if GarageBand works properly, if you start it from a different user account, to see if some settings in your account may be faulty.




  • Jeff_Jeffty_Jeff Level 1 (0 points)

    Thanks for the tips!  Yes I do get the same issue after restarting the computer.


    On the console there is a repeated message relating to a TascamUS122 audio interface that I haven't used in years.  Could this be causing the issue?


    This is the message:


    21/04/2012 12:44:42pkgutil[16861]PackageKit: *** Missing bundle identifier: /Library/Receipts/US122Driver.pkg
    21/04/2012 12:44:42[0x0-0x89089][16834]2012-04-21 12:44:42.501 pkgutil[16861:903] PackageKit: *** Missing bundle identifier: /Library/Receipts/US122Driver.pkg


    Thanks again for helping out.




    P.S. couldn't find any Process Monitor in the Apps folder.  I'll check on the different user issue.

  • léonie Level 10 (90,466 points)

    couldn't find any Process Monitor

    That was a typo - sorry ; I meant "Activity Monitor" (in Applications -> Utilities)


    a repeated message relating to a TascamUS122 audio

    This looks like something in your current preferences is referring to the audio interface, but this is not installed in your current GB version. Have you tried, if GarageBand works from a different account? Then we would know, if your User settings in your account refer to this interface or if this is system wide.




  • Jeff_Jeffty_Jeff Level 1 (0 points)

    Thanks again for the reply.


    I tried Garageband logged in on another account - result was the same (unable to record more than a split second) and checking  console still mentioned a 'missing bundle identifier (US122 interface I no longer use) and also 'audio engine overloaded, resetting' message.


    Also checked out Activity Monitor - CPU is 94% idle.


    If I uninstall Garageband (by dragging to trash) and then re-installing it from the iLife disc, will this sort the issue, or will it still be looking for this non-existent library .pkg file?


    Kind regards,



  • Jeff_Jeffty_Jeff Level 1 (0 points)

    Any other thoughts, anyone?  I really am stuck!





  • oz-macnut Level 1 (35 points)

    Try refreshing your preferences for Garageband (GB).


    Quit GB.

    Go to: ~/Library/Preferences/

    Move these files to the desktop - This keeps a quick backup of them. Garageband will re-create these prefs when you re-launch Garageband.


    Re-launch GB.

    You might have to reset some of your preferences in GB.


    You will have to do this in every user account.


    If something unwanted happens, just replace your prefs listed above with your desktop copies.

    If it solves your issue, then you can delete the prefs that you dragged to the desktop, othewise, you can place them back, replacing what was recreated.


    Have you tried uninstalling your Tascam software? Is there an uninstaller available? Sounds like there is a driver conflict...


    Check what your Audio MIDI Setup is doing also (in Applications/Utilities). Make sure you "input" in the same sampling format (e.g. 44.1 KHz, 16 bit) as what GB is doing. GB's preferences say the choice of "Better" is recording at 24 bit, but exporting at 16 bit. Differences in sampling rates between what the mac hardware/GB might be stopping you.

    Try the same preferences move to desktop trick (as above) on Audio MIDI Setup's "" (in ~/Library/Preferences also).


  • Jeff_Jeffty_Jeff Level 1 (0 points)

    Hey Oz,


    Thanks for getting involved in this issue! 


    OK, Here's what I've tried:


    1) Complete uninstall/reinstall of Garageband 11 (including removing receipts and all accociated GB files) This has solved the TascamUS122 issue


    No luck!  Still only records for a split second.  Tascam warning (in the Console report) gone, but still get the warning for 'audio engine overloaded resetting'.


    2) Refreshing preferences (as you suggested)


    No change.


    3) Checked Audio MIDI Setup -  matched (e.g. 44.1 KHz, 16 bit) with 'Good' on GB also 16 Bit.  Couldn't find any kHz settings in GB.


    No luck.


    4) Did the "" (in ~/Library/Preferences thing.


    No luck!


    Here's a copy of what the Console is saying (note no receipts for JamPacks etc since deleting the receipts for the re-install - hope this isn't a problem).


    28/04/2012 23:42:13[0x0-0x76076][11514]No receipt for '' found at '/'.
    28/04/2012 23:42:13[0x0-0x76076][11514]No receipt for '' found at '/'.
    28/04/2012 23:42:13[0x0-0x76076][11514]No receipt for '' found at '/'.
    28/04/2012 23:42:13[0x0-0x76076][11514]No receipt for '' found at '/'.
    28/04/2012 23:42:13[0x0-0x76076][11514]No receipt for '' found at '/'.
    28/04/2012 23:42:14[0x0-0x76076][11514]No receipt for '' found at '/'.
    28/04/2012 23:42:14[0x0-0x76076][11514]No receipt for '' found at '/'.
    28/04/2012 23:42:14[0x0-0x76076][11514]No receipt for '' found at '/'.
    28/04/2012 23:42:14[0x0-0x76076][11514]No receipt for '' found at '/'.
    28/04/2012 23:42:14[0x0-0x76076][11514]No receipt for '' found at '/'.
    28/04/2012 23:42:14[0x0-0x76076][11514]No receipt for '' found at '/'.
    28/04/2012 23:42:14[0x0-0x76076][11514]No receipt for '' found at '/'.
    28/04/2012 23:42:14[0x0-0x76076][11514]No receipt for '' found at '/'.
    28/04/2012 23:42:15MIDIServer[11534]MIDIServer [11534] starting; arch=x86_64
    28/04/2012 23:42:15MIDIServer[11534]PlugIn EmagicUSBMIDIDriver.plugin -- /Library/Audio/MIDI Drivers/ does not contain a supported architecture.
    28/04/2012 23:42:15MIDIServer[11534]MIDIServer relaunching because a 32-bit driver was found
    28/04/2012 23:42:15MIDIServer[11534]MIDIServer [11534] starting; arch=i386


    Does this give any clues?  Thanks again for your help - really apprecaite it!



  • Jeff_Jeffty_Jeff Level 1 (0 points)


  • oz-macnut Level 1 (35 points)

    Suggest looking for an update to the emagic midi driver.


    Failing all that, make sure you have at least one valid backup of your system, two backups to be safe, then try reinstalling snow leopard from the installer DVD.

    Then install GarageBand, jam packs, other extras, then replace your files from backup. Very important...


    If you have time, you could just try reinstalling SL without erasing the hard drive first, but it might be better to start from scratch. It's a lot of work, but it might make your headache go away for good!


    Still, try finding that emagic driver first.



  • Jeff_Jeffty_Jeff Level 1 (0 points)

    Thanks Oz.  Couldn't find anywhere to update the emagic driver.  I reinstalled the Session I/O driver just to make sure.


    I'll consider reinstalling Snow Leopard, but I'm hoping there's a solution we havent thought of.


    My iMac is a system migrated from my old MacBook Pro.  Just to be sure, I fired up the old Macbook Pro and successfully recorded using the same OS, the same audio interface and the same version of Garageband!


    Does this give any clues as to why the iMac might not be working?  Is there some setting on the new iMacs that is different to the old MacBook Pros (2006)?


    Thanks again for your help!



  • oz-macnut Level 1 (35 points)


    The should be nothing technically different between the MacBook pro and the iMac. Are you using the same interface? I.e. USB on both MacBook and iMac? Make sure you are obtaining the latest driver for your Session driver from the web too.


    What about installing a fresh install of snow leopard onto an external drive, install GarageBand and all your jam packs etc, and see if you can get the issue to present itself there. You should be able to boot using your external drive. Best if it is a FireWire enclosure. Perhaps leave your session I/o driver out of that installation.


    Perhaps another post of your system log might help again.


    What is your recording interface make and model? How does it connect? USB or FireWire?


    Sorry mark. Not being very helpful, am I?



  • Jeff_Jeffty_Jeff Level 1 (0 points)

    Thanks Oz, really appreciate your help on this.


    I'll think about the fresh install etc.  The trouble is, I'm a musician who bought a Mac back in the day, precicely because I'm not a techy and I was sick to death of daily ctrl+alt+delete wrestling matches with my old PC.  I'm still hoping there's a simpler solution which won't require too much fiddling with the OS.


    Another weird thing is that the Audio interface (Native Instruments Session I/O, bundled with Guitar Rig 3) works perfectly with Audacity, when recording guitar or voice.


    So the question is, what's wrong with GarageBand '11 that even a reinstall of GB won't cure, yet a free piece of audio software works fine!! I'm really confused.  I may try uninstalling it and going back to an older version of GB to see if that works.


    Here's the latest console message:


    02/05/2012 06:46:01MIDIServer[1695]MIDIServer [1695] starting; arch=x86_64
    02/05/2012 06:46:02MIDIServer[1695]PlugIn EmagicUSBMIDIDriver.plugin -- /Library/Audio/MIDI Drivers/ does not contain a supported architecture.
    02/05/2012 06:46:02MIDIServer[1695]MIDIServer relaunching because a 32-bit driver was found
    02/05/2012 06:46:02MIDIServer[1695]MIDIServer [1695] starting; arch=i386
    02/05/2012 06:49:39GarageBand[1670]Audio engine overloaded, resetting
    02/05/2012 06:49:44GarageBand[1670]Audio engine overloaded, resetting


    06:46:01 = me starting GarageBand

    06:49:39 = me pressing record on the guitar channel - only a split second was recorded.

    06:49:44 = me trying again to record - result as above.


    See screenshot image below.


    Thanks again for your ideas.





  • oz-macnut Level 1 (35 points)

    Happy to try and assist Mark.

    I understand your reluctance to do the whole re-install. I have found in the past, sometimes it takes less itme in the long run.


    Interesting that good old Audacity works OK. So it must be indeed GB that's giving you the issue.


    Lets check this next:


    Go the the Finder and launch System Preferences.

    Go to the Audio pref pane and look at the Input and Output sections there. Again, I don't have an interface connected, but...

    Is your Native Instruments Session audio interface listed and definately highlighted in both the input and output sections/tabs?




    Now launch GB and go to your preferences (⌘-, (Command-comma))

    Under Audio/MIDI, do you see your Native Instruments Session audio interface listed there under both Audio input and Audio output? This pic below was taken on my MacBook Pro (which I don't actively use for audio recording myself) so that's why I have System Setting listed there.

    If you change it, it will probably tell you that GB must change the audio driver, click Yes.

    GB Audio.png

    Go across to Advanced. Does your Audio Resolution say "Good"?

    Start with that and if sucessful we can try and go higher to say "Better" or "Best", if you want to record at a better audio resolution.

    GB Advanced.png

    My Console shows this when I launch GB:[33460]: PreSonus FireStudio MIDI Driver - - x86_64 - Aug 16 2011 05:08:04

    It shows the MIDI driver loading (where yours reports un-supported architecture and a 32-bit driver). The previous entries in your log indicate that the 64-bit MIDI is being loaded. (x86_64), but the driver is still 32-bit). I still think that perhaps an updated driver for the Native Instruments needs to be found... Audacity wouldn't care, as it does not support MIDI, but GB does, and would need to load both before being able to record sucessfully.


    I'll see what I can find out for you Mark.


    Hold tight!

  • oz-macnut Level 1 (35 points)



    If you are using a USB input, make sure you are plugging into one of the USB ports on the back of the iMac, not a keyboard/hub etc.


    Check the driver version for your Native Instruments Session I/O. You should be able to check the version number from System Profiler (Applications>Utilities), then click the interface your Session I/O is connected by (USB or Firewire), select your device and see what driver version is listed in the RHS panel's info. I would say it would be 2.4.xx (if your interface isn't that old.)


    You might need to un-install all Native Instruments drivers etc first though using the "Mac OS X Uninstaller Utility 1.1.0"



    Then install the driver "Guitar Rig Session IO Driver 2.4.23 - Mac"




    - Oz

Previous 1 2 Next