5 Replies Latest reply: Apr 22, 2012 1:15 PM by Bob Timmons
ddotyddot Level 1 Level 1 (10 points)

I am extending my AirPort Extreme network using an AirPort Express. Everything is set up according to the instructions here: http://support.apple.com/kb/HT4259?viewlocale=en_US&locale=en_US All lights are green and my network is extended.

 

The problem is my iMac seems to revert back to connecting to the AirPort Extreme even though it's close to the Express and gets a much better signal from the Express. AirPort Utility shows that my MacBook Pro is connected to the Express and speedtest.net shows its on a MUCH faster connection than the iMac. I have my MacBook Pro sitting next to the iMac now.

 

Can I force the iMac to connect to the Express? If so, how?

 

Running the latest Lion on both machines, iPad and iPhones seem to connect to either base station just fine.


iMac (21.5-inch Late 2009), Mac OS X (10.7.3)
  • Bob Timmons Level 10 Level 10 (89,730 points)

    If you have a newer dual band AirPort Extreme, one of the problems with trying to extend using an AirPort Express is that it can only extend one band from the AirPort Extreme.

     

    We need to figure out whether the Express is extending the 2.4 GHz band or 5 GHz band.

     

    If the MacBook Pro is connecting to the Express as you state, hold down the option key while you click on the fan shaped AirPort icon at the top of the screen and look for the Channel info. This willl indicate whether the Express is extending the 2.4 GHz or 5 GHz band.

     

    Then, do the same option-click check with your iMac and see what band it is connecting to.

     

    Post back on your results.

  • ddotyddot Level 1 Level 1 (10 points)

    Thanks, Bob. The laptop connected to the Express is getting 5 GHz. The iMac connected to the Extreme is getting 2.4 GHz. I managed to get the iMac to connect to the Express by restarting, and got 5 GHz. But now it has reverted back to the Extreme (2.4 GHz).

     

    While I was sitting here typing this, I noticed AirPort Utility acting like it was scanning the devices again. My iMac is now connected to the AirPort Express (5 GHz). I would love it if I could force it to always connect to the Express. I get a much more reliable (and way faster) Internet connection through it. Transferring files from machine to machine works much better this way as well.

     

    The Express is only a couple of weeks old. I got the Extreme in April of 2010.

  • Bob Timmons Level 10 Level 10 (89,730 points)

    You might want to try assigning a separate name to the 5 GHz network on the AirPort Extreme, and then re-configuring the Express to specifically "extend" that 5 GHz network name.

     

    If you are not sure how to do this, post back to let me know which version of AirPort Utility.....6.0 or 5.6....that you are using.

     

    Once you have verified that the Express is extending the 5 GHz network name, connect up to that network by "pointing" your iMac to that 5 GHz network name.

     

    Then on the iMac....

     

    Open System Preferences (gear icon on the dock)

    Open Network, and click on Wi-Fi

    Click Advanced at the lower right of the window

     

    Make sure that the name of the 5 GHz network is first in line at the top of the connection list so the iMac will connect to that network first. If the 5 GHz network is not at the top of the list, drag it there.

     

    Click Done, then click Apply

     

    Try things out.

  • ddotyddot Level 1 Level 1 (10 points)

    I have both AU 6 and 5.6, so whichever is easier. I'm not sure how to extend the 5 GHz network with a different name than my Extreme's Wireless Network Name. The Express is set up with the mode labeled "Extend a wireless network" but I don't see a way to change the name.

     

    Thank you for your help!

  • Bob Timmons Level 10 Level 10 (89,730 points)

    Using AirPort Utility 5.6........

     

    Select the AirPort Extreme and click Manual Setup

    Click the Wireless tab below the row of icons

    Click the Wireless Network Options button near the bottom of the window

     

    Click Done and then click Update to save the settings and let the AirPort Extreme restart

     

    Screen Shot 2012-04-22 at 3.01.03 PM.png

     

     

    Enter a check mark next to 5 GHz Name

     

    This will automatically add "5GHz" to the name of the 5 GHz band network

     

    Screen Shot 2012-04-22 at 3.05.26 PM.png

     

    Click Done, the click Update and allow the AirPort Exreme to restart

     

    On the AirPort Express....

    Open AirPort Utility > Manual Setup

    Click the Wireless tab

     

    Make sure that the name of the network that want to extend = your network name 5 GHz. This tells the Express to extend the specific 5 GHz network that you named on the AirPort Extreme.

     

    Screen Shot 2012-04-22 at 3.12.21 PM.png

     

    Click Update to save the settings on the AirPort Express.