Previous 1 2 Next 23 Replies Latest reply: Dec 9, 2013 6:35 AM by mlmiles1 Go to original post
  • singerdf Level 1 (0 points)

    They only fix that works and stays was to upgrade the OS.  We went from Lion to Mountain Lion and that solved the issued.  I have also seen the issue solved when the next update is applied.  No matter how many times I turned icloud off and back on it never stuck.


    Good Luck,



  • darrylfromsaskatoon Level 1 (0 points)


    "...We went from Lion to Mountain Lion and that solved the issued."


    I am hesitant to go there as I want my FCP 7 to continue to work flawlessly. Perhaps an update will solve the recurring issue.

  • singerdf Level 1 (0 points)



    I would try reapplying the last 10.7 update that came out.


    Good luck.



  • darrylfromsaskatoon Level 1 (0 points)

    sharae wrote:


    I had the same problem earlier today (address book search not working). After trying to delete preferenecs, restart system, etc I called Apple (I have AppleCare). While waiting for the advisor, I searched the Apple Community Forums and found clues to the issue - a corrupt address database index (see - Thank you Barney!).


    Rather than reinstalling my operating system, which is what Apple initially suggested to cure the problem, I decided to try:


    1. Backup system with time machine

    2. Navigate into Application Support/AddressBook.

    3. Delete addressbook.abcddb (the address database index) by moving it to my desktop

    4. Restart system

    5. Launch address book (search works again)


    So far, everything works again. I'm using OS 10.7.5, and am not syncing to iCloud.

    Well, that worked...

    UNTIL I performed an address card 'Merge' and now I am back to the same problem. Hmmmmm. It literally worked right up to a minute before the merge. And now nothing!

  • facmello Level 1 (0 points)

    Same with me. When I merge the local contacts with iCloud's, or when I just reload the backed-up contacts, the agenda stops searching again.


    I could not find any folder named or related to the Addressbook uner the Applications Support folder. Can anyone please try to help me? I am using MAC OS X 10.7.5 on an Airbook.


    Is there any way to simply reinstall the Agenda application?


    Tks all for your great help

  • facmello Level 1 (0 points)

    Quick Update: I did fix the problem by deleting all the contacts from my addressbook and loading them directly into iCloud. Then through the sync they got back to my local addressbook. There was ONE record that was not loaded and was apparently corrupted, but I do not know which. In any case, it seems that is was the cause. So the simptoms were quite the same as most people here, but the cause was different.


    Thank you everyone 

  • Tom Meade1 Level 2 (280 points)

    kaz78 your fix, which involves toggling the

    off/on for sending addresses to the local mac

    in Lion definately worked for mer. Good question,

    good figuring out, good answer. Keep up the

    good work and award yourself some good points.


  • G Robert Lewis Level 2 (225 points)

    Exact same experience here. Clearing cache didn't work, turning iCloud sync off & back on worked. 

  • mlmiles1 Level 1 (0 points)

    Wonderful advice!  This worked perfectly for me!



Previous 1 2 Next