12 Replies Latest reply: Oct 12, 2015 10:37 PM by cassporilla
asp9990 Level 1 (0 points)

I've had my AppleTV for a number of months.  However, I'm having problems with the remote when I'm using my TV to play music as my AppleTV remote operates my MacBook Pro as well as the TV.  So when I start to play a CD on the TV my MacBook Pro will play different CD.  How do I syncronise my remote to just AppleTV and stop operating my computer..........it's so annoying....

 

Also can someone advise me on how to use my AppleTV so I can use my TV as a monitor when carrying work on my computer e.g. files etc (if possible).

 

Thanks

Asp999

  • celliott147 Level 4 (1,300 points)

    on the MBP, go to  -> system preferences -> security & privacy -> general -> then check the box next to disable remote control infared receiver.

  • Alley_Cat Level 6 (19,190 points)

    asp9990 wrote:

     

    Also can someone advise me on how to use my AppleTV so I can use my TV as a monitor when carrying work on my computer e.g. files etc (if possible).

     

    Thanks

    Asp999

    You currently can't do this but may be able to if your hardware is supported for upcoming Mountain Lion and this feature.

     

    AC

  • asp9990 Level 1 (0 points)

    AC,

     

    I have Lion on my AMP is their an updated version coming out! Also someone at work suggested a cable to plug into the Apple TV so I can use my TV as a monitor.

     

    Thanks

    Asp9990

  • celliott147 Level 4 (1,300 points)

    you cannot connect to the Apple TV from a Mac without AirPlay. You can try AirParrot. It works well as long as you don't try to stream audio at the same time.

  • pullman Level 4 (1,135 points)

    Go to Sys Prefs - Security & Privacy - Privacy - Advanced. There you'll find the option to disable the remote control infared receiver.

  • okolejoe Level 1 (0 points)

    I had the same exact problem until I downloaded and installed candelair (http://www.iospirit.com/labs/candelair/download/). You then have to open candelair in the system settings > candelair and disable the remote.

     

    Alternately, I just found out that under the System Settings > Security and Privacy > Firewall tab > Advanced, after you have enable your firewall (if it isn't already), at the bottom of the list is a radio button that says "Disable remote control infrared receiver" and under that, after you check the box, it will say "This computer will not work with any remote."

     

    The firewall settings are an absolutely awful place to put a remote control enable/disable function...but there it is.

     

    Mac OS X Lion 10.7.4

  • HACKINT0SH Level 5 (5,760 points)

    Umm no. LOL. 

     

    It doesn't matter what TAB you have depressed. You get the same window every time you hit the ADVANCED button.

  • okolejoe Level 1 (0 points)

    You are correct, Hackintosh. I failed to notice that the Advanced button is in the same position regardless of what section you have selected. My apologies for the oversight. I shall endeavor to ensure that my guidance accurately reflects the necessary steps and does not include any erroneous information which may lead many users awry.

     

    The correct posting should read:

     

    System Settings > Security and Privacy > Advanced, at the bottom of the list is a radio button that says "Disable remote control infrared receiver" and under that, after you check the box, it will say "This computer will not work with any remote."

     

    I hope this clears up any misinformation I have carelessly strewn about cyberspace.

     

    Was that apology sarcastic sincere enough? LOL

  • pullman Level 4 (1,135 points)

    I gave the correct answer earlier. Why this repetition? Strange.

  • okolejoe Level 1 (0 points)

    Yes, strange indeed...directly above mine. I guess attention to detail really DOES pay off sometimes. Perhaps next time. Oops. Now, where's that "delete post" button?

  • baldoyler Level 1 (0 points)

    Stranger still, I've done just this (Preferences>Security and Privacy>Advanced>Disable... so that it says 'This computer will not work with any remote' but, hey, it still does. Toggled either way it makes zip all difference.

     

    Mountain Lion, MacBook Pro, brand new AppleTV.

     

    And not only that, but my old MacMini kicks into life as well (though I don't want it to) as soon as I click the MacTV remote. What's up with this thing? It's like being in one of those horror movies where the bad guy just keeps on coming and coming.

  • cassporilla Level 1 (0 points)

    Thanks!  That was driving me crazy!