14 Replies Latest reply: Jan 6, 2016 9:55 AM by karenfromnewbury park
JSCooper Level 1 Level 1

Hi All,

 

This is for those of you with an Actiontec router (the one used by Verizon FiOS)  trying to get Home Sharing and Airplay working...

 

I wanted to share this to save anyone else from two hours of hair pulling. Got an Apple TV last night, hooked it up, got all logged in, Netflix streamed,  everything was ok EXCEPT Home Sharing and Airplay would not work. Everything Apple's help pages said would happen when we followed certain steps, didn't happen.  I finally found this old post: http://forums.verizon.com/t5/FiOS-Internet/iTunes-Home-Sharing-and-the-Actiontec -MI424WR/td-p/151123

 

To paraphrase this wonderful person, log in to your router, go to Wireless Settings then Advanced Security Settings. At the bottom of the screen, click "Other Advanced Wireless Options". On the next screen change Network from "Network (Home/Office)" to "Broadband".  Click Apply (or save or whatever).

 

After that, all worked!  Just like the original author, I have no idea what this setting does exactly. But so far everything is still working.

 

Hope this helps someone.

 

Thanks,

 

Jeff

  • SRMN Level 1 Level 1

    Thank you for posting this, I have FiOS as well and this worked perfectly!

  • platygadgepoodle Level 1 Level 1

    So this sounds EXACTLY like my problem with home sharing and airplay with a Actiontec MI424WR router for Verizon Fios.  But on mine the admin menu is a little different.  There is no Network setting under Other Advanced Wireless Options--there is a whole set of Network settings under the Network panel--for WiFi, Ethernet, Broadband, WAN, etc.  When I set the top level one to "Broadband" instead of "Home/Office" I lost internet and network connectivity.  No good.  Any idea what the proper setting is here?

     

    Thanks!

     

    Toby

  • somoma Level 1 Level 1

    Thanks so much.  We also had the Actiontec Router MI424-WR Rev.E for FIOS.  In addition to the  Airplay not working, my husband's iPad3 and MacBook Pro could not airprint, even though my IPad 3 and MacBock Pro could Airprint.  I followed the above directions and changed the Network setting to Broadband and now everthing is working as it should.

    It should be mentioned that Once you click on "other Advanced Wireless Options", a warning screen comes up and asks you if you are sure you want to proceed.  You have to click "yes" and then you will go to a screen that has "Network" on the second line with a pull down menu that has 3 options, one of which is Broadband.  You have to click the Save buttons on the bottom on the screen and at one point, the router will temporarily disconntent and then reconnet to save the new setting.  That took less than 30 seconds.

  • richardim Level 1 Level 1

    I messed around for hours and finally got a setting that works for internet and for airplay.  Refer to this post in VZ forums I made.

     

    http://forums.verizon.com/t5/FiOS-Internet/Itunes-Sharing-not-working-over-wirel ess/td-p/197152/highlight/true/page/2

     

    Disabling IGMP Proxying lets my network see the multicast packets AND use internet.

  • Kirkus Level 1 Level 1

    YES!  Older posts (referencing older routers) had an option to set "Network" from "Home Network" to "Broadband" under advanced wireless settings.  The newer routers do not have this option.  The IGMP solution above resolves the issue.  Well done!

  • Me Mac? ...Maybe Level 1 Level 1

    If the above two solutions don't work, it likely means you have an even newer router and surely just for fun they've moved stuff around.  My solution is just a workaround of the above solutions.

     

    -Login

    -click my network at top

    -click network connections on the left

    -click "Advanced >>" on the lower right (result is that it breaks out 2 sub categories under "Network (Home/Office")

    -Click "Wireless Access Point"

    -Click settings

    -Change first drop down to Broadband Connection

    -Save or apply or whatever

    -Cycles for 20 seconds and then should be all good.

     

    As a test I downloaded something at over a couple MB/s (Bytes) and airplayed which it previously couldn't do without one of the two things going to *****.

     

    GL

  • BlackStart1401 Level 1 Level 1

    This is the exact steps I took and it corrected it within 30 seconds.  It took me a year to figure out it was the router settings.  

     

    Thank you for the updates steps on the newer firmware.

  • Krüger Level 1 Level 1

    I owe you a tremendous debt of gratitude. I have been trying to solve this problem with my Verizon router for almost a year now, and while I don't know how I initially missed this thread, you and the commenter known as "Oryoki" have provided the solution that no employee at Verizon or Apple could. I cannot thank you enough.

  • Flying Pelican Level 1 Level 1

    This solved it for me too, along with also disabling the IGMP proxy in Advanced Network settings on the router.  Airprint could not find any connected printers before changing these settings.  I also had to update the firmware on my HP printer.

  • theshenk Level 1 Level 1

    Hey JS -

    I have this modem as well, and home sharing isn't working either. But don't have the same options as the ones you're listing. See screen shot below. I must have a different firmware running. Nowhere in Wireless Setup or Advanaced Setup can I find a place that gives me that option. Firmware is: QAQ002-31.20L.4 and it says it has the latest firmware. I've been googling but can't figure out where the dropdown option is in this interface. Any idea?  Thanks, Daniel

     

     

     

     

    captcha.jpg

  • CosmicPirate Level 1 Level 1

    This worked for me, thanks much! Firmware version 20.21.0.2.

  • brantsteen Level 1 Level 1

    This worked like a charm for me too... but do we have any idea what this setting does? Or if there are any security concerns here?

  • quattrog Level 1 Level 1

    Thanks. Been trying to fix this for a while as well. Changing the setting to broadband worked instantly.

  • karenfromnewbury park Level 1 Level 1

    Thank you so much for this! This solved my issue after hours of trying to make it work.