13 Replies Latest reply: Apr 23, 2012 11:42 PM by AlexPFrance
AlexPFrance Level 1 (0 points)

Hi,

 

I am trying to buy an app (Star Wars KOTOR) on the app store, and everytime I press the button buy, my pointer switches to a "loading" pointer (the rainbow turning disc thing) and nothing else happens.

 

Does anyone knows a solution ?

 

Thank you,

 

Alex


App Store, Mac OS X (10.6.8)
  • AlexPFrance Level 1 (0 points)

    I identified this as the famous spin wheel problem on the app store and tried absolutely everything:

     

    -removing the files,

    -dowload the 10.6.6

    -log out, restart and re log

    -create a new account

     

    Nothing works wether it is a free app or something else.

    What's very weird is that I was able to download an app two days ago

     

    Please Help !

  • Carolyn Samit Level 10 (103,360 points)

    Hi Alex ...

     

     

    According to your profile in your first post you are running Snow Leopard v10.6.8 so downloading v10.6.6 won't work. The game's minimum requirements are v10.6.6 so it should run ok on v10.6.8.

     

    Sometimes it's necessary to reinstall the App Store.

     

    You can do this by installing the Mac OS X 10.6.8 Update Combo

     

    It's ok to do this even though you are already running v10.6.8

     

    Restart your Mac after installing the combo, then try downloading the app again.

     

    If you still have problems downloading the app, contact the app developer here.

     

     

     

    edited by:  cs

  • AlexPFrance Level 1 (0 points)

    I did this (download the 10.6.8 combo) and It won't work. The problem is that is won't work for evry single app. I can't download any app, I always get the spinning wheel and it stays there for hours.

  • Carolyn Samit Level 10 (103,360 points)

    If you have anti virus software installed, disable that.

     

    Try turning off the Firewall in System Preferences > Security

     

    If you have an app called LIttle Snitch installed, that can prevent apps from downloading.

     

    And how much free space on the startup disk?

     

    Right or control click the MacintoshHD icon. Click Get Info. In the Get Info window you will see Capacity and Available. Make sure there's a minimum of 15% free disk space.

  • AlexPFrance Level 1 (0 points)

    Thank you for your reply. I don't have any antivirus on and I don't have Little Snitch installed. I turned off the firewall.

     

    Concerning my drive I have 83.46 GB available (out of 249.72) => 33.4 % free space.

     

    And I was able to download three apps two days ago. Since then, All I did was to install an update for Application loader, which was downloaded via the software update of my macbook

  • Carolyn Samit Level 10 (103,360 points)

    If you haven't restarted your Mac since you installed that update, try now.

  • AlexPFrance Level 1 (0 points)

    I tried it and still doesn't work. Maybe there is something I did not do right ? This is driving me crazy.

  • Carolyn Samit Level 10 (103,360 points)

    Run Disk Utility in case the startup disk needs repairing.

     

    Launch Disk Urtility located in /Applications/Utiliites

     

    Select the startup disk on the left then select the First Aid tab.

     

    Click: Verify Disk  (not Verify Disk Permissions)

     

    If the disk needs repairing, follow the instructions for Using Disk Utility to verify or repair disks

  • AlexPFrance Level 1 (0 points)

    I get this:

    The volume Macintosh_HD appears to be OK.

     

    What if I trash the entire app store and download it again ? (If yes, where can I find it ?)

  • Carolyn Samit Level 10 (103,360 points)

    It's in your Applications folder but just moving the app to the trash doesn't remove all the associated files.

     

    Use this utility >  Download AppCleaner for Mac - Uninstall your apps easily. MacUpdate.com

     

    Good to know the startup disk is ok. At least we can rule that out.

     

    Reinstall the App Store using the update combo link I posted previously.

  • AlexPFrance Level 1 (0 points)

    Just did it, and still the same problem.

     

    I have draged App Store in the AppCleaner, it was uninstalled, I re installed the update, and relaunched and It won't download. I also tried again to remove the files and still nothing.

  • Carolyn Samit Level 10 (103,360 points)

    Try deleting the cache associated with the App Store.

     

    Quit the App Store.

     

    Go to   ~/Library/Caches/com.apple.appstore/Cache.db

     

    Move the Cache.db file to the Trash.

     

    Relaunch the App Store.

  • AlexPFrance Level 1 (0 points)

    Tried it. Doesn't work.