Previous 1 2 3 4 Next 53 Replies Latest reply: Jul 18, 2007 3:29 PM by David Fritzinger
rlpm Level 1 Level 1 (75 points)
Does anyone know how to manually eject a disc? I tried booting with the trackpad button down, but nothing. I don't even get a grey screen, just a black one. It sounds like the disc spins up, but nothing on the screen.

Please help!

MacBook Pro 15/2.0/2GB/256/100@5400 (disc stuck in drive, won't even boot!), Mac OS X (10.4.5)
  • rlpm Level 1 Level 1 (75 points)
    I think it was the RAM. I had been experiencing kernel panics all week long, and was running the hardware tests. It looks like either one of my RAM sticks is bad, or the RAM slot closer the the motherboard is bad.

    Anyway, I put what I think is the good stick in the slot away from the motherboard, and it booted, and I got the disc out with the eject key.

    If anyone knows how to manually eject a disc, I'd still like to know.
  • DC Dan Level 1 Level 1 (5 points)
    I've had luck by holding down the eject button while booting.

    MBP 2.0 two sticks of 512MB and 7200 100GB drive   Mac OS X (10.4.5)  
  • rlpm Level 1 Level 1 (75 points)
    Thanks for the reply, but I was looking for the "put the paper clip in the small hole" trick for when there's no power to the machine.
  • scorcher14 Level 1 Level 1 (5 points)
    I've got a disc stuck in my machine, too.
  • scorcher14 Level 1 Level 1 (5 points)
    Phone support not able to help and Apple Store sent me away (too busy). Any help would be appreciated. I want to figure out what to do to get the CD out of the drive!!
  • kellsbells Level 1 Level 1 (10 points)
    Well, if Phone Support and the Apple Store don't work, you can always do the chat with an agent online. Check it out here:

    http://www.apple.com/support/chat/

    And yes, it actually works. I've talked to them. They are quite nice, even when I accidentally started a chat with no reason. Oops!
  • jim farley Level 3 Level 3 (505 points)
    I'm not sure if this works on the Intel Macs or not, since I haven't tried it, but here are details on ejecting a CD from the firmware prompt:

    http://guides.macrumors.com/ForceEject_a_Stuck_CD_orDVD
  • underattack Level 1 Level 1 (50 points)
    Webchat is not available for Macbooks. Only iMac and iPod owners can use webchat at this time.

    And yes, I have the same problem. Brand new Macbook Pro. Inserted the install disk (to get X11 installed) and it was neither recognized, nor can I eject it now.

    I called Apple support who went with me through the regular motions (e.g. hold eject key while booting). They tried to get me to use open firmware, which does not exist on Intel based Macs (at which point she put me on hold and eventually the call got dropped while I was on hold).

    The disk appears to spin on boot, but even trying to pick it as a boot disk doesn't work. Just looks like the drive is not recognized at all. Maybe just a stupid lose cable?

    This is a Macbook Pro, 2.0 GHz, 1 GB RAM, 100 GB HD. Just picked up yesterday at the local Apple store. Will go there this afternoon/evening to see if they can help.
  • underattack Level 1 Level 1 (50 points)
    I went to the Apple store with my Macbook. They confirmed that the system doesn't even see the CD ROM and gave me a new Macbook (plus a new set of CDs, as one of the OS X CDs was stuck in the drive)
  • scorcher14 Level 1 Level 1 (5 points)
    Finally got into the Mac store today and they got the disk out. Turns out that it was an extra thick CD-R combined with a thick label. So the overall size was more than the slot loading drive could handle. Now I know to watch out for "fat" CDs in the future!
  • deckwalker Level 1 Level 1 (5 points)
    How did the guys at the Mac store get the disk out? I'm in Afghansistan (had my new MacBook Pro shipped out by my Mother-in-law via DHL) and have a DVD stuck. I can't exactly go down to my local Mac store...
  • scorcher14 Level 1 Level 1 (5 points)
    They pressed the touchpad button while rebooting the machine. This is something I had tried myself a couple of times at home, but for some unknown reason it worked at the store. Hope it works for you!
  • deckwalker Level 1 Level 1 (5 points)
    Holding down the mouse button while booting didn't work for me; I tried it several times, and tried it while holding the computer upside down. I ended up completely disassembling the machine, taking out the DVD drive and - very carefully - removing the DVD from the drive. Thankfully the machine is back up and running beauitfully and the drive works fine again.
  • scorcher14 Level 1 Level 1 (5 points)
    Wow. I'm impressed. Good job. Any idea why it got stuck? Was it the thickness or a different issue?
Previous 1 2 3 4 Next