Previous 1 2 3 4 5 Next 171 Replies Latest reply: Sep 7, 2014 6:11 PM by George Hulseman Go to original post
  • Gorbet Level 1 Level 1

    The issue with me (and several others, I think) is this configuration:


    - Logitech USB Unifying Receiver plugged into the TB Display (and, yet to confirm, using a Logitech Performance MX mouse)


    In that situation, none of the USB devices in the display ports are recognized, though the camera, speakers, display, and ethernet still work.


    Like others, if I plug my Unifying Receiver into my MBA directly, then the mouse works AND the display USB ports all work.


    I have two TBDs (serial #s C02GW038DJGR & C02GW070DJGR) and the above observations are true for both. 


    Because of these observations, I strongly suspect that the issues those of us with this setup are having, are not hardware deficiencies but rather problems with the low-level software.  Either the firmware for the TBD USB ports, or the Logitech Unifying Receiver driver.


    I'd be really interesed in hearing from anyone using a Unifying Receiver with a piece of Logitech hardware other than the Performance MX mouse.  Or anyone else using a Performance MX mouse with their MB/MBA, with or without problems.


  • Chatlanian Level 1 Level 1

    @Gorbet TB Serial: C02GM38K0JGR


    Sleep / Wake, plug / unplug works with only the network and full size mac keyboard plugged in to it. But with the Logitec Performance MX dongle it does not. In particular, the keyboard and mouse are not working after reboot when plugged in to the TB.


    For the most time I do not shut down my macbook, just close the lid and it goes to sleep. I drive home and plug it in to TB. When I go to work I unplug it from TB and it is sleeping on the way to the office, at work it gets plugged in to a pathetic DeLL crappy monitor, though no problem waking up there.



    Quick question, @Gobert, do you shutdown the macbook and then start it back up when plug in in to TB or do you sleep it by just closing the lid and then hook it up to the TB and hit the external keyboard to wake it up?

  • Gorbet Level 1 Level 1

    I almost never shut down my MBA; it is always on sleep.  I have noticed that once I have run into an issue with the Logitech receiver/mouse, if I reboot the MBA with the TB plugged in the mouse and other peripherals will work.  So one option for you might be to just shut down your mac when you leave work, plug in the TB at home, then boot it.  That process might solve your problem.  For me, I'm hotswapping the TB (or trying to) several times a day at work so it's less convenient.


    If that does work consistently for you, then we have two possible work-arounds, at least:


    1. plug the unifying receiver into the laptop itself, not the display, or

    2. boot the laptop _after_ the display is plugged into it.



  • Chatlanian Level 1 Level 1

    Rebooting, Ney. This is what Windows users do, arn't they? Very retro.

  • Gorbet Level 1 Level 1

    Well, yeah, but it does provide a work-around to the problem.  :-)

  • ejkitchen Level 1 Level 1

    I switched monitors to C02H60XJDJGR and same problem today. I am trying another one (we have lots of new Thunderbolt displays).


    Either Apple has two or more suppliers for internal components and those of us with the bad one are having problems or there is a bug in the Thunderbolt/USB driver/firmware. My gut tells me this is a driver/firmware issue.

  • riaandelange Level 1 Level 1

    I have the same problem. Sometimes the screen is just dead in Windows. The other time I left it off overnight, and it worked again in Windows. Once I enabled the Gigabit NIC in Windows, I got a buzz noise then blue screen. It's as if it couldn't talk to the hardware device, then bombs out.


    My USB's are DEAD on the screen. Mouse, Keyboard and USB HDD seems to work for 10sec whilst booting into Windows, then all of a sudden they stop working. I plug them out, and directly into my MacBook Pro, then they work again.


    My colleague has the exact same setup as me, MacBook Pro 17" Mid-2011 with 27" Thunderbolt, and he has no issues. I was the one who updated my Software & Firmware via Mac OS X. He did not...

  • diogomes Level 1 Level 1

    I have the exact same problem discussed here...


    I have an 11" MacBook Air (mid 2011) and an Apple Thunderbolt Display (TD).


    Previously to acquiring a Logitech Marathon Mouse M705, I would disconnect the TD from the MBA and put the MBA to sleep by closing the lid, would take the MBA home and turn it on, return to the office plug the MBA to the TD and everything would be OK. At this time, I was using a USB cord-based Intelli Mouse from MS.


    After buying the M705, I simply plugged the RF receiver on the same port where the cord mouse was plugged in. Today, when I get back to office and plug the MBA back to the TD, not a single USB device connect to the TD will work. If I disconnect the TD, my MBA will simply freeze and requires a reboot.


    Having the receiver directly connect to the MBA makes everything work OK (except that I don't want to carry the receiver around!)


    I have noticed the following error on my kernel message log (dmesg) on connecting the TD:


    [ PCI configuration end, bridges 17 devices 18 ]

    USBF:          63988.948          The USB EHCI driver found a controller at the wrong PCI Power State (0x9) - fixing that issue.


    Hope this helps to sort out the problem.


    There is also a thread at logitech forums about this problem.

  • Gorbet Level 1 Level 1

    Thanks @diogomes!


    It seems, then, that this problem is related to the Logitech Unifying Receiver, not just the Performance MX mouse.


    With the console open, I just tried watching kernel log messages as I plugged/unplugged the TD with/without the Unifying Receiver in a TD USB port.  I didn't see the message you mention, though I can confirm that as usual, my other USB devices work if the UR is not in, but don't work if it is in.


    Then, I searched all my logs for the string "USBF" and did find some messages, but not the one you list, and none for the past 3 days.


    Is it possible this error is a red herring?  Can you try examining the logs as you hotswap the TD with and without the UR in?

  • Gorbet Level 1 Level 1



    I was reviewing this thread and noticed you said


    "In particular, the keyboard and mouse are not working after reboot when plugged in to the TB."


    In my case, I just tested this, and if I


    1. plug the UR into my TBD

    2. plug the TBD into my MBA

    [at this point, USB devices on the TBD are not working]

    3. restart my MBA


    then after the restart, the USB devices are all working, including the one on the UR.


    Is that different from your case?



  • Chatlanian Level 1 Level 1

    A bit of an update:

    I thought, in fact I was convinced that all my problems were to do with the Logitech in particular plugged in to TB. Because once I started just plugging the dongle in to the MBP problems went away. But the thing is, that nothing else was really plugged in to the TB except a full-size mac keyboard, and ocasionally my iPhone.


    Now my boss told me we need to write an app for android platform as well and gave me a variety of those pesky android phones to play with. (I am not a big fan of android at all, just business). Thus if I have any of those rascals plugged in to the TB and I dare to connect my sleeping MBP in to it, the waking up / booting problem is back. This tells me that it is not Logitech, but other USB devices can cause this same problem.


    If nothing except the keyboard and network is plugged in to the TB all is well.

  • diogomes Level 1 Level 1

    Thats interesting...


    Some more information:

    - I always keep a Belkin powered USB Hub (F5U233) connected to the TBD all the time. And that doesn't affect this issue.

  • ejkitchen Level 1 Level 1




    I concur. I have a powered Staples USB hub and it causes the same problem. My co-worker has a generic USB drive enclosure and it too causes the exact same issue. This is not just a Logitech issue.


    An update on monitors. I now have tried 5 different Thunderbolt monitors and all exhibit the same issue.


    And here is another interesting tidbit. If my monitor's usb hub goes down and my computer does not crash and I move my Logitech mouse dongle from the monitor to the Macbook Pro, it works *BUT*, the scroll wheel goes into high gear and essentially it now does 10 lines at a time instead of 2-3 or whatever the setting is normally.



  • Gorbet Level 1 Level 1

    Okay.  This is just too weird.  In the process of testing a Targus powered USB hub on my setup, I seem to have been able to successfully hot-swap with my Logitech UR in the's intermittent, and I'll see if I can do some more testing another time, but I was able to successfully hotswap several times in a row.  One thing I'll be following up on: the display power connector wasn't hooked up to the MBA, just the TB cable.  That might fit with the kernel message @diogomes was getting about power states...


    In the mean time...So it looks like some devices cause this problem and some don't.  Inventory so far...


    Seem to play fine with the TBD USB ports:

    - Logitech Cordless Mouseman (@Gorbet)

    - BYTECC SmartDrive USB HDD enclosure (@Gorbet)

    - Blue Snowball USB microphone (@Gorbet)

    - Apple full-sized USB keyboard (@Chatlanian, and others)

    - Belkin powered USB Hub (F5U233) (@diogomes)

    - MS Intellimouse USB corded mouse (@diogomes)

    - Targus powered USB Hub (PAUH216) (@Gorbet)


    Cause USB ports to stop responding when TBD is plugged into MB:

    - Logitech Unifying Receiver (@Gorbet, @diogomes, and others)

    - some Android phones (@Chatlanian)

    - powered Staples USB hub (@ejkitchen)

    - some generic USB HDD enclosures (@ejkitchen)


    This points  (in my semi-educated mind) to either some devices ignoring something about the USB standard, or the Apple TBD ignoring something about the USB standard.  I'm now thinking it's the latter, given that it's happening across devices from multiple manufacturers.

  • diogomes Level 1 Level 1

    As it turns out, it has nothing to do with the UR... The TBD display alone will always generate this message

Previous 1 2 3 4 5 Next