Previous 1 2 Next 17 Replies Latest reply: Sep 16, 2012 7:45 AM by jdietsch
Terry58 Level 1 Level 1 (0 points)

I have several Alias Icons on my desktop which are unable to be removed.

I have tried changing the rw permission and reselecting the original appliaction etc.

But still unable to delete these alias icons.

 

can someone point me in the right dircetion to use Terminal command such as rm -f file name

to permanetely remove these left over icons.

Before OS X Lion 10.7 I was able to chmod etc and delete the icon.

Thanks


MacBook Pro, Mac OS X (10.7.2)
  • Topher Kessler Level 6 Level 6 (9,605 points)

    What happens when you try to remove them? Do you get a specific error in the Finder when you move them to the trash?

  • Terry58 Level 1 Level 1 (0 points)

    Hi,

    When I select the alias icon in Finder and "Move to Trash"

    I get a box asking for my admin password, when I input p/w and return, All I get is the noise of file being dropped in trash, but No error message etc.

     

    Also tried using App Cleaned no different.

     

    The Alias icon permisions are set to rw when I use terminal ls - l command.

    any help thanks

    Terry

  • leroydouglas Level 6 Level 6 (14,800 points)

    Did you try relaunching your Finder.

     

    >Force Quit>Finder> Relaunch

  • Terry58 Level 1 Level 1 (0 points)

    I have relaunched finder and rebooted OSX several times since this p[roblem first occured about 4 MONTHS ago.

    I need to remove several Alias Icons which are no longer requiered on the Desktop, some of which no longer have their original appliactions installed.

    Heres a screen shot of the Terminal Screen after doing ls - l in the Desktop

    ( The Alias icons are all the ones with rw --rw--@)

     

    terry mac book pro:desktop terencethirlwell$ ls -l

    total 4104

    ----rw-rw-@  1 terencethirlwell  staff  405448 24 Apr 15:46 Blackmagic Disk Speed Test.app

    drwxr-xr-x   5 terencethirlwell  staff     170  1 Aug  2011 MiniVNA

    lrwxr-xr-x   1 terencethirlwell  staff      35  8 Sep  2011 My BT.app -> /Applications/BT Home Hub/My BT.app

    -rw-rw-rw-@  1 terencethirlwell  staff  144664 24 Apr 15:08 Stickies.app

    lrwxr-xr-x   1 root              staff      29  9 Oct  2011 VinylStudio -> /Applications/VinylStudio.app

    -rw-rw-r--@  1 terencethirlwell  staff  144608 23 Nov 11:54 WDNAS1 alias

     

    Thanks

  • Topher Kessler Level 6 Level 6 (9,605 points)

    Try doing this. Open the Terminal and type the following command followed by a single space (do not press enter yet):

     

    sudo rm

     

    Then drag one of the stubborn aliases to the Terminal window (its full path should complete when you do this), and then press Enter to run the command. Supply your password when prompted, and the alias should disappear.

     

    If this works as expected, then perform this same procedure for the other aliases, and you should be good to go.

  • Terry58 Level 1 Level 1 (0 points)

    Hi Topher,

    I have already tried using sudo rm -f

    etc

    here is my Terminal screen capture:

    terry mac book pro:desktop terencethirlwell$ sudo rm -f

    Password:

    terry mac book pro:desktop terencethirlwell$ /Users/terencethirlwell/Desktop/Stickies.app

    -bash: /Users/terencethirlwell/Desktop/Stickies.app: Permission denied

     

    I also tried the other Alias icons with the same result.

     

    When it asked for the password I gave my normal user password.

    Is there any root password I can use instead?

    This problem has been bugging me for quite a while now , and I would like to get it solved.

    Thanks

    Terry

  • Topher Kessler Level 6 Level 6 (9,605 points)

    Are you running in an administrator account? Try first running the following command:

     

    sudo su

     

    Then after authenticating run the folloing command to confirm you are running as "root"

     

    whoami

     

    When this is done, then run the "rm -f" command (there is no need to use "sudo" when running as root):

     

    rm -f path/to/file

     

    When done then close the Terminal and confirm to close all processes.

  • Terry58 Level 1 Level 1 (0 points)

    Hi Again,

    Thanks for all your suggestions regarding removing alias icons.

    I carried out the steps you put in your message.

    Here s the results:

    Last login: Tue Apr 24 17:15:56 on ttys000

    terry mac book pro:~ terencethirlwell$

    terry mac book pro:~ terencethirlwell$ sudo su

    Password:

    sh-3.2# whoami

    root

    sh-3.2# rm -f /Users/terencethirlwell/Desktop/Stickies.app

    rm: /Users/terencethirlwell/Desktop/Stickies.app: Operation not permitted

    sh-3.2# rm -f /Users/terencethirlwell/Desktop/Blackmagic\ Disk\ Speed\ Test.app rm: /Users/terencethirlwell/Desktop/Blackmagic Disk Speed Test.app: Operation not permitted

    sh-3.2# rm -f /Users/terencethirlwell/Desktop/WDNAS1\ alias rm: /Users/terencethirlwell/Desktop/WDNAS1 alias: Operation not permitted

    sh-3.2#

    So I am Not able to remove the alias icons !

    It must be a permissions problem.

     

    I will keep looking and trying different actions.

    Thanks

    Terry58

  • Topher Kessler Level 6 Level 6 (9,605 points)

    If the bare root user cannot perform these actions, then it suggests the problem is not permissions-related. The root account is not restricted by permissions at all, and unlike admin accounts does not need to request special permission to run commands without permission restrictions (such as using the "sudo" option before them). Therefore, this implies the problem is likely from an error in the partition/format structure of your drive.

     

    Have you tried using Disk Utility to check the drive for errors? Do this by selecting the boot device in the drive list and then running "Verify Disk" routine, followed by doing the same when you have selected the boot volume itself.

  • Topher Kessler Level 6 Level 6 (9,605 points)

    One additional option might be if there are file locks on the files. Get information on them in the Finder to see if the "Locked" option is checked in the information window.

  • Terry58 Level 1 Level 1 (0 points)

    Hi Topher,

    Re locked file option, I checked Finder Info and it shows that Alais File is NOT locked.

    Also I have run Disk Utilities and Verify Disk Routine with No Errors.

     

    I have just rebooted my MacBook Pro and retried removing the alias file but same problem.

     

    Someone suggested Login as a different user / admin super user?

    Are there any other Terminal commands which might be useful?

    Regards

    Terry58

  • Terry58 Level 1 Level 1 (0 points)

    Is there anyone out there in the Community Who can assist me with this problem?

     

    I have a number of Desktop Icons on my MacBook Pro running OS X Lion 10.7.3, which are Alias Icons.

    I CANNOT Delete / Remove / Move to Trash /Change them even after using Administrator and Terminal commands.

    Whatever I try results in an error message such as  "Operation not permitted" or "Permission denied"

     

    I have checked that I am logged in as Admin and accessing root etc.

    Also have run Disk Utility Verify and Pertmission checks etc.

     

    I know that Alias files are only small , But This is Bugging me and i Want to clear them of the Desktop.

    Previiously under OS X 10.6 I was able to delete alias files & Icons, but since insatlling Lion I have had this problem.

    Please Help - I Do NOT wish to Re install OS X Lion.

    Thanks

    in Advance

    Terry58

  • HeyAng Level 1 Level 1 (25 points)

    Terry,

     

    did you ever get this resolved?

  • Terry58 Level 1 Level 1 (0 points)

    Hi All,

    Yes I did manage to delete the Alias Icons from the desktop.

     

    I carried out a software update from Lion 10.7.2 to 10.7.3 and after that I tried to clean up the desktop etc.

    To my surprise the Alias Icons were no longer " Protected" and could be removed??

     

    I am not sure why this happened, but at least I now have no Ghost Icons on the Desktop.

    TThanks for asking

    Regards

    Terry

Previous 1 2 Next