Previous 1 2 Next 25 Replies Latest reply: Aug 29, 2012 9:50 AM by DMcVicker
meganfromferguson Level 1 Level 1

We have been trying to purchase apps through the App Store Volume Purchase Program site for over a week.  When we log in and select the quantity of apps we want and click "Buy", we receive the error message:

 

"We are currently experiencing technical difficulties.  Please try again later."

 

I have called customer service, submitted a Fast Lane inquiry, and no one knows or can say what the problem is. 

 

Anyone else having the same issue?  We have purchased apps in the last few months with no problems.


iPad 2
  • gyrhead Level 3 Level 3

    Which store and which country? Education? Business?

  • Friendship1234 Level 1 Level 1

    I am also having this problem.

     

    Its the Volume Purchase Program for Education

     

    United States

  • gyrhead Level 3 Level 3

    I just purchased an item this morning from the VPP education store - U.S..  no  issues. Have you agreed to the latest EULA?

  • meganfromferguson Level 1 Level 1

    We are trying to purchase from the business program, US, we just joined the program about a month ago so I assume that we are current on the EULA.  It seems like a site issue. 

  • gyrhead Level 3 Level 3

    I have had sporadic issues in the past with the VPP edu site but nothing that lasted longer than a few hours.  When it was down I called my rep and I was informed it was due to site maintenance.  Again, I have used the site twice today, once to buy and once to download a spreadsheet and there were no issues.

  • meganfromferguson Level 1 Level 1

    I just figured it out.  If you are using a PC, change your cookie settings to accept all cookies from apple.com.  Then it should work.  Hope it helps!

  • JoeEtnaSupply Level 1 Level 1

    I tried Chrome, IE, FireFox nothing would work, accepted all cookies, delete temp files and history, nothing worked. I tried Safari and my volume purchase went right threw first try.

  • sreilly99 Level 1 Level 1

    I , too, am having trouble for the last couple of days.  Got the same "Technical Difficulties" error yesterday and now I can't even load the store.  It flashes the store for a second, that goes away and just spins on a blank page.  FIrefox and Safari have the same symptoms.

  • gyrhead Level 3 Level 3

    Check your proxies, filtering, and firewall logs. Set your browser to the lowest security settings. Turn off pop up blocking .  When you open the education store now it redirects to another page with this message:  "This web page is being redirected to a new location. Would you like to resend the form data you have typed to the new location?".  If this is being suppressed due to a security setting in your browser or there is an https 443 setting in your firewall that is set to the highest level you won't get anywhere. You could try the store from home or a non work location and see if that helps/

  • lvtab Level 1 Level 1

    I'm having exactly the same problem -- the quick flash to store for a second and then spinning. Tried Firefox, IE, Safari. I have no proxies or filtering, no popup blocking, accepting all cookies. I've tried the store from both home and work; same results. This has been happening for a few days this time around. I also happened for a few days in late March.

     

    Is anyone at Apple working on this?

  • gyrhead Level 3 Level 3

    Lower the security setting in your browser, allow page redirects.

    I have been using the education VPP store on and off all this week with no issues. Worked in both the latest versions of Firefox and IE.

  • lvtab Level 1 Level 1

    tried all these--no result. it hangs showing "transferring data from metrics.apple.com" in the status bar.

    p.s. tried it on a newly installed Safari; same result

  • gyrhead Level 3 Level 3

    Ok, this just happened to me too.  I emailed an Apple Inside Account executive to see if they know whats up.  Stay tuned.

  • gyrhead Level 3 Level 3

    The response from Apple " Iam sorry, it is being worked on.   A known issue."

Previous 1 2 Next