4 Replies Latest reply: May 29, 2012 4:47 PM by Pondini
guitarplayr82 Level 1 Level 1 (0 points)

Lately it seems that Time Machine has been underestimating the size of each backup. What it originally says to be a 10 MB backup turns out to be several GB. As it's backing up, Time Machine will say "X out of 10MB backed up" or something along those lines, but when X reaches 10MB, X continues to grow and so does the original estimate of 10MB. It might then say "13MB of 13MB backed up" and it will continue on this way until it has backed up so much underestimated data that Time Machine tells me it can't finish the backup because it doesn't have enough space on the backup drive. (Time Machine should've deleted some backups beforehand to make space for the new backup, but it didn't know to because it had underestimated the amount of space necessary for the backup.)

 

 

I have already wiped the backup drive and deleted all the Time Machine preference files, only to still face the same problem. I'm backing up my internal 1TB drive (only 300 GB used) and my 500GB external drive (400GB used) to another 1TB external drive, so having enough space on the backup drive shouldn't be the problem, right? BTW, I'm running Snow Leopard. Any help is appreciated!


iMac, Mac OS X (10.6.8)
  • Henry314 Level 1 Level 1 (5 points)

    I am having this same problem too on Lion. I am trying to back up about 380gig of data onto a 1tb drive, and it continutes filling it indefinatly. I ejected all my other hard drives and reformatted the backup drive, but it appears to be doing the same again.

     

    Any help would be greatly appreciated.

  • Henry314 Level 1 Level 1 (5 points)

    OK, I've solved it on my machine, but I'm not sure if It will work for you as it sounds like you may have already tried what I did. Plus you're in a different OS. Anyway, this is exactly what I did, I'm not sure if all the steps are necessary, but its worth a shot.
    1.Turn off time machine.

    2. Unplug all of your external drives (except the one you are backing up onto).

    3. Reformat the drive you intend to back up onto.
    4. Go into your time machine preferences and click options.

    5. Add all but one of your folders to the list of things to exclude from the backups - make sure the folder dosent contain very much, I picked one with about 1.5 gig of stuff. Its ok if its a subfolder.
    6. Turn on time machine and tell it to make a backup. It could take as long as an hour for it to do this but it'll get there, dont be discoured if it sits there calculating for ages. When it finally starts to backup it will do the thing where it continues adding to the amount but it won't go on forever. Mine stopped about about 4 gig.
    7. Reopen the time machine preferences and deselect some of the folders in the exceptions list. Try and do this in small blocks.
    8. Tell time machine to perform another backup. It shouldn't take nearly as long as it did the first time.
    9. Repeat steps 7 and 8 until you have backed up the whole drive.

     

    By the time I finsihed the 384 gig of data I was backing up was only taking up about 400 gig of space.


    Also I'd really appreciate it if someone would explain to me why the **** what I did worked. Just in case I get a simliar problem again in the future.

  • guitarplayr82 Level 1 Level 1 (0 points)

    Hmm, interesting. Thanks for posting what worked for you. My problem actually randomly went away a couple weeks ago. I have no idea what I did to fix it, but TM is working as it should now.  It must've been one of those many reformats/resets I did. If the problem ever comes up again I'll try the steps you posted.

  • Pondini Level 8 Level 8 (38,715 points)

    Henry314 wrote:

    . . .

    Also I'd really appreciate it if someone would explain to me why the **** what I did worked.

    Most likely, there's a directory problem on your internal HD that's causing the overestimate.  Try verifying your internal HD, per #6 in Using Disk Utility.