8 Replies Latest reply: Nov 5, 2013 11:14 AM by comoquiera
H1lgy Level 1 Level 1

HI,

 

I use a MacBook Pro and until today the sound worked fine. All of a suden the sound doesn't work, having checked the sound settings there is no option to select internal speakers the only available option is 'Optical digital out port'.

 

Any sugestions?

 

Thanks


MacBook Pro, Mac OS X (10.7.3)
Solved by softwater on Apr 25, 2012 10:37 AM Solved

Have you got a TV or some other device connected to your Mac? Unplug everything and restart. Same problem?

  • softwater Level 5 Level 5

    Have you got a TV or some other device connected to your Mac? Unplug everything and restart. Same problem?

  • H1lgy Level 1 Level 1

    No, nothing have restarted and tried updating software??

  • softwater Level 5 Level 5

    Start your computer up in Safe Mode:

     

    http://support.apple.com/kb/HT1455

     

    Same problem? If NO, then restart normally, and look at your Login Items list here:

     

     > System Preferences > Login Items

     

    Something in there is messing with your system. Try removing anything that you remember adding recently and restarting again.

     

    If you're not sure, just make a copy of the whole list by taking a screenshot: hold down 'shift-command-4 and press the spacebar to highlight the window, then clikc your mouse or trackpad; the shot is on your desktop.

     

    Next, select all and hit the '-' minus key at the bottom of the window.

     

    Restart and see if the problem is solved. If so, start adding things from the list back in one at a time till you find the culprit (you'll have to restart after adding each one to test that).

  • Nosaint Level 1 Level 1

    Just experienced the issue with the sound prefrences not showing the internal speakers.

    So plugged the headphone in headphone jack a couple of times and it resolved my issue. ITs weird as it never happened before, this is the first time..

  • Van-D Level 1 Level 1

    I had the same problem but it seems to have stemmed from a failure of the earphone jack to reset when I'd removed an external speaker I had used.  I reconnected the pin plug and removed it and the internal speaker retruned. Aparently the jack replaced the internal speaker with digital output which remained when the plug was removed.  Re-inserting and removing the plug reset the output.

  • thoughton Level 1 Level 1
    expertise.macosx
    Mac OS X

    FWIW, my fix was not to stick a toothpick into the socket like some other suggested, but to put my lips to the socket and suck out the fluff.

  • comoquiera Level 1 Level 1

    I jusgt tried it but nothing. I do see a red light, does that mean it is stuck in that mode?

  • comoquiera Level 1 Level 1

    nothing else plugged in