Previous 1 2 Next 29 Replies Latest reply: Oct 21, 2012 9:03 PM by steadyeddy2 Go to original post
  • ant_b Level 1 Level 1 (0 points)

    sorry to join this thread just now.

     

    I am in Italy; I have(I have 6Mbps band, Airport Extreme+Airport Express, working fine with other downloads.

     

    I have been trying trying to download a movie with SD and I am experiencing a very slow dowloads (from 6hrs->24hrs). Problem seems to be in common with many users, since very long time (I have seen forums on this subject from 2008). I have 2 questions:

    - I have understood that slow download might be caused by DNS setting. How do I fix it?

    - I do not see in my iTunes library the movie I rented (and I am tryng to see) . I can I do?

     

    cheers

  • MikeB NZ Level 1 Level 1 (0 points)

    I'm also in NZ on TelstraClear cable, just upgraded to Warpspeed 100Mb.  Nothing wrong with the internet connection, I'm getting 30Mbps down, and downloading an HD movie from iTunes it runs between 5Mbps and 7Mbps without any issues.

     

    BUT, my Apple TV 2 has gone from instant download and ready to play, to a 45 minute delay before its ready to watch.

     

    Looking at my firewall stats it seems that the AppleTV is limiting its download rate to a steady 4Mbps, even though there is plenty of bandwidth available it just caps itself at 4Mbps.  This is in contrast to renting the same movie via iTunes on my Mac and the firewall shows it using between 5-7Mbps.

     

    So this isn't an internet issue, its an Apple TV issue.  The device is rate limiting itself for some reason.

     

    Seriously its so bad I'm about to stop using it, which is a real shame because a month ago I loved my Apple TV and recommended it to everyone.

     

    Also, it seems the list of movies available for rent on the Apple TV is now very limited, where as on iTunes there are many more movies for rent.  Or am i just being paranoid?

     

    There is a note in the iTunes help files that states:

    Note:  If you plan to watch a rental using Apple TV, you’ll get the best-quality video by renting it using your Apple TV. HD movies rented using Apple TV can’t be transferred to another computer or device. For more information, see the documentation for your Apple TV.

     

    I wonder if the Apple TV movie version is different, perhaps a much higher bitrate with less compression, hence bigger file and longer download. 

     

    I'm going to try doing the network test on the Apple TV but I will tell it I have only a 2-3Mbps connection and see if it adjusts itself down to a lower bitrate movie file... maybe its the fact that it now has such a high speed connection it is trying to download too higher a quality movie?

  • ZSS Level 1 Level 1 (0 points)

    Hi all,

     

    I am also on Telstra Clear network in NZ, I discovered problem with slow downlaod and all sort of delays and errors, since I changed from Telecom to Telstra Clear, my judgement is based on the following experiment:

     

    1) Power off your Telstra Clear Router

    2) Activate your Personal Hot Spot on your Mobile

    3) Access Vodafone 3G internet network  through apple TV

    4) Try start a rented movie and you will see for your self that life is normal again.

     

    I believe is to do with Telstra Clear NZ ISP and their DNS server being unreliable.

     

    Does anybody know how to fix this????

  • racock Level 1 Level 1 (0 points)

    Hi, I'm in NZ, and I know a lot of you are saying that you're on TelstraClear, but I'm on Telecom, and our connection is pants as well. Is there supposed to be a way you can tell the box to down load a movie in the background, rather than stream it?

     

    I know that waiting for 2 hours to watch a movie is pretty poor, but I could cope with that if I didn't have to sit in front of the screen waiting for it and unable to listen to any music either because otherwise it cancels the download.

     

    Just to clarify, yes, every time we exit the screen saying it's downloading, the download seems to cancel and the next time we go to watch it, we have to wait while it re-streams it from the start. Noted that if it ever gets as far as being ready to play, that I can press menu at that point and come back to it later, but it doesn't carry on downloading in the background after I've rented a film and told it that I want to watch it.

     

    Thanks for your help guys. It's well noted that no-one from Apple seems to post in these forums with any helpful insights, which rather points to an un-solved but known bug.

  • Cowan Pettigrew Level 1 Level 1 (0 points)

    hi all,

     

    chipping in. I'm a sysadmin for a large company. My home package is business connection on telstraClear.

     

    My DNS settings are as above for bevan and yet I'm still crawling when it comes to download. Prior to the update i was watching movies the moment i'd rented them.

     

    I've got no more to add at this stage other than we are in the same boat.

  • Cowan Pettigrew Level 1 Level 1 (0 points)

    I've also tried connecting via ethernet (cat 5 & 6), resetting, restoring, dancing around the fireplace whilst hopping on 1 leg and nothing yet as worked. I disconnected all devices that could possibly interfere with the ATV and still no difference.

     

    I'm beginning to think of as apple as, shiny outside, rottern to the core inside.

  • racock Level 1 Level 1 (0 points)

    Yeh, I'm not exactly a novice to IT either with over a decade of large corporate IT Support. But I'm only a recent convert to Apple having been given an iPhone for work, being wowed with the Pad, and then hearing how good the TV was, got one of them. Got fed up with the Win7 media centre, so added a MacMini to the mix, so now my TV can stream movies beautifully from the NAS and Novell server shares, but downloading movies is just painful. I think I'm on a version3 TV (the black one w/ HDMI), but it certainly has the performance of the v2 that everyone seems to be having since the software update.

     

    I have a friend who has an earlier one, and he's jail-breaked his to run xbmc (or whatever the Linux media centre is) and loves it, but I like the whole Apple interface. Shame about this one issue with streaming as it's a nice toy other than that.

  • Cowan Pettigrew Level 1 Level 1 (0 points)

    hi,

     

    Agrred, since the update, it is extremely slow. we run 3 mac servers in our lan with a huge mix of platforms, there are about 250 users and it's not the first time i've had to make/create/hack/ do a rain dance to get our Mac PDC's to do what they are supposed to do.

     

    I find it interesting that you gave up on Win7Media, i was going to take a look at that for interests sake however i think i wont now based on your thoughts here. To date my ATV has been mostly reliable except for the odd "your content cannot be displayed. Please try again later." :-)

     

    Have you seen the temp fix, download via itunes either rental/purchase then stream to ATV? i did that last night and it worked perfectly. Not as elegant i agree but workable.

  • MikeB NZ Level 1 Level 1 (0 points)

    Hi all,

    There is a simple fix.  Change the DNS servers on the Apple TV to Xtra's rather than TelstraClears.  This fixed it for me.  Previously under TelstraClear's DNS the download rate for the Apple TV was being capped at 4Mbps, after changing to Xtra's DNS servers it runs at full speed. 

     

    The DNS server I used was 202.27.158.40.

     

    Below is a snapshot of the throughput graph on my firewall.  You can clearly see on the left the traffic being capped at 4Mbps, then after changing DNS servers it runs full speed on the right.

    Screen Shot 2012-10-13 at 3.30.43 PM.png

  • Cowan Pettigrew Level 1 Level 1 (0 points)

    hI Mike,

     

    Thanks for this, i'll give it a go. I'll admit to being slightly confused though. DNS is a pointer only not routing so simply getting a translation from xtra DNS servers as opposed to TCl shouldn't make a difference as the ATV will then connect direct to the IP given which across both DNS servers should be the same unless apple are running mirors on ISP networks.

     

    I'll admit the graph doesn't lie and neither does the data outcome. I'd being interested to know where your ATV went after this, i.e. the same IP that TCL dished out or a mirror located on the telecom network?

     

    I know that when my mac connects for apple updates it connects to a 203.167.x.x subnet which is owned by TCl so its possible that mirror sites are in operation which would explain your findings above.

     

    Cheers

     

    Cowan

  • Cowan Pettigrew Level 1 Level 1 (0 points)

    wow ok that works for me as well.

     

    Awesome man. Perhaps a reason to swap from TCL to Telecom?

     

    Cheers

  • MikeB NZ Level 1 Level 1 (0 points)

    Hi guys,

     

    This is why it matters which DNS server you use:

     

    The Apple TV content is hosted by Akamai, a global content delivery company.  They have servers all over the world hosting the content so that it can be provided from a nearby location, rather than sent from overseas.

     

    Akamai uses the IP address of your DNS server to work out where you are, and then provide the IP address of the nearest Akamai server.  So although DNS has nothing to do with routing, it is just a lookup service, Akamai uses the DNS server as the location pointer.

     

    It seems then that TCL's DNS servers are seen by Akamai to be elsewhere, perhaps in Australia.  So that when your Apple TV looks up Akamai's IP address using a TCL DNS server it gets given the address of a server in Aussie (I'm just guessing that its in Aussie given the slower performance, it might not be).

     

    But if you use Xtra's DNS servers Akamai provides a local NZ based server, hence the must faster performance.

     

    This isnt a reason to change from TCL to Xtra, afterall if you are on Warpspeed you'll still get much better performance than on DSL.  But it is a good reason for TCL to talk to Akamai and get their DNS servers being pointed to a local NZ based Akamai server.

     

    TCL are you listening - this is a TCL / Akamai issue and it needs to be fixed.

     

    Cheers
    Mike

  • Cowan Pettigrew Level 1 Level 1 (0 points)

    Now that is awesome answer. I stand in awe.

     

    Cheers Mike

     

    +1

  • Cowan Pettigrew Level 1 Level 1 (0 points)

    I did a bit more digging. It appears that Telecom and Orcon have local akamai servers on there network whilst Telstraclear do not.

     

    Not helpful TelstraClear.

  • steadyeddy2 Level 1 Level 1 (0 points)

    Hi, I have had this problem as well so I changed the SERVER  setting as provided by my ISP on My Apple TV and this has fixed it.

     

    Good Luck

Previous 1 2 Next