Previous 1 2 3 4 5 6 7 Next 93 Replies Latest reply: Nov 24, 2014 4:21 PM by hwoodlive Go to original post
  • Volantiad Level 1 (0 points)

    I'm dismayed to see that the original post for this problem ~ which exactly describes my problem ~ was made in late April of this year... about 6 months ago.  I didn't start suffering from safari atrophitis (made that up) until about maybe 6 weeks ago.  Kinda crept up on me till I really noticed it about 3 weeks ago.  I guess I just hoped it'd go away on it's own (i.e. Apple might fix the problem) but it hasn't.  Sadly, it seems like the 'cure' is to stop using Safari and switch to something like Chrome or FireFox.  Well, if I have to, I will.  I can't take waiting 10, 20, 30 seconds for a webpage to open... if it does at all.  Yahoo, particularly, seems to suffer from this ailment although no webpage seems imune.  Bye, bye safari: it's been nice knowin' ya.   

  • fruzzl Level 1 (0 points)

    I agree. I just upgraded to mountain lion and noticed a degredation in performance with safari. Not sure if the reason is related to mountain lion or not but it appears to be an unisolated issue.


    For me, when I search, or type in an address in the url line of Safari, it will freeze after I hit enter for roughly 10-30 seconds. It then loads fast...but it's quite frustrating. I hope this isnt a sign of things to come with Apple in general now that their fearless leader has passed.


    If Apple techs are reviewing these forums please read through this thread thoroughly as this is a very frustrating issue.

  • Bucky Turgidson Level 1 (0 points)

    I have the same problem.


    It is definately Safari related as using any other browser removes the delay.


    This is a shame as I like Safari but i cant pu up with such slow page loading.


    I may have to look at option 5!

  • G.Madigan Level 1 (0 points)

    I tried the suggestion by "Hal in Maine":


    I have been having the same problem, but may have at last found a fix. I am running Mountain Lion and an Apple Airport Extreme Basestation router along with a recent iMac. What I did was go into Network settings through System Preferences, click on Advanced, click on the DNS tab, and then the + sign under DNS servers. Then I added the Google DNS address, which is 2001:4860:4860::8888. I then dragged this address to the top of the list of DNS servers and clicked Apply. Restarted Safari and Chrome and both are now much faster on loading web pages. Hope this may help.


    • Making sure 2001:4860:4860::8888 (EXACTLY as shown with the double colons :: ), and it was first in the • DNS list by adding it (copy/paste works) then dragging it to the top of the list.

    • Be sure to click the "Apply" button before leaving Network Preferences. (BTW – I never used WiFi, it's not on, but to suggest turning it off and using an ethernet cord as a solution is insane in 2012. That is NOT a solution.)

    • Quit Safari and re-opened it.

    • I haven't tested it long term.


    Although Safari's blue progress bar is still acting very oddly (pausing about 80% of the way across then vanishing for a several seconds), the reliability of it loading a page has been perfect so far.

    A quick side-by-side comparison with Firefox showed no significant difference when going to a few not-previously-visited sites.



    WARNING: Rant Ahead!


    I am getting very tired of bumping into more and more half-baked Windows-like problems with an Apple logo on it. The worst of it is Apple now gives Microsoft-like (read as useless and fonger-pointing) solutions that are often taking months, if they ever reply. I can see why Woz left to go to Australia; MUCH faster internet and to get away from this Microsoft-like morphing of Apple, a producer of cheap and poorly tested hardware and software, and big $$ for minor (if any) improvements.


    Do you remember when the Apple stores had chilled bottles of water?

    Do you remember when the Apple stores had people demoing the hardware that knew how to format a drive?

    Do you remember when the Apple stores had people demoing the hardware that knew what a Level 2 Cache was and what it did?

    Do you remember when the Apple stores had people that didn't make you feel like you were an idiot for spending so much on so little?


    OK: Done ranting.

  • fruzzl Level 1 (0 points)

    I too tried the suggestion by Hal in Maine and my problem persisted. Now i'm starting to think it doesnt have much to do with Safari though. Everytime I wake my macbook from sleep mode it drags when trying to load a page. I have to reset the wifi in order to continue.


    Before it appeared it had only to do with Safari, then I thought it hd something to do with flash player, but I'm not sure anymore. Hal in maine seems to have issues with google pages only which isnt my problem and most others on here. This happens on every page.

  • Gontran Bolduc Level 1 (0 points)

    I may have found a solution for the problem of speed interruption.


    The logic I followed is this one.


    There is no pattern for the anomaly to occur. I presumed the IMAC is working properly because the same event happened to different computers at home. I suspected the problem was in communication with the service provider because I have a server on my intranet and the problem was not present.  Then I assumed 2 automatic communications programs were fighting for control.


    Here is what I did and this worked for me 95% of the time.


    Go to system preference


    Click on

    • network
    • advance
    • Hardware
    • MTU - Change Automatic to Custom and in the window change 1500 to 1300.
    • Click on OK
  • Thomas Harnish Level 1 (20 points)

    Solved the problem. Curious, worked fine for, well, since forever. Then suddenly every pageload studdered or failed. Your solution fixed it for me.

  • Hal in Maine Level 1 (0 points)

    I did what Gontran suggested and, miraculously, both Safari and Chrome have improved their response times. Just like the good old days. Both are now much speedier in their retrieval of web pages, both on my iMac running Mountain Lion and on my iPad running IOS 6.0.1

    Now, if Apple would just publicize this fix!

  • Gontran Bolduc Level 1 (0 points)

    I did report to apple the problem and the temporary fix. 

  • A.Gardoh Level 1 (0 points)

    This worked for me

  • pato_londres Level 1 (0 points)

    Hi Gontran Bolduc tried to use your solution, but I use WiFi to connect to the Internet and therefore my setting are different.


    Do you have a solution for WiFi users?

  • Gontran Bolduc Level 1 (0 points)

    I hope I am giving you the answer you are looking for:

    in the preference you click on


    • wi-fi
    • advance
    • Hardware
    • MTU - Change Automatic to Custom and in the window change from 1500 to 1200 or 1300 or 1400. (The site Thomas Harnish found is really good.)
    • Click on OK and apply


    If use a IPAD after sync. with your computer, (I suspect) it will modify itself for the size of the packet.

  • pato_londres Level 1 (0 points)

    Hi Gontran Bolduc I don't appear to have these setting. I trying to attach a screen grab so you can see my menu settings. Thank you very much for helping me



  • Gontran Bolduc Level 1 (0 points)

    Are you talking about a computer, an Ipad or Iphone?