Previous 1 2 3 Next 93 Replies Latest reply: Nov 24, 2014 4:21 PM by hwoodlive
excelcius Level 1 (0 points)

Hi I've been having a problem with Safari for the past few months it frequently freezes when loading web pages, sometimes it will eventually load, other times it wont. the blue progress bar in the address bar stops on about 10% with a plain white page it doesn't happen all the time but disturbingly it happens on pages as simple as Google search, not just data heavy sites. other symptoms include having to click links several times to get them to respond and I get the you are not connected to the Internet page when I go to some sites only to try another page from my bookmarks and it will load perfectly.


Any help greatly appreciated its driving me nuts.

iMac, Mac OS X (10.7)
  • excelcius Level 1 (0 points)

    Thanks Linc I'll look into that, Im just looking into firmware upgrades first best to keep everything up to date, for the benefit of anybody with a similar issue I'll update you as to my progress.

  • excelcius Level 1 (0 points)

    No Ive tried all that still the same problem

  • Linc Davis Level 10 (192,629 points)

    Can you reproduce the problem? That is, does it always happen when you take a certain action?

  • excelcius Level 1 (0 points)

    No it seems quit random even doing something as simple as pressing the back button results in blank white pages with the spinning loading icon at the end of the address bar, some pages load fine others don't for example I might type something into Google sometimes Google loads straight away sometimes it freezes up.

  • Linc Davis Level 10 (192,629 points)

    Please read this whole message before doing anything.


    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.


    Third-party system modifications are a common cause of usability problems. By a “system modification,” I mean software that affects the operation of other software — potentially for the worse. The following procedure will help identify which such modifications you've installed. Don’t be alarmed by the complexity of these instructions — they’re easy to carry out and won’t change anything on your Mac.


    These steps are to be taken while booted in “normal” mode, not in safe mode. If you’re now running in safe mode, reboot as usual before continuing.


    Below are instructions to enter some UNIX shell commands. The commands are harmless, but they must be entered exactly as given in order to work. If you have doubts about the safety of the procedure suggested here, search this site for other discussions in which it’s been followed without any report of ill effects.


    Some of the commands will line-wrap or scroll in your browser, but each one is really just a single line, all of which must be selected. You can accomplish this easily by triple-clicking anywhere in the line. The whole line will highlight, and you can then either copy or drag it. The headings “Step 1” and so on are not part of the commands.


    Note: If you have more than one user account, Step 2 must be taken as an administrator. Ordinarily that would be the user created automatically when you booted the system for the first time. The other steps should be taken as the user who has the problem, if different. Most personal Macs have only one user, and in that case this paragraph doesn’t apply.


    Launch the Terminal application in any of the following ways:


    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    ☞ If you’re running Mac OS X 10.7 or later, open LaunchPad. Click Utilities, then Terminal in the page that opens.


    When you launch Terminal, a text window will open with a line already in it, ending either in a dollar sign (“$”) or a percent sign (“%”). If you get the percent sign, enter “sh” (without the quotes) and press return. You should then get a new line ending in a dollar sign.


    Step 1


    Copy or drag — do not type — the line below into the Terminal window, then press return:


    kextstat -kl | awk '!/com\.apple/{printf "%s %s\n", $6, $7}'


    Post the lines of output (if any) that appear below what you just entered (the text, please, not a screenshot.)


    Step 2


    Repeat with this line:


    sudo launchctl list | sed 1d | awk '!/0x|com\.(apple|openssh|vix)|edu\.mit|org\.(amavis|apache|cups|isc|ntp|postfix|x)/{print $3}'


    This time, you'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. You don't need to post the warning.


    Note: If you don’t have a login password, you’ll need to set one before taking this step. If that’s not possible, skip to the next step.


    Step 3


    launchctl list | sed 1d | awk '!/0x|com\.apple|edu\.mit|org\.(x|openbsd)/{print $3}'


    Step 4


    ls -1A /e*/mach* {,/}L*/{Ad,Compon,Ex,Fram,In,Keyb,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Spo,Sta}* L*/Fonts 2> /dev/null


    Important: If you synchronize with a MobileMe account, your email address may appear in the output of the above command. If so, anonymize it before posting.


    Step 5


    osascript -e 'tell application "System Events" to get name of every login item' 2> /dev/null


    Remember, steps 1-5 are all drag-and-drop or copy-and-paste, whichever you prefer — no typing, except your password. Also remember to post the output.


    You can then quit Terminal.

  • excelcius Level 1 (0 points)

    Hi Linc thanks just a quick potentially stupid question there isn't anything in the output which could compromise my security if I post it on the forum is there ?

  • Linc Davis Level 10 (192,629 points)

    Not in my opinion, but that's for you to decide. Please don't make duplicate posts about the same issue.

  • excelcius Level 1 (0 points)

    I only posted the other post because I hadnt anticipated getting such a quick responce from you , Im on a tight deadline for work and I needed to get this problem sorted a.s.a.p, I didnt think that anybody else would hop onto this discussion Anyway heres the output I get


    Last login: Wed May  9 13:18:21 on console

    Gareth-Joness-iMac:~ gareth$ kextstat -kl | awk '!/com\.apple/{printf "%s %s\n", $6, $7}'

    Gareth-Joness-iMac:~ gareth$ sudo launchctl list | sed 1d | awk '!/0x|com\.(apple|openssh|vix)|edu\.mit|org\.(amavis|apache|cups|isc|ntp|postfi x|x)/{print $3}'



    WARNING: Improper use of the sudo command could lead to data loss

    or the deletion of important system files. Please double-check your

    typing when using sudo. Type "man sudo" for more information.



    To proceed, enter your password, or type Ctrl-C to abort.




    Sorry, try again.



    Gareth-Joness-iMac:~ gareth$ launchctl list | sed 1d | awk '!/0x|com\.apple|edu\.mit|org\.(x|openbsd)/{print $3}'



    Gareth-Joness-iMac:~ gareth$ ls -1A /e*/mach* {,/}L*/{Ad,Compon,Ex,Fram,In,Keyb,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Spo,Sta} * L*/Fonts 2> /dev/null










    Adobe AIR.framework











    /Library/Input Methods:



    /Library/Internet Plug-Ins:


    Flash Player.plugin


    Quartz Composer.webplugin

    QuickTime Plugin.plugin











    /Library/Keyboard Layouts:













    Flash Player.prefPane

















    Adobe Unit Types.osax




    Microsoft Office.mdimporter

















    Library/Address Book Plug-Ins:








    Library/Input Methods:




    Library/Internet Plug-Ins:



    Library/Keyboard Layouts:




    com.adobe.AAM.Updater-1.0.plist 8592213B6.plist




    Gareth-Joness-iMac:~ gareth$ osascript -e 'tell application "System Events" to get name of every login item' 2> /dev/null


    Gareth-Joness-iMac:~ gareth$



  • Linc Davis Level 10 (192,629 points)

    The problem isn't caused by third-party software. Please connect to your router via Ethernet and turn off Wi-Fi. Any difference?

  • excelcius Level 1 (0 points)

    I did that once before when I first started having issues ie I moved my mac next to the phone socket and connected the ethernet cable from the back of the router to the mac and I didnt seem to have the problem.

  • Linc Davis Level 10 (192,629 points)
  • excelcius Level 1 (0 points)

    No Joy I noticed the problem started when I tried to update my iphone to ios5.1 it wouldnt connect to the servers either via iTunes or on my iphone and I changed my DNS to opendns ie and after a few more tries I managed to update to ios5.1 via itunes, but since then Ive had this problem. Ive noticed that under network DNS settings I dont have anything set for Search Domains would that have any effect, what should it be set to ?

  • Linc Davis Level 10 (192,629 points)

    If you've taken all the steps recommended in that article, including checking to see whether a firmware update is available for your router, then you're probably dealing either with interference, a hardware fault, or an incompatibility between the router and the Mac. The 802.11n Wi-Fi standard was only finalized in 2009, though devices claiming to be compatible with it were in use before then. Those devices are sometimes incompatible.

Previous 1 2 3 Next