9 Replies Latest reply: Dec 31, 2012 9:36 AM by chakadog
bigio Level 1 (0 points)

Hi everybody,


I have been using a magicmouse with my macbook air and works fine, although since I have it I never manage to make it work with my Macpro. Always had a problem with the magicprefs always turning off and the scrolling not working.


I was hopping to get the problem solved with the Lion. Finally I did the upgrade and had the exact same problem.


When I turn the magicprefs on I get this error:

Screen Shot 2012-04-27 at 6.28.19 PM.png


and then, every minute get the following problem:


Screen Shot 2012-04-27 at 6.29.22 PM.png


     (MagicPrefs hanged and was restarted by MPSafeguard.

     This most likely means there are conflicts with other software, see MPSafeguard's preferences.)


This is not my first post on this problem, but never got a solution for it.

I don't have the usb overdrive installed, I know that can give this problem and already tried to uninstall several  programs to see if any of them were

creating this issue.


In the system preferences where I should find the magicmouse preferences I got the preferences for any other bluethooth mouse:


Screen Shot 2012-04-27 at 6.21.36 PM.png


I've tried everything that I can remember

If anyone can help me with this I would appreciate very much.


Thank u



Mac Pro, Mac OS X (10.7.3)