9 Replies Latest reply: Mar 17, 2014 7:09 PM by dmrich
TresRoque Level 1 Level 1 (85 points)

I've tried the few solutions in this forum but none work.


I can't figure out how to stop Spotlight indexing, as it's been doing it since yesterday.


Any tips?

Macbook 2.4Ghz (White) 4GB RAM, Mac OS X (10.6.4), Logic Studio 8, Safari 5.0.2, iLife 08, iWork 08, Aperture 2
  • Gerry Brown Level 3 Level 3 (795 points)

    Try the following:  {This will delete the Spotlight database and tell it to start over}

    1) From the Terminal

         >sudo rm -rf /.Spotlight-V100/*

    2) Reboot

    NOTE: It will take a couple of hours to reindex your hard drive. "Don't Panic"


    and if you have any large mounted drives you don't want indexed, in the Spotlight System Preferences, select the Privacy tab and add the volumes you dont want indexed.

  • TresRoque Level 1 Level 1 (85 points)

    Thanks. I tried it but Terminal rejected it 'permission denied'.


    Didn't reboot.

  • Gerry Brown Level 3 Level 3 (795 points)

    Umm, sudo reported permission denied?  Spacing is important.

  • TresRoque Level 1 Level 1 (85 points)

    I'm a n00b on Terminal I tried:


    • no spacing
    • one space
    • two spaces


    I just copied your command line from above and pasted it it.

  • Gerry Brown Level 3 Level 3 (795 points)

    Copy and Paste it exactly as it is, minus the ">" character.  I am assuming thatyour account has Admin piveledges, so when it asks foe a password, yours will work.

  • ds store Level 7 Level 7 (30,325 points)

    Run through this list and get back with me


    Step by Step to fix your Mac

  • TresRoque Level 1 Level 1 (85 points)

    Hi. I did that workaround in between waiting for another response:


    1. Go to System Preferences
    2. Choose Spotlight
    3. Privacy tab
    4. Select the User


    I then left it a few minutes to 'kick in' and hey presto! Spotlight ceased indexing. I then deselected the User profile from Spotlight, meaning I can use it again.


    Thanks for your help, though. I've filed it away for another day when Spotlight will most certainly do this again.

  • RyanBoulder Level 1 Level 1 (0 points)

    I had the same problem, but the solutions above (only doing sudo rm -rf /.Spotlight-V100/*) didn't work for me. Then I found this solution, which did work for me:


    http://guidovanoorschot.nl/how-to-fix-spotlight-when-it-keeps-indexing-n-mac-os- x-lion/

  • dmrich Level 1 Level 1 (0 points)

    so I've been annoyed to **** with spotlight for the last few weeks, only looking at it on and off. warning this will rebuild spotlight indexes of all drives afaik


    Tried and failed:

    system preferences, spotlight, privacy, add and remove the drive

    sudo rm -rf /.Spotlight-V100/

    sudo mdutil -ai off then sudo -ai on

    sudo mdutil -E /


    many of these have worked in the past, but osx had me in for some fun


    finally after finding nothing, and after all these steps watching spotlight reindex into eternity...




    dsenableroot (type your admin password then set a root password - note you won't see typing as the pw is hidden)


    login, select other user

    login as root/the password you just set

    rm -rf /.Spotlight-V100/

    mdutil -ai off

    mdutil -ai on

    mdutil -E /



    then logout, login as your admin again, open terminal

    sudo dsenableroot -d

    type user pw

    type root pw if needed


    spotlight pwned


    i know some of these steps are redundant, but might as well blow the #$%&%er away as reliably as possible. SUCH a simple fix can't believe i didn't think of it before. this also isn't the first time i've seen osx need you fully logged in as root to get rid of a strange issue. pfft.