Skip navigation

HT2490: Mac Basics: Set your preferences

Learn about Mac Basics: Set your preferences

HT2490 How can I change the language setting on my Mac?

16274 Views 30 Replies Latest reply: Jan 13, 2014 10:59 PM by hossam.alosh RSS
1 2 3 Previous Next
columbus new boy Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 28, 2012 2:00 PM

How can I change the language setting on my Mac? Even with everything I see set to English, when I install new software, it installs in Italian...

Macbook Pro
  • Linc Davis Level 10 Level 10 (107,695 points)

    Select  ▹ System Preferences ▹ Language & Text ▹ Language.

  • Linc Davis Level 10 Level 10 (107,695 points)

    So you install new software, any software, and the user interface is Italian, even if English is selected in the preference pane? Selecting another language has no effect? What about old software?

     

    Launch the Terminal application in any of the following ways:

     

    Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    If you’re running Mac OS X 10.7 or later, open LaunchPad. Click Utilities, then Terminal in the page that opens.

     

    Drag or copy — do not type — the following line into the Terminal window, then press return:

     

    defaults read -g AppleLocale

     

    Post any lines of output that appear below what you entered — the text, please, not a screenshot.

  • Linc Davis Level 10 Level 10 (107,695 points)

    According to the documentation, X-Plane has its own language setting. Have you tried changing it?

  • Linc Davis Level 10 Level 10 (107,695 points)

    When you log in, is the login screen in Italian?

  • Linc Davis Level 10 Level 10 (107,695 points)

    Please read this whole message before doing anything.

     

    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    The purpose of this exercise is to determine whether the problem is localized to your user account. Enable guest logins and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up a guest account” (without the quotes) in the search box.

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem(s)?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    Note: If you’ve activated “Find My Mac” or FileVault in Mac OS X 10.7 or later, then you can’t enable the Guest account. Create a new account in which to test, and delete it, including its home folder, after testing.

  • Alberto Ravasio Level 4 Level 4 (3,160 points)

    Can you post a picture of the menu. I can guide you in changing the default language if the option is available.

  • Kurt Lang Level 7 Level 7 (31,485 points)

    To set your preferred language, go back into the System Preferences > Language & Text. Click on the Language tab.

     

    On the left side in the list of languages, drag and drop (in your case) Italian to the top of the list. Log out and log back in, or restart for the change to take effect.

  • Alberto Ravasio Level 4 Level 4 (3,160 points)

    columbus new boy

     

    That's my point - I've tried that. In language there are several languages listed, all of which I use, but English is first and yet everytime I install new software the instalation is in Italian...

     

    He already has English at the top of the list.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.