6 Replies Latest reply: Apr 29, 2012 9:25 AM by Poikkeus
Poikkeus Level 4 Level 4 (2,785 points)

I want to confide with you before lugging my iMac to the Apple Store.

 

I've burned disks with several different applications, from Simply Burns and Liquid CD to Toast. No problems. However, several days ago, I encountered a curious error. When I tried using Toast, the display read, "No recorder found."

 

I tried using other burners, like Burn, with no luck. Same "No Recorder found" dialog, or something akin to it. Is this a software issue that can be fixed with some know-how? Or is this a hardware problem that willl require getting a new burner for my iMac? Have you encountered this error, or managed to fix it?

 

Thanks!


iMac, Mac OS X (10.7.3)
  • den.thed Level 7 Level 7 (25,180 points)

    Reset the SMC > Intel-based Macs: Resetting the System Management Controller (SMC)

     

    1. Shut down the computer.

    2. Unplug the computer's power cord.

    3. Wait fifteen seconds.

    4. Attach the computer's power cord.

    5. Wait five seconds, then press the power button to turn on the computer.

     

    the PRAM > Resetting your Mac's PRAM and NVRAM

     

    1. Shut down the computer.

    2. Locate the following keys on the keyboard: Command, Option, P, and R. You will need to hold these keys down simultaneously in step 4.

    3. Turn on the computer.

    4. Press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.

    5. Hold the keys down until the computer restarts and you hear the startup sound for the second time.

    6. Release the keys.

     

    then do a Safe Boot > Mac OS X: Starting up in Safe Mode

     

    1. Be sure your Mac is shut down.

    2. Press the power button.

    3. Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.

    4. Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

     

    Now try Burning a CD or DVD......

  • Poikkeus Level 4 Level 4 (2,785 points)

    Thanks for the comprehensive, clear explanation. However, I get the same error as before.

     

    Strangely, I can still import CDs via iTunes and watch DVDs. But something is stopping me from using the burner.

  • necronym Level 4 Level 4 (1,350 points)

    Is your system identifying a blank writeable disc?

     

    If not this sounds like a similar issue I was having which resulted in my iMac going away for a new SuperDrive

  • Poikkeus Level 4 Level 4 (2,785 points)

    A blank writable disk is identified. I also can't seem to reset the PRAM - which is a popular way to address this problem.

  • den.thed Level 7 Level 7 (25,180 points)

    If your using a wireless keyboard, try holding the keys down at the chime instead of before. Alternatlly you may want have to use a USB keyboard for entering resets and startup commands.

  • Poikkeus Level 4 Level 4 (2,785 points)

    Thanks again for your help.

     

    I use a wired keyboard. When I press the keys in the proper order, there's no chime. Instead, if I wait long enough, I'm at a textured gray screen where I enter my computer password. Then, I'm at the installation screen. In any case, it seems that PRAM reset is disabled. I'm not sure how to resolve this.