7 Replies Latest reply: Sep 17, 2012 3:24 AM by benbookpro
perky29 Level 1 Level 1 (0 points)



I have the Virgin Media Superhub and Apple Extreme.  I tried first just using only the Superhub (which doubles as a router), but the wireless strength was extremely poor.  So I have hooked up the Extreme, with the Superhub in "modem only" mode.


The internet is working fine, with much better wireless strength, but at least once a day I get a Double NAT error on the Extreme, flicking orange.  I will reset the Extreme and that seems to sort out the problem, but I would love not to have to do that.


Does anyone know what the Double NAT error might be, and what settings I should use on the Extreme?  It is set in DHCP and NAT mode (as using the Bridge mode doesnt' allow me to connect to the internet at all)


Many thanks for any help!

AirPort Extreme 802.11n (4th Gen), iOS 5.1
  • Bob Timmons Level 10 Level 10 (93,610 points)

    A Double NAT message indicates that you have two devices on the network that are both trying to act as the router for the network. You only want one device acting as a router on a network.


    Bridge Mode would be the correct setting for your AirPort Extreme.


    Suggest that you reconfigure it that way.


    You may not have power cycled your entire network previously.


    Very Important.....once the AirPort Extreme is configured in Bridge Mode, you need power off the entire network. Turn off all devices in any order that you wish.


    Wait a few minutes


    Start the Virgin Media device first and let it run 2-3 minutes by itself


    Start the AirPort Exteme next the same way


    Continue starting devices one at a time about a minute until the entire network is powered back up


    Check the network for proper operation.

  • perky29 Level 1 Level 1 (0 points)

    Bob, thanks very much.


    I gave that a try tonight.  This was after turning on the computer and getting the orange light- no internet connection in the usual way.


    So, I set the Extreme in bridge mode, and followed those steps.  For some reason it doesn't like it and there is no connection at all when in bridge mode.


    So, I tried it back in DHCP and NAT mode on the Extreme, and hey presto the green light comes on and I have a solid connection.


    It is so strange, because I'm typing this now when online and I'm getting a great wireless signal and reliability.  I just know that, after I turn everything off tonight, in the morning I will get the Double NAT error and have to restart everything always in order to get an internet connection!


    I have looked on the Virgin Media webiste, and I have gone into the Virgin Media Superhub settings online, but when in Modem only mode there doesn't seem to be any settings to alter what I have from the modem side of things. 


    I guess I'm stuck with this? 


    Are there any other advanced settings on the Extreme I should look at?  Eg checking the dhcp values, dns server numbers (none of which mean anything to me!!)


    Thanks again

  • Bob Timmons Level 10 Level 10 (93,610 points)

    From your description....and an online check.....the SuperHub appears to be a gateway device.....a combination modem/router in the same package.


    I understand that you have tried to configure the Hub in modem mode.


    It is apparent that the SuperHub is still providing NAT service, even though it might be configured in modem mode.  That puzzles me.


    Can you provide a model number for the SuperHub or a link to the setup manual?

  • perky29 Level 1 Level 1 (0 points)

    Thanks Bob. 


    Got in today and Internet not working at all due to the double nat problem, am writing this from my phone...


    The virgin media superhub doesn't have a manual that I can see, but you're right that it is a modem and router in one - putting it into modem only mode should knock out the router function though.


    As for model no, these are the details according to the superhub:


    EU DOCSIS 3.0

    Hardware version 2.00

    Software version V5.5.2R30

    Serial no 2HA317U8050F9


    Any help is massively appreciated as I am going mad!

  • Bob Timmons Level 10 Level 10 (93,610 points)

    putting it into modem only mode should knock out the router function though.

    But it is clear that it doesn't.....so my opinion would be that the SuperHub cannot function as a true bridge mode modem. Virgin support might be able to confirm on that. 


    Unfortunately, based on all the information we have at this point,  if you want to eliminate the Double NAT error, it is the AirPort Extreme that will need to be configured in Bridge Mode. The Virgin gateway goes back to its normal role of a modem/router.


    The only other option that I can think of....if you want to run the AirPort Exteme as the router.... is to replace the Virgin SuperHub with a true modem.....not a gateway type of device that provides both modem and router functions.

  • JBF80 Level 1 Level 1 (0 points)

    I had a similar problem trying to use my Asus N66U as my primary router - the Superhub was still performing NAT and DHCP in modem mode (wireless was disabled).  This meant the N66U got an 'internal' IP address on the WAN interface - I had previously changed the Superhub internal LAN range to 192.168.12.x and the N66U WAN IP was so clearly modem mode wasn't acting as a modem but still a router.


    This was resolved by performing a reset on the superhub.  First I powered off the N66U.  Then reset the superhub by poking in the reset button for 20-30 seconds until it rebooted.  Once rebooted I connected and went straight to settings to enable modem mode.  Once the superhub had rebooted in modem mode I powered on the N66U.  It worked correctly and my N66U now has a real Public IP address on its WAN interface.  I also noticed that the superhub could now only be accessed via (as documented by virgin).  Previously it responded on that address as well as which was it's LAN IP whilst in router mode.


    From the discussion above it sounds like you have a similar problem.  I don't know if this was because my superhub didn't like that I'd changed the internal LAN subnet to 192.168.12.x rahte rthan the default (which clashes with a remote network I dial in to).  Worth anyone else having similar issues giving this a go.

  • benbookpro Level 1 Level 1 (0 points)

    Hi Perky, i am also having a similar problem and have exactly the same hardware. Did you resolve this?