2 Replies Latest reply: Jul 10, 2012 4:13 AM by French Roast
Pierre-Yves 1 Level 1 Level 1 (5 points)

In order to have an easy overview of dhcp connected clients, I have set the "client id" field in the DHCP tab of the Network Preferences (for wired and wireless interfaces). I have done that on all my idevices (iMacs, iPhones, iPad). The result is quite annoying : for one of my iMacs (all iMacs are under Lion except one under SL) the DHCP client id reported by Airport utility (v5.6) is exactely what I have manually set (and I can have a different id for the wired and wireless I/F). For all others iMacs the client id I have set is replaced by the computer name as defined in the Sharing prefs (with spaces replaced by dashes); for those computers, the displayed client ids are the same for both wired and wireless interface whatever I put in the Client Id field.

My only clue is that the only iMac for which things are working as expected is the newer oner that have been bought with SL and upgraded to Lion. Others Macs where first Tiger Macs that have been upgraded to Leopard then SL and finally Lion for most of them).


But that's not all. When I started "debugging" this behaviour, I noticed that none of my portable devices where identified by their client id. After reading some posts in this forum, I discovered the required settings for iPhone & iPad : It worked : the client id displayed in the Airport utility was exactely the one I specified. But few hours later, the client id name of most my iPhone/iPad was changed into the device name (given in iTunes) (again with spaces replaced by dashes).


Quite difficult to give a general rule (in addition, Airport Utility v6 which only shows wireless client id have a different behaviour...).


Why do I want to use DHCP through client ID ? Because using using DHCP through MACaddress while using Bootcamp gives the same IP address to Bootcamp and Lion which is an unwanted behaviour for me.



If someone has clue, your welcome ;-)

Time Capsule 802.11n (4th Gen)
  • normanfromnsw Level 1 Level 1 (0 points)

    Hi Pierre,


    I know this is an old thread but you might be interested in my experience. I've just gone through the whole dhcp id thing and finally got it soretd out last night. I know my solution doesn't reflect what is supposed to happen but at least it's working and I now have accurate names showing in Airport utility.


    Here's what I'm doing:


    On computers - make sure the name you want to appear in Airport Utility is in the sharing/ 'Computer Name' fileld. Yes, I know it's supposed to come from the TCP/DHCP ID field in the network/advanced settings - but it doesn't! Also, make sure there are no apostrophies (') as it doesn't seem to like them. I have opted for simple alpha/numeric names and no spaces.


    On iPhones and iPads it is getting the name from the system settings/general/about/Name field at the top of the page. Again alpha/numeric names and no spaces, they only get replaced with hyphens anyway.


    With this set-up I am getting all the correct names showing in Airport utility immediately when someone connects. I've got 3 iPads, 3 iPhones, 3 computers all working. The only difference in my setup is that I'm reserving IP addresses by mac address rather than id and I don't know if that makes any difference.


    Hope this helps you and anybody else trying to figure this out - I've been at it for days!

  • French Roast Level 1 Level 1 (0 points)

    My Airport Utility used to show the DHCP Client IDs of all connections until I changed the Computer Name.


    What I found, atleast in my case, is that the DHCP Client ID instead of the computer name will be displayed if the computer name is atleast 16 characters long and atleast one of those is a "-" (dash) or a space.


    Reading about how it worked for your iPad only temporarily makes me think that I'm on the wrong track.


    My posting about this: Changed Computer Name: Now DHCP Client IDs Do Not show in Airport Utility


    If you can confirm what I found, then I may feel a little relief.