5 Replies Latest reply: May 5, 2012 5:04 AM by nigel52
nigel52 Level 1 (0 points)

I have built a charity website for the Gurkhas   www.2ndgoorkhas.com  there is a secure members area which requires the member to put in their email address and password.  One particular elderly member with an 9 month old Apple Mac running latest version of Safari finds that when he puts his email and password in and hits 'Sign In' the input lines go blank.


The software is Serif Webplus X5 and is working with Windows and IE and most other Apple Mac/Safari users.  I am not an expert in the Mac/Safari environment and have remotely logged on to this members machine and cannot see anything obvious.


I and Serif have both tested the particular webpage with Safari in a windows environment and several Serif Forum users who are Mac users have tried the page with no problems.


I have been told that this is the forum where all the Apple experts reside who may be able to help me.  I certainly hope so as this elderly gentleman would love to get on his Regimental site.


many thanks


PowerBook, Safari
  • b noir Level 9 (72,060 points)

    What kind of form are you using for the Login, Nigel? Is it Java using dopostback, or something a bit different?

  • nigel52 Level 1 (0 points)

    The form is a standard form in a web authoring package called Serif Webplus X5.  Certainly the form has Javascript in it and therefore reequires a Java enabled browser to view properly. I don't know what dopostback is I am afraid.


    regards NIgel

  • b noir Level 9 (72,060 points)

    Okay. If there's Javascript involved, the follwig workaround is worth a try.


    Perhaps switch to a different user agent prior to visiting the site (perhaps try one of the iOS ones):



    Safari user agents.png


    To get access to the User agents via the Develop Menu, go into your Safari advanced preferences and select "Show develop menu in menu bar":


    Show develop menu in menu bar.png


    If he can enter his password while using a different user agent, log out again, and try going in using the default 5.1.5 user agent. Does 5.1.5 perform properly with the field now?

  • nigel52 Level 1 (0 points)

    Thank you for your suggestions - I am awaiting the return of the person I am trying to support before trying out your suggestions.  When I have tried these I will let you know how it went. Again thank you for helping.

    regards Nigel

  • nigel52 Level 1 (0 points)

    Hi tried all your suggestions which unfortunately did not work.  Ended up going through all the Safari options and found that if I clicked the option for User names and passwords it worked. I tried so many things that I am pretty sure that was the one that seemed to do the trick. I also clicked enable pop-ups but not sure about that one.  Problem is I do not have a Mac to practice on and had to do this whilst remotely supporting an elderly member user of the website I support.


    Thanks for your help.