Previous 1 2 Next 16 Replies Latest reply: Apr 30, 2012 7:08 PM by computerdummi
computerdummi Level 1 Level 1

just purchased airprint printer....was able to connect it wirelessly to both my mac laptop and windows desktop, but ipad2 and iphone are not able to find the airprint printer? Printer is a canon pixma mx432...on the list for airprint


iPad 2 Wi-Fi
Solved by John Galt on Apr 30, 2012 7:17 AM Solved

So is the firware something that installs on the printer itself?

 

Yes. You will not need Windows (the horror!) if you have a Mac. However, it can't be installed using an iPad alone.

 

Click here:

 

which is this ridiculously long link

 

http://www.usa.canon.com/cusa/consumer/products/printers_multifunction/office_al l_in_one_inkjet_printers/pixma_mx432?CMD=MIXED_SEARCH&mName=PIXMA+MX432&mType=PI XMA+MX&pageKeyCode=ekbresults&searchString=mx432+firmware&BASIC_SEARCH_CURRENT_T OPIC_ID=2653&BASIC_SEARCH_CURRENT_TOPIC_TYPE=0&RESULTS=RELEVANCE&RELEVANCE_START =1&RELEVANCE_COUNT=10&CONFIGURATION=1011&PARTITION_ID=1&TIMEZONE_OFFSET=null&USE RTYPE=1&isSecure=false

 

and read the second and third articles:

 

Screen Shot 2012-04-30 at 10.04.15 AM.png

 

The first one says this - referring to the nozzle test:

 

Screen Shot 2012-04-30 at 10.16.17 AM.png

 

So it must be installed while connecting it with a USB cable. Don't know if that will fix things but AirPrint is supposed to work.

Reply by John Galt on Apr 29, 2012 9:45 PM Helpful

...  Would it be able to work with my mac laptop wirelessly if airprint didn't work?

 

Yes, they are separate functions. I can't find any reason your 2wire should not work.

 

Oddly enough this is from Canon's specifications for that printer:

 

  1. Printer firmware update may be necessary for AirPrint function. Certain exception may apply. AirPrint functionality requires an iPad, iPhone 3GS or later, or iPod touch 3rd generation or later device running iOS 4.2 or later, and an AirPrint-enabled printer connected to the USB port of your Mac, PC, Airport Base Station, or Time Capsule is not supported.

 

"Certain exception may apply" ...? Not helpful.

 

Then, the bold text makes no sense. Are AirPort Base Stations supported or not? If the conjunction "and" were to be removed and a new sentence started with the following word "an" it would make slightly more sense.

 

Anyway, go to Canon to determine if it's a printer firmware upgrade you need.

All replies

Previous 1 2 Next