Previous 1 2 3 4 Next 112 Replies Latest reply: Feb 3, 2016 6:34 PM by jimoase Go to original post
  • uncleross Level 1 (0 points)

    I'm on an iMac with wireless track pad. The darned thing opens everything I scroll accross! I am constantly fighting with drop  downs that I don't click on! Appreciate any ideas. . .

     

    iMac, OS 10.8

  • Pedronsky Level 1 (0 points)

    I'm having the exact same issue on a Mac mini mid 2010 with a Magic Trackpad on OS X 10.8. I tough at first it was the trackpad but now I'm starting to think that is OS X 10.8. And same as unclesross we appreciate any idea!

  • shamanross Level 1 (0 points)

    It was acting up for a while before 10.8 so, I don't think the OS is it. I get so tired of deleting emails just because I scroll over them!

  • filipecamargo Level 1 (0 points)

    Same problem here on my MC516LL/A (Macbook Core 2 Duo) with 10.7.4. It's started today!

    Nothing above discribed has solved my problem. Either any reset nor pressure on trackpad.

    Any other hint?

    Thanks

    Im typing from my Ubuntu Acer cause my macbook is unusable...

  • ims20 Level 1 (0 points)

    Hi, tried reseting PRAM and PMU. Tried putting pressure on trackpad, helps for a few seconds, then problem came back. Then i noticed a few post on web about dust around the edges of trackpad. My two year old daughter had her fingertips on my macbook pro before this problem started a few weeks ago. I used my fingernail around the edges of the trackpad.... worked.

  • Mewnor Level 1 (0 points)

    Tried all of the above and my trackpad on my Macbook Pro is still under a mind of its own.

     

    It renders the machine useless.

     

    It happened the day after I upgraded to Mountain Lion and that can't be a coincidence.

  • shamanross Level 1 (0 points)

    Sounds like we may be looking at a couple of issues - dirty trackpads on iBooks for one. I however, am on a magic Trackpad with my iMac. I can, as I said, simply scroll over emails and delete them, as I scroll accross the screen I am greeted by endless drop downs that I don't click for and God forbid I should scroll across a web site with ads!

  • Megansbob Level 1 (0 points)

    Hi,

    I have a mid 2010 Macvook pro 13 inch, I have just upgraded gone to Mountain Lion and the trackpad has developed a mind of its own, the cursor will not go where you want it and the screens keep chnaging of its own accord. How do you get rid of Mountain Lion and go back to Snow Leopard or Lion?

  • therealhershey Level 1 (10 points)

    Same thing for me!  2011 MBA 13.  For a week after upgrading to ML, everything was great, then gestures stopped working once or twice until I restarted, or killed the Dock via Terminal.  But the past couple of days, the trackpad has been completely possessed, with a mind of its own!  Resetting the PRAM/SMC hasn't helped; killing the Dock, nor restarting help anymore, it just comes and goes from one minute to the next.

     

    I'm about ready to throw it out the window, because even with a Magic Mouse and wireless keyboard, it's nearly impossible to get any sort of work done!  I guess I'll try reinstalling ML...

  • Alny Level 1 (0 points)

    This worked for me:

     

    I cleaned the track pad thoroughly with a slightly windexed paper towel, running fingernail along the edge to remove any dusty/oily buildup.

     

    There may be more than one issue in this thread, however. I'm still on Snow Leopard :/

     

    Good luck!

  • crazedllama Level 1 (0 points)

       Here is a cautionary tale regarding trackpad performance:

     

    I, like many people that post on this topic, had never a single issue with my trackpad performance.   Last night after dinner, I was working and then went for an early evening run in the Texas heat.   I returned, and finished an email that I was writing.   When I went to move the cursor up from the gmail text body so that I could send it, the usual behavior didn't take place.   The cursor was "stuck".  When I moved my finger, it either remained stubbornly in place, or just did a little annoying "wiggle".   With great effort I could get it to move in the direction that I wanted.   But then it might jump halfway across the screen, and then open whatever applications were in its path.   It deleted the email text body.   Ultimately, I rebooted.   Same problem.    Cleaned trackpad.   No better.   Did online reading.   Reset PRAM.   Rebooted.   It worked for a bit - maybe five minutes and then pooped out again as I was writing an email.   Decided it had to be Firefox.   Rebooted.   PRAM reset again.  Worked for a while - maybe ten minutes this time - and I tried sending an email in Safari.   Worked.  But then it got stuck again.   I went to bed, and read on my iPad about this problem.    Read about the "pushing on the trackpad for a bit" approach. 

     

    Woke up this morning, and went to the coffee shop to work.   Rebooted, and skipped the PRAM thing.    Pushed on trackpad for a bit.  Worked now quite well.  Maybe ninety minutes.    Again, it pooped out during email composition.   Came to work, and cleaned trackpad again.   Pushed a bit.   It has been working all day, just like it did before this bizarre interlude.

     

    My conclusion is this:   I went running last night, and it was about 98 degrees outside.   When I came back in, I went immediately to my email and left a fair amount of sweat on my trackpad.   I remember even wiping it off, as similar things often cause brief trackpad troubles and did, just as I moved the cursor to resume the email.   But it was thirty minutes later that I tried to send it and found myself stymied.   I think that the two washings, and just general dilution via contact with a normal, unsweaty pair of fingers throughout the day finally "fixed" this problem.   The morale of the story is that the capacitive surface is a very delicate thing.   Probably the best "cure" I read last night on my iPad was a thorough cleaning.   I now strongly recommend that approach.

     

    And I thought my MBP has a virus.

  • therealhershey Level 1 (10 points)

    I cleaned my trackpad and blew the cracks out with compressed air, neither of which seemed to help, so I reinstalled ML, and the trackpad imediately did it after booting for about 5 minutes, but since then, it's been fine.  This is the strangest thing I've ever encoundered with an Apple product.

  • Babio Level 1 (0 points)

    I'm Having the same problem everybody is having. This never happened before I upgraded to Lion OS X and I honestly believe this is a software glitch in Mountain Lion! Apple Please Hurry And Fix This ****!!! I Am A Dj And I Have Been A Victim Of This While At Gigs!!!! HELP!!!

  • mstyles@me.com Level 1 (0 points)

    My wife's mid-2009 Macbook Pro had this issue.  Resetting PRAM and PMU only temporarily fixed it.  We tried cleaining it off and applying pressure and sometimes that worked and sometimes it didn't.  I then upgraded to Mountain Lion and it started working fine.  This is really puzzling, but I do not think it is a software glitch...at least not with Mountain Lion. 

  • ASKofman Level 1 (0 points)

    Today:                      Erratic trackpad (13 inch MacBook Pro)

    Since installing SL:    Battery life issues

    Not smart enough to know what is causing either issue and/or if they are related

    I can live with the second (by pluggin the machine in) but the trackpad makes the computer unusable

    Any advice would be very much appreciated

Previous 1 2 3 4 Next